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Preface 1
Purpose of this documentation 

Getting Started - Part 1 gives you an initial overview of the PCS 7 process control system, 
enabling you to create a simple project yourself. You can configure the project on an existing 
SIMATIC PC station. 
Getting Started - Part 1 is intended for newcomers to PCS 7 who work in the following areas: 
● Configuration 
● Commissioning and service 

Required basic knowledge 
You should already have knowledge in the following areas: 
● Microsoft operating system Windows XP, Windows Server 2003 
● Functions and configuration of SIMATIC S7 (S7-400, STEP 7) 
● Functions and configuration of SIMATIC NET (network components, transmission media) 

Validity of the documentation 
This documentation is valid for the software package Process Control System; PCS 7 
Toolset V7.0 SP1. 
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Guide 
Getting Started - Part 1 explains the individual steps required to create the "color_gs" project. 
You will find the most important background information required to understand the steps in 
this Getting Started as well as detailed instructions on how to work through them. 
Additionally, we provide you with the completed "color_gs" project as an example project. 
This is installed along with the system documentation of PCS 7.  You open this project on an 
existing engineering station (ES) in order to view the configuration data and compare the 
data with your own configuration data. You activate the project on an operator station (OS) in 
order to control and monitor the process. 
 

 

 Note 
To test the example project in process mode, the hardware configuration of the project must 
correspond to your actual hardware configuration. If necessary, replace the hardware 
components of the example project with the actual hardware components present. 
You can find additional information about opening and adapting the example project under 
"Starting and adapting the example". 

 

Conventions 
In this Getting Started, all the instructions are given using their full menu commands. You 
can also activate the majority of functions via the context menu or by double-clicking.  

 

 Note 
In this documentation the designations of elements of the user interface are specified in the 
language of this documentation. If you have installed a multi-language package for the 
operating system, some of the designations will be displayed in the base language of the 
operating system after a language switch and will, therefore, differ from the designations 
used in the documentation. 
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In PCS 7, you can use standard Windows functions in many situations: 
● Multiple selection using the <CTRL> and <SHIFT> keys 
● Column sorting in tables by clicking on the column header 
● Use of drag & drop instead of copy and paste 
If you open the HTML version of Getting Started, you can run video sequences. You can 
follow along step-by-step in these video sequences. Video sequences are indicated by the 
following icon: 
Video 

 
 

Click on the word "Video" to start a video sequence. You start and stop the video sequences 
using the corresponding commands in the context menu. 
The individual tutorials in Getting Started build on each other so that you will create your own 
complete PCS 7 project step-by-step. For this reason, you should work through all the 
tutorials in the specified sequence. 

PCS 7 glossary 
A PCS 7 glossary which contains the definition of important technical terms used in the 
documentation is available on the DVD SIMATIC PCS 7; Manual Collection or in the 
SIMATIC Manager Online Help system within the PCS 7 software (menu command Help > 
Topics > "Glossary" button). 

Additional information 
You can find detailed background information and general context in the following manuals, 
which you can use for reference purposes:  
● Process Control System PCS 7; Operator Station 
● Process Control System PCS 7; Engineering System 
These manuals are stored as follows: 
● As PDF files on the DVD "PCS 7 Engineering Toolset V7.0 SP1" 
● In the PCS 7 software of the SIMATIC Manager. 

Select the menu command Start > SIMATIC > Documentation > [required language] to 
open these files. 

If you wish to familiarize yourself with specific topics in greater depth, refer to the appropriate 
manuals, for example, for SFC and CFC. 
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Additional support  
If you have further questions about the use of products presented in this manual, contact 
your local Siemens representative:  
A list of Siemens representatives is available at:  
http://www.siemens.com/automation/partner  
A guide to the technical documentation for individual SIMATIC products and systems is 
available at:  
http://www.automation.siemens.com/simatic/portal/html_00/techdoku.htm  

Training center  
We offer courses to help you get started with the S7 automation system. Contact your 
regional training center or the central training center in D 90327 Nuremberg, Federal 
Republic of Germany.  
By phone: +49 (911) 895–3200  
Internet: http://www.sitrain.com 

Technical Support  
You can contact Technical Support for all A&D products  
● using the Support Request Web form  

http://www.siemens.com/automation/support-request  
● By telephone: + 49 (180) 5050-222  
● By fax: + 49 (180) 5050-223  
You can find additional information about our Technical Support online at: 
http://www.siemens.com/automation/service 

Service & Support on the Internet  
In addition to our paper documentation, our complete knowledge base is available to you on 
the Internet at:  
http://www.siemens.com/automation/service&support  
There, you will find the following information:  
● Newsletters providing the latest information on your products  
● A search engine in Service & Support for locating the documents you need ● A forum 

where users and experts from all over the world exchange ideas  
● Your local contact partner for Automation & Drives in our Contact Partners database  
● Information about on-site service, repairs, spare parts, and much more under "Services"

http://www.siemens.com/automation/partner
http://www.automation.siemens.com/simatic/portal/html_00/techdoku.htm
http://www.sitrain.com
http://www.siemens.com/automation/support-request
http://www.siemens.com/automation/service
http://www.siemens.com/automation/service&support
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Requirements for Getting Started 2
2.1 Requirements for Working through Getting Started - Part 1 

Introduction 
To be able to work through Getting Started, the following requirements must be met for the 
components below: 
● Hardware  
● Software  

2.2 Required hardware for Getting Started 

Hardware Components 
The list below shows the hardware components you need to work through Getting Started 
and that we have used in the Getting Started example. For some hardware components you 
must use a specific version because it is not possible to work through Getting Started with a 
different (e.g., older) version. 

 
Hardware Component Version Used in Getting Started Other Version Possible 
PG or PC with a standard 
network card 

3Com EtherLink III IS Yes 

Rack UR2 Yes 
Power supply PS 407 10A Yes 
CPU CPU 417-4, firmware V 3.1 or higher No 
CP 443-1 6GK7 443-1 EX11-0XE0, 

Firmware V 2.0 or higher, with 
permanent MAC address 

No 

Memory card   
Crossover cable  No 

 
 

NOTICE  
To implement the configuration described in Getting Started, you must have, at a minimum, 
the CPU and the CP. 
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Use of Other Hardware Components 
If you are using other hardware components, you must enter the components you are 
actually using in the relevant places, for example, in HW Config. For the sake of clarity, we 
recommend using exactly the same components as those we have used in Getting Started. 

Using S7-PCLSIM 
If you do not have any hardware components available, you can use the S7-PLCSIM 
software that is included on the PCS 7 Toolset CD. You require a special license to use this 
software. If you use this software, you can use exactly the same hardware components as 
described in Getting Started. 

2.3 Required software for Getting Started 

Software components 
The following software must be installed: 
● Windows XP Professional or Windows Server 2003 
● Internet Explorer 6.0 (supplied) 
● Message Queuing Service 
● SQL Server 2005 
● PCS 7 software package Engineering Toolset 

If you have questions about installing the PCS 7 software, read the Readme file on the 
installation DVD or contact Customer Support. 
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PCS 7 in overview 3
3.1 Brief Overview of PCS 7 

Description 
PCS 7 is a process control system with many automatic functions to assist you during 
configuration. It enables you to create a project fast and conveniently. You will get to know 
some of these automatic functions in this Getting Started. At the same time, PCS 7 provides 
the advanced user many options for creating individual, project-specific solutions customized 
to the requirements at hand. These individual solutions are not part of this Getting Started - 
you can find additional information about these in the configuration manuals once you are 
familiar with the basic functionality. 

What is a PCS 7 project? 
Among other things, a PCS 7 project includes the following objects: 
● Hardware Configuration 
● Blocks 
● CFC charts and SFC charts 
These objects are always included - regardless of the number of operator stations, modules, 
and networking. 
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3.2 What Is Included in PCS 7? 

PCS 7 Applications 
You create the project on an engineering station (ES). Various applications are available on 
the ES. All applications provide you with a graphic user interface for simple operation and 
clear display of your configuration data. When you work through Getting Started, you will get 
to know the following applications: 
● SIMATIC Manager is the central application and gateway to all other applications that you 

use to create a PCS 7 project. SIMATIC Manager is the starting point for creating your 
entire project. 

● HW Config contains the configuration of the entire hardware of a system, for example, 
CPUs, power supply, communications processors. 

● CFC editor and SFC editor are the editors you use for creating CFC charts and 
sequential control systems. 

● PCS 7 OS with various editors is the tool you use for configuring the OS 

3.3 What is SIMATIC Manager? 

SIMATIC Manager 
SIMATIC Manager represents the central application within the PCS 7 system and is used to 
access all the other applications you need to configure your PCS 7 project.  
The SIMATIC Manager and all other applications are "linked": This is why you also see all 
blocks you have inserted into an CFC chart with the CFC editor in the SIMATIC Manager, for 
example.  
Another great advantage of this link becomes clear when configuring the operator station: 
You have convenient access to all the data you have created in the SIMATIC Manager and 
the applications it includes. For example, you can visualize a process tag from a CFC chart 
quickly and easily when configuring the OS. 
Due to the central function of SIMATIC Manager within PCS 7, it is worth taking time to 
become familiar with its structure and functions. 

3.4 What is the Basic Structure of SIMATIC Manager? 

Structure of SIMATIC Manager 
SIMATIC Manager has a split window similar to Windows Explorer: 
● In the left-hand window you will see a tree structure which displays different content 

depending on the View selected. 
● In the right pane, the detailed window, you can see details of the object you have 

selected in the tree structure. 
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3.5 What Do the Views Signify in SIMATIC Manager? 

Meaning of the Views 
SIMATIC Manager provides you with three different views. An important feature of these 
views is that the objects they contain exist only once in reality but can be displayed and 
edited in the various views.  
The structural principle of the views is the same:  
The left pane displays the tree structure and the right pane displays the detail view. Each 
view offers advantages for performing certain tasks: 
● Component view – this view represents the physical memory location of the individual 

objects, for example, of the charts and blocks. In the Component view, you can see 
immediately which blocks and charts belong to which AS. 

● Plant view – this view shows the exact hierarchical structure of your plant. You can divide 
the plant into units and see which charts and which process pictures belong to which unit. 

● Process object view – this view shows details of the individual objects from the plant view. 
This is particularly suitable when you want to assign the same parameter values to a 
large number of objects or if you want to add the same comments or make the same 
interconnections for these objects. 

In the step-by-step instructions in Getting Started, you are always told which view you should 
be working in.  
All the work that you perform in SIMATIC Manager is saved automatically by PCS 7. 
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3.6 Procedure 

3.6.1 How to Open SIMATIC Manager 

Procedure 
You can start SIMATIC Manager in two ways: 

 
Option Procedure 
 1 Double-click the STEP 7 icon on your desktop. 

 
 2 To start SIMATIC Manager, go to the Windows task bar and select the Start > 

SIMATIC > SIMATIC Manager command. 

When you start SIMATIC Manager, the project you last opened is automatically opened 
again.  
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Initial work for the project 4
4.1 Planning the project 

4.1.1 The "color_gs" Project 

Introduction 
After the initial theoretical introduction (Page 15) to PCS 7, you will now work 'hands-on' to 
create the "color_gs" project. Detailed step-by-step instructions are provided to assist you. 
To facilitate your understanding of the step-by-step instructions, some additional theoretical 
knowledge is necessary. Therefore, we will provide you with the most important background 
information for each topic. 

Plant Description 
We will only configure a small part of the entire plant for fully automatic dye production since 
configuring the entire plant would be beyond the scope of this Getting Started project. 
However, you should understand how this small part is integrated in the overall plant in order 
to better understand the total context. The following is a summary of the individual phases of 
the production process: 

Phase I - Raw Materials 
The liquid raw materials for the product are stored in two raw material tanks and are pumped 
from these tanks to the reactors. The solid raw materials are stored in three silos. Screw 
conveyors are used to measure out the solid raw materials from the silos to a weigh hopper 
for weighing. Another screw conveyor and a blower are used to blow the raw materials into 
one of the two mixing tanks in the correct mixing ratio. 

Phase II – Production 
The required quantities of liquid material are fed from the two raw material tanks to Reactor 1 
or Reactor 2 by means of valves. The solid materials from the mixing containers are 
transported via screw conveyors to the reactors where they are blended using an agitator. 
The product is produced in the reactors by agitating, heating and cooling the raw materials 
together with the additives. Valves and actuators control the temperature in the reactors. 
When necessary, water from a filtration plant can be introduced into the reactors using a flow 
controller. 
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Phase III - Holding Phase 
The product is pumped to a holding tank for postprocessing. Here, it is stirred slowly and 
kept at a constant temperature. 

Phase IV – Filling 
After the holding phase, the product is temporarily stored in a filling tank. From there, it is 
filled into bulk-tank trucks or small packing drums. 

Phase V – Cleaning 
The reactors, piping, valves, actuators, holding tank, and filling tank can be cleaned by a 
cleaning-in-place (CIP) system. The resulting wastewater is collected in a separate effluent 
tank and disposed of. 
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4.1.2 Task list for Getting Started 

Specific Configuration Task 
You will now configure part of "Phase I – Raw Materials": 
Specifically, you will configure the storage of the liquid raw materials in two raw material 
tanks and the pump control used to pump these raw materials to the two reactors. 

Piping and Instrumentation Diagram (P&ID) 
The piping and instrumentation diagram illustrates the precise sequence of the configuration 
task and shows you all of the associated relevant process tags: 
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Explanation of the Piping and Instrumentation Diagram 
The designations in the P&ID have the following meanings: 
● LI111 (level indicator) – measurement of the current liquid level in the raw material tank 
● NK111 and NK112 (customer-specific identifier for valves) – stop valves that must always 

be open when dosing raw materials. 
● NP 111 (customer-specific identifier for motors) – pump that transports the raw material to 

the reactors 
● NK 113 or NK 114 (customer-specific identifier for valves) – valves used to transport the 

raw material to either Reactor 1 or Reactor 2; only one of these valves can be open at a 
time 

● FC111 (flow control) – actuator that is used to control the quantity of raw material 
The states of valves NK111 to NK114 will be displayed on the operator station and can be 
monitored. You also have the opportunity to influence the dosing by means of FC111. 
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4.1.3 Configuration of the plant for the 'color_gs' project 

Configuration 
The "color_gs" project will be implemented on a minimum system consisting of a single 
automation system and a combined engineering station and operator station. The operator 
station is designed as a single station system. The following figure illustrates the system 
configuration. 

 
 

Description 
In Getting Started, you will build a control system containing the following components: 
● Automatision system (AS) 

The individual components are described in the section "Requirements for performing the 
Getting Started". 

● Program, which controls the "color_gs" plant.  
You create this program in the ES and download it to the CPU. The CPU executes the 
loaded program and shows process values to you. You load the program via the CP 443-
1. 

● Operator station (OS) on which the plant operator controls and monitors the plant during 
runtime. You yourself create the process picture seen by the plant operator on the OS. 
The AS is connected to the OS via the CP 443-1. 
 

 

  Note 
Note that the plant configuration and hardware settings that result from it need to be 
espeically adaoted the the requirements of this Getting Started.  
When configuring a real project, you will surely use more automation systems and also 
operate the engineering station and operator station(s) on several computers. The 
hardware settings will then be more complex, in any case, and will no longer correspond 
to the descriptions in the Getting Started. 
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4.1.4 Overview of Configuration Tasks 

Configuration Sequence 
You configure the system components in the following configuration steps: 
● Setting the Parameters for the Network (Page 25) 
● Creating the Project (Page 28) 
● Configuring the Stations (Page 38) 
● Working in the Plant Hierarchy (Page 51) 
● Creating CFC Charts (Page 63) 
● Creating SFC Charts (Page 115) 
● Compiling, Downloading, and Testing Charts (Page 143) 
● Configuring operator stations (Page 155) 
● Creating the Process Pictures (Page 171) 
● Working in Process Mode (Page 199) 
● Performing the Additional Task (Page 213) 
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4.2 Preparational settings for the network 

4.2.1 Settings for the Network and Interfaces 

Settings 
Before starting to configure the "color_gs" project, make the following settings: 
● Network adapter settings on the configuration console 

PCS 7 automatically identifies the network adapters installed on your computer during 
startup of the station. You can use this information to program the interfaces on the 
configuration console. 
 

 

  Note 
These settings are usually made immediately after PCS 7 is installed. If you did not install 
PCS 7 yourself, you should check the settings again and make any necessary 
modifications. 

 
● Selecting the network adapter 

Select the network adapter the PC station requires to communicate with the PC station in 
this dialog. 
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4.2.2 Procedure 

4.2.2.1 How to Make the Settings in the Configuration Console 

Requirements 
● All the necessary hardware components must be inserted on the rack and switched on. 
● The crossover cable must be connected between the 3Com network adapter of your ES 

computer and the CP 443-1. 

Procedure 
1. Open the configuration console using the Windows command Start > SIMATIC > 

SIMATIC NET > Configuration Console. 
2. Go to the "SIMATIC NET Configuration/ 

Modules/ [name of the network adapter]" entry in the tree view to select the network 
adapter to be used for AS-OS communication. 

3. Select the "Address" entry. 
The address details of the selected network adapter are output to the detail view. 

4. Make a note of the "Ethernet(MAC) address" because you will need this to subsequently 
configure the hardware. 

5. Select the entry "Access points". 
6. Double-click the "S7ONLINE" access point in the detailed window.  

The "Properties of S7 Online" dialog box opens. 
7. In the "Assigned Interface Configuration" drop-down list, select the entry "PC internal 

(local)" and save your setting by clicking "OK". 
8. Set all other network adapters in your PC to the "PG mode". 
9. Close the configuration console. 
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4.2.2.2 How to select the network adapter in Simatic Shell 

Introduction 
Below, you will select the network adapter used to configure the PC stations. 

 

 Note 
If a PC station is used as a single-station system with no connection to other PC stations, the 
following configuration steps are not necessary. 

 

Procedure 
1. Select the PC station (workstation) in the tree view of Windows Explorer. 
2. Select the "Simatic Shell" folder. 
3. Select the Settings... command from the shortcut menu. 

The "Select terminal bus" dialog box opens. 
4. Select the network adapter you want to use to establish communication with the PC 

stations. 
5. Click "OK". 
6. Close the "Simatic Shell" folder. 

The communication module is reinitialized. 
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4.3 Creating the project 

4.3.1 Use of the "New Project" Wizard 

PCS 7 "New Project" Wizard 
The PCS 7 "New Project" wizard is started automatically by means of default setting when 
you open SIMATIC Manager. You can enable or disable this option in the PCS 7 "New 
Project" wizard. 
The "New Project" wizard supports you step-by-step in creating a new project and offers 
default settings. The PCS 7 wizard automatically creates various objects according to the 
default settings or the specific settings that you make.  

Objects for "color_gs" 
For the "color_gs" project, the following objects are important: 
● Hardware objects: SIMATIC stations, for example a SIMATIC 400 station for the AS, a 

SIMATIC PC station for the OS 
● Hierarchy folders representing the hierarchy levels of the plant structure. The number of 

hierarchy folders created corresponds to the setting you input in the PCS 7 wizard. 
● A CFC chart 
● An SFC chart 
● One picture per plant hierarchy folder 
● A master data library 
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4.3.2 Background knowledge for the PCS 7 wizards 

What happens in the background when a new project is created?  
The next two sections provide you with some theoretical background knowledge for the 
PCS 7 "New Project" wizard. They introduce two objects that are of great importance for 
working with PCS 7: 
● Multiproject 
● Master data library 

How does a multiproject function? 
When you create a new project with the PCS 7 wizard, a so-called multiproject is created 
automatically. A multiproject consists of a number of single projects.  
In the context of the example project, the multiproject is structured as follows: The 
multiproject represents the entire plant and all of the single projects within this multiproject 
based on the individual phases of the process for producing paint. Since you are configuring 
only one phase of the overall plant in this Getting Started, your multiproject only contains one 
single project in this case.  
Multiprojects have one major advantage: You can distribute the single projects to different 
configuration engineers who can then edit them. Once the configuration of the single projects 
is completed, these can be merged to form a complete project.  
In Getting Started, although you will be working within a multiproject, you will not be using 
the wide range of functions provided by this multiproject engineering.  
Detailed information is available in the Process Control System PCS 7; Engineering System 
Configuration Manual.  

What is a master data library? 
When you create a new project with the PCS 7 wizard, a master data library is created 
automatically. You store all the blocks required for the entire project in this library. Before 
you create a CFC chart, for example, you first store all the standard blocks you will insert in 
this CFC chart in your master data library.  
A master data library provides the following advantage:  
● When you archive a project, the master data library is automatically archived along with it. 
● You can also adapt the blocks and then reuse these adapted blocks repeatedly in the 

project. 
In the context of a "multiproject", the master data library is particularly important because it 
allows you to provide all the project engineers involved with blocks of a defined version so 
that you can be sure that only this version is used in the project. 
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4.3.3 Procedure 

4.3.3.1 How to Create the "color_gs" Project 

Procedure 
The PCS 7 wizard assists you in creating the "color_gs" project: 
1. Open SIMATIC Manager. 
2. Select the menu command File > 'New Project' Wizard... 

 The "New Project" wizard of PCS 7 opens. 

 
 

3. Click "Continue". 
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4. In Step 2(4) "Which CPU are you using in your project?", select the CPU bundle you are 
using in your project. 
Detailed information about the selected CPU bundle is displayed below the list. 

 
 

5. Click "Continue". 
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6. Make the following settings in Step 3(4) "Which objects are you still using?": 
– Select item "4" from the "Number of levels" drop-down list. 
– Under "AS Objects", check if the "CFC chart" and "SFC chart" check boxes are 

activated. 
– Activate the "PCS 7 OS" check box under "OS Objects". 

The "Single station system" option is activated automatically. 

 
 

7. Click "Continue". 
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8. In Step 4(4), enter the name "color_gs" in the "Directory name" input field and accept the 
specified storage location. 

9. Click "Preview >>" to see a preview of your current configuration status. This preview 
corresponds to the appearance of the project in the SIMATIC Manager. 
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10. Click "Finished". 
The "Message Number Assignment Selection" dialog box opens for creating the project 
and the "Assign CPU-oriented unique message numbers" check box is activated. 

 
 

11. Click "OK" to apply the setting. 
The project is completed with these settings. 
 

 

  Note 
Please note the following: 
• If the project does not open automatically, follow the instructions provided in the 

section "How to close and opent the "color_gs" project (Page 36)". 
• To activate different views, follow the instructions provided in the section "How to work 

with the various views (Page 37)". 
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Result 
The project appears now in the plant view of the SIMATIC Manager as follows: 
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4.3.3.2 How to Close and Open the "color_gs" Project 

Procedure for Closing a Project 
1. If you have other projects open in SIMATIC Manager, close these projects for the sake of 

clarity. 
2. Select the Window > [Name of Project] command and then select the project you want to 

close. 
SIMATIC Manager shows this project in the foreground. 

3. Select the File > Close command. 
The program closes the project. 

Procedure for Opening a Project 
1. Open SIMATIC Manager. 
2. Select the File > Open command if your "color_gs" project is not opened automatically. 

The "Open project" dialog box opens with active "User projects" tab. 
3. Change to the "Multiprojects" tab and select the entry "color_gs_MP". 
4. Click "OK". 

The program opens the project and the associated master data library. 
Video  

 
 



 Initial work for the project 
 4.3 Creating the project 

PCS 7 - Getting Started - Part 1 
Getting Started, 09/2007, A5E00857261-02 37 

4.3.3.3 How to Work in the Various Views 

Introduction 
Once you have opened your project in SIMATIC Manager, you can display the project in 
various views and switch between these views. 

Procedure 
1. Select the View > [Name of the desired view] command in SIMATIC Manager: 

– Component view 
– Plant View 
– Process object view 

or 
1. Select the Window > [Name of the project (name of the view)] command if you already 

opened several projects. 
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4.4 Configuring the stations 

4.4.1 Configuration overview 

Overview 
Configure the control system components which the PCS 7  "New Project" wizard has 
automatically inserted. This includes components such as the AS, the OS, and the 
associated connections.  
For this purpose you must perform the following configuration steps: 

 
Step What? 
 1 Configure AS (Page Fehler! Textmarke nicht definiert.) 
 2 Rename PC station (Page 42) 
 3 Configure OS (Page 43) 
 4 Set connection in NetPro (Page 46) 
 5 Download hardware configuration (Page 50) 

Local PC station 
With PCS 7, you can configure the computer on which you perform the ES configuration as a 
local PC station. This allows you to conveniently test the functions of external operator 
stations using the menu command Start OS Simulation, without having to download the data 
to the real OS. Compiling the OS is enough. 
The plant configuration for this Getting Started is a single station system; the ES and OS are 
on one computer. In this way, the local PC station you configure represents the ES and the 
OS at the same time. You configure a local PC station in a multiple station project in the 
same way. 
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4.4.2 Procedure 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated. 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ SIMATIC 400(1)" folder from the tree view. 
2. Select the "Hardware" object in the detail view and then select the menu command Edit > 

Open Object. 
HW Config opens and shows a view of the system hardware configuration. 

 

  Note 
Select the menu command Vew > catalog if the hardware catalog is not displayed. 
This opens the hardware catalog with active "PCS7_V70" profile. 
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3. Select the CP 443-1 and then select the menu command Edit > Object Properties. 
The "CP 443-1 Properties" dialog box opens. 

4. Click "Properties" in the "Interface" group. 
The "Ethernet Interface CP 443-1 (R0/S5) Properties" dialog box opens. 

5. Enter the MAC address in the "MAC address" input box. The MAC address is labeled on 
the CP under the cover. 

6. Deactivated the "IP protocol is being used" check box. 
This deactivates all associated input boxes. 

 
 

 
7. Click "New" to create a new network connection. The CPU communicates with the ES via 

this network connection. 
The "Properties -- New Industrial Ethernet Subnet" dialog box opens. 
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8. Click "OK" to apply all the preparational settings. 
The "Ethernet(1)" entry is entered in the "Subnet" list and is already selected. 

 
 

 
9. Click "OK". 

Your settings are applied. 
The "Properties - CP 443-1 (RO/S5)" dialog box opens. 

10. Click "OK". 
Your settings are applied and the dialog box closes. 

11. Select the menu command Station > Save and Compile. 
12. Close HW Config. 
Video  
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4.4.3 How to Rename the PC Station 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated. 

Procedure 
1. Select the  

"color_gs_MP/color_gs_Prj/SIMATIC PC Station(1)" object from the tree view. 
2. Select the menu command Edit > Object Properties. 
3. Enter the name of the local computer "Name" input box as it appears in the network. You 

can find this name in the "Station" box of the Station Configuration Editor. 
4. Activate the "Computer name identical to PC station name" check box in the "Computer 

name" area. 
The computer name is automatically entered in the lower box. 

5. Click "OK". 
Your settings are applied and the dialog box closes. 
The component view identifies the PC station symbol with a yellow arrow. 
  

 

  Note 
If the PC station is not labeled with a yellow arrow, refresh the screen display by pressing 
the <F5> key. 
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4.4.4 How to configure the PC station of the OS 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ [name of the PC station]" folder from the tree view. 
2. Select the "Configuration" object in the detail view and then select the Edit > Open Object 

command. 
HW Config opens and returns a view of the OS components. HW Config opens with the 
settings you made when configuring the AS: 
– The hardware catalog is open. 
– The "PCS7_V70" profile is active. 

3. Select this CP from the hardware catalog: 
"SIMATIC PC-Station/CP-Industrial Ethernet/IE General/SW V6.2 SP1...". 
Drag-and-drop the CP to slot 1. 
The "Properties - Ethernet interface" dialog box opens. 

4. Select the "Set MAC address/use ISO protocol" check box. 
5. Enter the address that you noted from the configuration console in the "MAC address" 

box. 
6. Clear the "IP protocol is used" check box. 
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7. Select the "Ethernet(1)" entry from the "Subnet" list box. 
This is the connection that you already configured for the CP.. 
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8. Click "OK" to save your entries. 
The program closes the dialog box and returns you to HW Config. 

 
 

9. Select the Station > Save and Compile command. 
10. Close HW Config. 
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4.4.5 How to Make Settings in NetPro 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated. 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ [name of the local computer]" object from the tree view. 
2. Select the "Connections" entry in the detail view and then select the menu command Edit 

 > Open Object.  
Net Pro opens. 

3. Select the "WinCC Applications" object at the SIMATIC PC station. 
Enter the required connection in the blank list shown in the lower detail view.. 

4. Select the first line in the lower detail view, and then select the menu command Insert  > 
New Connection....  
The "Insert New Connection" dialog box opens. 

5. Select the CPU of your project from the tree view. 
This CPU is the communication partner of the OS, that is, it receives the data of this AS. 
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6. In the "Connection" group for the type, check if "S7 Connection" is set and the Display 
properties before inserting" check box is activated. 

 
 

7. Click "OK". 
The "Properties - S7 Connection" dialog box opens and the "General" tab is selected. 
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8. Select the following connection partner for the connection between the CPU and OS: 
– Local: Interface "[Network adapter of the OS]", e.g., IE General 
– Partner: Interface "[CP of the AS]", e.g., CP 443-1 

 
 

9. Click "OK".  
The new connection is shown in the list. This connection is also displayed if you select 
the CPU for the AS. 

10. Select the menu command Network > Save and Compile.... 
The "Save and Compile" dialog box opens. 

11. Select the "Compile and check everything" check box and click "OK".  
When the compilation operation is completed, the "Outputs for consistency check" 
window opens. 

12. If the compilation was executed without errors, close the window.  
If any errors are displayed, correct them based on the information in the error messages 
and repeat the compilation operation. 

13. Close NetPro. 
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4.4.6 How to configure and download the PC station of the OS 

Procedure 
1. Switch to the SIMATIC Manager. Select the PC station and select the menu command 

PLC > Configure....  
The "Configure" dialog opens. 

2. Click "Configure".  
The "Configure: <Selected Station>" dialog box opens. 

3. To perform and apply the remote configuration, follow the instructions in the online help of 
the "Configure: <Selected Station>" dialog box. 

4. Click "OK" and then acknowledge the subseqent information window that opens with 
"OK". 
The configuration data are transferred to the PC station. 

5. When the "Transfer successfully completed" message appears, click "Close" in the 
configuration dialog. 
You must still download the network settings to this PC station in order to activate the 
network connections. 

6. Select the PC station and select the menu command PLC > Download. 
The "Delete system data completely from the automation system and replace with offline 
system data. Are you sure?" message dialog opens. 

7. Click "Yes".  
The "Stop Target Modules" message dialog opens. 

8. Click "OK".  
The download finishes. 
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4.4.7 How to download the hardware configuration of the AS 

Introduction 
After you have configured and set the hardware, you must also make this information known 
to the CPU. Download the hardware configuration to the CPU. 

Requirements 
● The CPU is in "STOP" mode. 
● The example project is open in SIMATIC Manager. 
● The component view is activated. 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ SIMATIC 400(1)" folder from the tree view. 
2. Select the menu command PLC > Save and Compile Objects.... 

The "Save and Compile Objects" dialog box opens. 
3. Activate the check boxes in the "Compile" and "Download" columns of the 

"color_gs/[SIMATIC 400(1)/Hardware" object. 
4. Click "Start". 

The message "Downloading program changes during operation can, in the case of 
malfunctions or program errors, cause serious damage to personnel and equipment! 
Make sure..." opens. 

5. Click "OK". 
The compile and download operation is executed. The log file is opened in the text editor 
when the function is completed. 

6. Close the text editor. 
7. Click "Close" in the "Compile and Download Objects" dialog box. 

The dialog box closes. 
8. Start the CPU. 
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4.5 Working in the PH 

4.5.1 Settings in the Plant Hierarchy 

Plant hierarchy 
Once again, it is time for a little theory: 
The plant hierarchy (PH) maps the hierarchical structure of your plant exactly, for example, 
the plant, unit or function. The PH provides you with a variety of possible settings, the most 
important of which are described here: 
● Number of hierarchy levels: 

The nesting depth of these levels is determined by the plant structure. Rule: the more 
complex the plant structure the higher the number of hierarchy levels you require to 
reflect your plant structure. With the PCS 7 wizard, hierarchy folders with default names 
are created according to your specification. 

● Determination of the hierarchy level(s) which influence the name of plant ID (HID): 
The PCS 7 project contains many instances of the HID: Messages generated in the 
active process and tag names contain this HID in order to allow operators to quickly 
recognize a specific plant unit associated with a message or tag. Rule: the more 
hierarchy levels you define and the longer each individual HID part is, the longer and less 
recognizable the entire HID becomes. 

● Deriving the picture hierarchy from the PH: 
The process pictures are grouped in a specific hierarchy: This allows you to change from 
an overview picture to a lower level picture in process mode. The subordinate pictures 
represent a portion of the overview picture that is accurate in every detail. The hierarchy 
of the process pictures corresponds to how the process pictures are stored in the plant 
hierarchy. 
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4.5.2 How to Perform the Settings for the PH 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj" hierarchy level in the tree view. 
2. Select Options > Plant Hierarchy > Settings.... 

The "Customize Plant Hierarchy" dialog box opens for you to set the PH options. 
3. Enter the value "4" in the "Number of hierarchy levels" box. 

This setting allows the definition of up to four hierarchy levels. 
4. Enter the value "10" in the "Max. number of characters" input box for all four hierarchy 

levels. 
This setting limits the length of the HID string to 10 characters per hierarchy level. 

5. Select the "Included in HID" check box for levels 1 and 2. 
6. Select the "OS area" option for level 2. 
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7. Activate the "Derive picture hierarchy from the plant hierarchy" check box. 
Subsequent appearance of the dialog box: 

 
 

8. Click "OK" to save your entries. 
The "You have changed the "Included in HID" property. Do you also want the changes to 
apply to existing hierarchy folders?" message is output. 

9. Click "Yes" in the message box.. 
The program saves all settings. 



Initial work for the project  
4.5 Working in the PH 

 PCS 7 - Getting Started - Part 1 
54 Getting Started, 09/2007, A5E00857261-02 

4.5.3 Structure in the Plant View 

Plant hierarchy of the example project 
You already specified four hierarchy levels with the PCS 7 "Create new project" wizard. As a 
result, you will find the following hierarchy folders in the tree view of your project: 
● Process cell - level 1 
● Unit - level 2 
● Function - level 3 
● Device - level 4 
The names of the hierarchy folders are default names assigned automatically by PCS 7 
when the project is created. 
For your "color_gs_MP" project, you must, adapt this structure to the individual requirements 
of the "color_gs"  project, change the default names, and insert new hierarchy folders. This 
provides you with a clear structure and makes it easier to navigate through your project. You 
can also treat all the objects as individual units. 
In Getting Started we have specified the following hierarchy folder names for the various 
components of the plant: 

 
Default name Hierarchy folder Technological assignment 
Plant Plant1 Complete plant 
Unit RMT1 Raw material tank 1 
Function FC111 Flow control (dosing) 
Function LI 111 Level indicator for raw material tank 1 
Function NP 111 Pump control 
Function NK 111 Valve control 
Function NK 112 Valve control 
Function NK 113 Valve control 
Function NK 114 Valve control 
Device ADDIT Auxiliary chart for specifying setpoints 
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4.5.4 How to Adapt the Default Names 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure for renaming the "Plant" folder 
1. Select the hierarchy folder "color_gs_MP/color_gs_Prj/Process cell(1)". 
2. Select the menu command Edit > Object Properties.... 

The "Properties - Hierarchy Folder" dialog box opens and the "General" tab is selected. 
3. Enter the name "Plant1" in the "Name" box. 

 
 

4. Click "OK" to apply your settings. 
The dialog box closes and the name of the hierarchy folder is changed to "Plant1". 

Video  
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Procedure for renaming the "Unit" folder 
1. Select the hierarchy folder "Unit (1)". 
2. Select the menu command Edit > Object Properties.... 

The "Properties - Hierarchy Folder" dialog box opens and the "General" tab is selected. 
3. Enter the name "RMT1" in the "Name" box. 
4. Switch to the "Control and Monitoring Attributes" tab. 

The "No modification when renaming the hierarchy folder" check box is deactivated by 
default. This ensures that the text for the OS area ID is always changed according to the 
name of the hierarchy folder. 

 
 

5. Click "OK" to apply your settings. 
The dialog box closes and the name of the hierarchy folder is changed to "RMT1". 
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Procedure for renaming additional folders 
1. Select the hierarchy folder  

"color_gs_MP/ color_gs_Prj/Plant1/RMT1/ Funktion(1)". 
2. Select the menu command Edit > Object Properties. 

The "Properties – Hierarchy Folder" dialog box opens. 
3. Enter the name "FC111" in the "Name" box. 
4. Click "OK". 

Your settings are applied and the dialog box closes. 
5. Select the folder  

"color_gs_MP/ color_gs_Prj/Plant1/RMT1/ FC111/ Device(1)". 
6. Select the menu command Edit > Object Properties. 

The "Properties – Hierarchy Folder" dialog box opens. 
7. Enter the name "ADDIT" in the "Name" box. 
8. Click "OK". 

Your settings are applied and the dialog box closes. 
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4.5.5 How to Insert Additional Hierarchy Folders 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "RMT1" folder. 
2. Select the Insert > Plant Objects > Hierarchy Folder command. 

The program generates new hierarchy folder named "Function [consecutive number]". 
3. Change the name to "LI111". 
4. Press the ENTER key 
5. Repeat steps 1 to 4 to create additional hierarchy folders: 

– NP111 – motor control 
– NK111 – valve control 
– NK112 – valve control 
– NK113 – valve control 
– NK114 – valve control 
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Result 
Your plant hierarchy should now look like this:  
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4.5.6 How to Check the Assignment of AS/OS to the PH 

Assignment of the hierarchy folders 
The individual components of the plant are assigned to specific automation systems and 
specific operator stations. Each hierarchy folder of the plant hierarchy is given exactly this 
information. This is only important if you have more than one automation system or operator 
station in your project.  
In the "color_gs" project, you have only one automation system and one operator station. As 
a result, all the hierarchy folders are automatically assigned.  

Procedure for checking the assignment 
1. Select the "RMT1" hierarchy folder and then select the menu command Edit > Object 

Properties. 
The "Properties - Hierarchy folder" dialog box opens. 

2. Select the "AS-OS Assignment" tab. 
Assignments in this tab: 
– In the "Assigned AS (chart folder)" list, you will see the automation system that 

processes the data. 
– In the "Assigned OS" list, you will see the operator station on which the data are 

displayed. 
3. Close the dialog box. 
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4.5.7 The Current State of your Project 

Completed Configuration Tasks 
Up to now, you have made the following settings for your project: 
● You have created the "color_gs" project in SIMATIC Manager. 
● You have configured the hardware components in HW Config. 
● You have downloaded the hardware configuration from HW Config to the CPU. 
● You have entered settings in the plant hierarchy. 
● You have mapped the plant structure of the "color_gs" project in the plant hierarchy. 
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Creating CFC charts 5
5.1 CFC Charts and the CFC Editor 

The Theory -- What are CFC Charts and What is the CFC Editor?  
The overall process of a plant is described by continuous sequences. For this purpose, you 
must create CFC charts in the CFC Editor of PCS 7.  
You create CFC charts by inserting blocks from the PCS 7 Library V7.0 into the charts. 
These include single blocks, for example, blocks for closed-loop control of a process or for 
monitoring measured values. The inputs and outputs of these blocks are then interconnected 
and assigned parameters directly in the CFC Editor. The user-friendly graphic user interface 
of the CFC Editor assists you in this task. 
PCS 7 also provides process tag types in the standard library. They represent full CFC 
charts for various process tags such as motors and valves. 
You retrieve the CFC charts in the plant hierarchy. To keep the structure of the project clear, 
the CFC charts are always stored in the hierarchy folders according to their relevance in the 
process. 

Identification of CFC charts 
CFC charts are identified by the following icon leading their name:  
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5.2 Working with libraries 

5.2.1 CFC Charts and the Master Data Library 

A brief theoretical introduction to the master data library 
When creating CFC charts, you are working with the master data library. DO NOT copy any 
blocks and process tag types directly from the PCS 7 standard library to the CFC charts of 
your project. Create the blocks and process tags as required in the master data library and 
copy these object from this library to the CFC charts. 

What are the advantages of the master data library? 
Use of the master data library ensures that the the same version of a block is used in a 
project and that there can be no confusion. This especially important if there is more than 
one project engineer working on a project with a multiproject.  
The use of the master data library also provides you with another convenient PCS 7 function: 
the hiding of libraries. This function allows you to hide all libraries except for the master data 
library, for example, in order to prevent inconsistency and errors within the project.  
One other advantage of using master data libraries is that they are archived automatically 
when you archive the multiproject. 
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5.2.2 How to Store Objects in the Master Data Library 

Changes to blocks 
You can change the properties of the block in the master data library. For example, you can 
adapt messages specifically to your project requirements. Each block instance that is 
created when you insert a block in a CFC chart automatically has the modified properties.  
This means that you only have to modify the block once in the master data library and not 
repeatedly for each individual block instance.  
Modifications to blocks that are intended for a specific CFC chart are made directly in the 
block instance in the CFC chart. This includes, for example, parameters for inputs and 
outputs, such as setpoints and limit values.  

Master data library and process tag types 
You can also store the process tag types provided by PCS 7 in your master data library. The 
following occurs in the background: all the blocks included in this process tag type, are 
automatically entered in the block folder of your master data library. 

Basic procedure 
 

 
Step Action 
 1 Open library (Page 68) 
 2 Store all blocks in your master data library (Page 69) 

The PCS 7 wizard automatically generates the master data library when a project is 
created. 

 3 Store process tag types in the master data library (Page 72) 
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5.2.3 Working with the Master Data Library 

Blocks in the master data library 
Creating a master data library for a large project requires detailed planning before the CFC 
charts are actually created. In this Getting Started, we will provide you with all the blocks you 
require for the "color_gs" project. The blocks are listed in the table below. The table also 
contains:  
● Object name 

This is an alphanumeric block code displayed in PCS 7 
● Symbolic name 

Short descriptive name for the block 
● Meaning 

Short description of the purpose of this block 
● Type of block 

Defines the block category 
● Associated CFC chart 

Returns all CFC charts where the block is installed 
 

 
Object  
name 

Symbolic  
name 

Meaning Type of  
block 

Associated 
CFC chart 

FB40 INT_P Generates the time integral of an 
input value 

Technological 
block 

CFC_LI111 
CFC_FC111 

FB46 OP_A_LIM Manipulates an analog value Operator control 
block 

CFC_FC111 

FB48 OP_D Manipulates a digital value Operator control 
block 

CFC_FC111 

FB61 CTRL_PID Continuous PID controller Technological 
block 

CFC_FC111 

FB63 DOSE Doses components Technological 
block 

CFC_FC111 

FB65 MEAS_MON Monitors an analog measured value Technological 
block 

CFC_LI111 

FC63 MUL_R Multiplies input values and outputs 
the result at the output 

Function CFC_FC111 

FC275 CH_AI Processes an analog input value 
signal 

Driver block CFC_LI111 
CFC_FC111 

FC276 CH_AO Processes an analog output value 
signal 

Driver block CFC_FC111 

 



 Creating CFC charts 
 5.2 Working with libraries 

PCS 7 - Getting Started - Part 1 
Getting Started, 09/2007, A5E00857261-02 67 

Process tag types in the master data library 
You enter the process tag types in your master data library in exactly the same way as the 
individual blocks. You need the following process tag types for the "color_gs" project: 

 
Object name Meaning Associated CFC chart 
MOTOR CFC chart for a motor CFC_NP111 
VALVE CFC chart for a valve CFC_NK111 
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5.2.4 How to Open the Libraries 

Requirement 
SIMATIC Manager is open. 

Procedure 
1. Select the File > Open.... 

 command. The program opens the "Open Project" dialog box. 
2. Select the "Libraries" tab. 
3. Highlight the "PCS 7 Library V70" and "color_gs_Lib" libraries in the picklist. 

 
 

4. Click "OK". 
The program opens both libraries in the component view. 
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5.2.5 How to Store Blocks 

Requirements 
● SIMATIC Manager is open. 
● PCS 7 Library V70" is opened and the component view is activated. 
● The "color_gs_Lib" master data library is open and the component view is activated. 

Procedure 
1. Select the Window > PCS 7 Library V70 (component view) command 

The program opens the PCS 7 standard library. 
2. Select the  

"PCS 7 Library V70/ Blocks + Templates/ Blocks" entry from the tree view. 
The detail view shows all blocks available in the PCS 7 standard library. 

3. Select the View > Details command. 
The view returns the object names, that is, the short names, and the symbolic names of 
the blocks. This gives you more detailed information. 

4. In the detailed window, select the required blocks according to the following list: 
– FB40 - INT_P 
– FB46 - OP_A_LIM 
– FB48 - OP_D 
– FB61 - CTRL_PID 
– FB63 - DOSE 
– FB65 - MEAS_MON 
– FC63 - MUL_R 
– FC275 - CH_AI 
– FC276 - CH_AO 
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5. Select the Edit > Copy command. 
6. Select the Window > color_gs_Lib (component view) command. 

This opens the master data library. 
7. Select the tree view entry  

"In <color_gs_MP>/ color_gs_Lib/ S7 program(1)/ Blocks". 
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8. Select the Edit > Paste command. 
The program inserts the selected blocks. 
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5.2.6 How to Store Process Tag Types 

Introduction 
In the following, you will store process tag types in the "Charts" directory of your master data 
library in the component view. You will then copy your master data library from the 
"Templates" directory to the "Process tag types" directory in the plant view. 

Requirements 
● SIMATIC Manager is open. 
● PCS 7 Library V70" is opened and the component view is activated. 
● The "color_gs_Lib" master data library is open and the component view is activated. 

Procedure 
1. Select the menu command Window > PCS 7 Library V70 (Component View). 

This opens the component view of the PCS 7 standard library. 
2. Select the PCS 7 Library V70/ Blocks + Templates/Templates" entry from the tree view. 

The detail view shows all charts templates available in PCS 7. 
3. Select the following charts in the detailed window: 

– "MOTOR" 
– "VALVE" 

4. Select the menu command Edit > Copy. 
5. Select the menu command Window > color_gs_Lib (component view). 

This opens the master data library. 
6. Select the tree view entry  

"In <color_gs_MP>/ color_gs_Lib/ S7 program(1)/ Charts". 
7. Select the menu command Edit > Paste. 

All the selected process tag types are inserted. 
8. Close the "PCS 7 Library V70". 
9. Open the plant view of "color_gs_lib". 
10. Select the "In <color_gs_MP>/ color_gs_Lib/ Templates" folder from the tree view. 
11. Select the following subfolders in the detailed window: 

– "MOTORS" 
– "VALVES" 
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12. Select the menu command Edit > Cut. 
13. Select the folder  

"In <color_gs_MP>/ color_gs_Lib/ Process tag types" from the tree view. 
14. Select the menu command Edit > Paste. 

The selected process tag types are inserted. 
The "Templates" directory is empty. 

 
 

 Note 
As soon as a process tag type is stored in the master data library, all the individual blocks 
contained in this process tag type are automatically stored in the "Blocks" folder.  
If you select "<color_gs_MP>/ color_gs_Lib/ S7 Program(1)/ Blocks" in the tree view, in the 
detailed window you will see all the blocks that you yourself have inserted or that were 
automatically created by copying the process tag types. 

 

5.2.7 Showing and Hiding Libraries 

Introduction 
You can hide libraries you do not require. This makes working with the catalog in the CFC 
Editor clearer and less prone to errors. Since you have already stored all the necessary 
blocks and process tag types in your master data library, you work exclusively with this 
master data library when creating the "color_gs" project. 
You can show libraries again quickly if you need them again. 
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5.2.8 How to Hide and Show Libraries 
 

NOTICE  
Make sure that you actually have all the required blocks and charts in your master data 
library.  

 

Requirement 
SIMATIC Manager is open. 

Procedure for Hiding Libraries 
1. Select the File > Manage.... 

 command. The program opens the "Manage" dialog box. 
2. Select the "Libraries" tab. 
3. Select all the libraries in the list except the following libraries: 

– Master data library "color_gs_Lib" 
– "PCS 7 Library V70" 
– SFC Library 
– Standard library 
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4. Click "Hide". 
All the libraries you selected are removed from the list. 

5. Click "Close". 
You have hidden all libraries which you are not going to use. You can no longer see them 
in the CFC Editor catalog. 

Procedure for Showing Libraries 
1. Select the File > Manage.... 

 command. The program opens the "Manage" dialog box. 
2. Select the "Libraries" tab. 
3. Click "Display...". 

The program opens the "Browse" dialog box. 
4. Select the ".../SIEMENS/ STEP7/ S7LIBS/ [name of library]" object from the tree view. 

The library is displayed in the pane on the right side. 
5. Click "OK". 

The program closes the dialog box. The library you selected is displayed and marked in 
the libraries list of the "Manage" dialog box. 

6. If you want to display additional libraries, repeat steps 3 through 5. 
7. Click "Close". 

The program closes the dialog box. 
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5.3 CFC charts in the PH 

5.3.1 Working with CFC Charts 

Introduction 
Once you have made the preparations for creating the CFC charts by filling your master data 
library, you can now start creating the CFC charts. 

Basic procedure for creating CFC charts 
 

 
Step Action 
 1 Create empty CFC charts in the plant hierarchy 
 2 Insert individual blocks in an empty CFC chart 
 3 Interconnect the inputs and outputs of blocks and assign parameters to them 

 

CFC Charts in the PH 
The PCS 7 "New Project" wizard has already created a CFC chart in your plant hierarchy. 
This is stored in the "ADDIT" folder. This CFC chart does not yet contain any blocks. You 
have to insert them in the CFC Editor. 
In addition, you require other charts for the "color_gs" project , which you insert in the plant 
hierarchy and then edit in the CFC Editor. 
It is also important that you assign brief descriptive names for all CFC charts of the 
"color_gs" project to keep your project easy to understand.  
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5.3.2 Which Charts do you Need in the "color_gs" Project? 

CFC Charts in the Example Project 
The following CFC charts are needed for the "color_gs" project: 
● CFC_SETP - for specification of setpoints 
● CFC_FC111 – for closed-loop control of dosing amount and dosing speed 
● CFC_LI111 – for control and simulation of the liquid level 
● CFC_NP111 – for motor control 
● CFC_NK111 to CFC_NK114 – for valve control 
Each chart has a process-related meaning. To fully understand the part of the plant you are 
configuring in Getting Started, you should understand the process-related meaning of the 
individual CFC charts. We provide a brief description of each individual chart below. 

Some Details about Creating CFC Charts 
You will create the CFC_SETP, CFC_FC111 and CFC_LI111 charts yourself. PCS 7 makes 
the CFC_NP111 and CFC_NK11x available to you as a complete CFC chart in the form of a 
process tag type. This will illustrate the great advantage of using process tag types, which 
thus far you have only stored in your master data library. 
 

 

 Note 
In the "color_gs" project, the names of the CFC charts are assigned according to the name 
of the associated hierarchy folder and, thus, also the name of the associated process tag. As 
a result, unique identification is always possible.  

 
 

5.3.3 Process-Related Meaning of the "CFC_SETP" CFC Chart 

CFC_SETP 
The CFC_SETP is used for dosing from the OS. The blocks mean the following in this case: 
● The PARADOS_RM1_QTY block specifies the dosing speed. 
● The PARA_DOS_RM1_VOL block specifies the dosing volume. 
● The PARA_DOS_RM1_SEL block specifies the target reactor. 
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5.3.4 Process-Related Meaning of the "CFC_FC111" CFC Chart 

CFC_FC111 
The CFC_FC111 is used for closed-loop control of the dosing volume and dosing speed. The 
blocks mean the following in this case: 
● The "CH_AI" block provides the currently dosed volume at the "V" output and transfers 

this measured value to the "PV_IN" (process value) input of the "DOSE" block. 
● The interposed "INT_P" block is used for simulating the dosed volume. 
● The "CTRL_PID" block controls the speed of the dosing by means of a flow controller. 
● The"CTRL_PID" block receives the setpoint specifications via the step control in 

conjunction with the "PARA_DOS_RM1_VOL" block. 
● The manipulated variable for the valve is output at the "LMN" output and is fed directly to 

the "CTRL_PID" block at input "LMNR_IN" in the absence of manipulated variable 
feedback from the process. 

● The "CH_AO" block outputs the manipulated variable to the valve. 

5.3.5 Process-Related Meaning of the "CFC_LI111" CFC Chart 

CFC_LI111 
The CFC_LI111 is used for controlling and simulating the fill level. The blocks mean the 
following in this case: 
● The "CH_AI" block reads in the fill level of the raw material tank and outputs the current 

value at output "V". 
● By default, this output is interconnected with the "U" input of the "MEAS_MON" block. 
● The "INT_P" block is used to simulate the fill level. 

5.3.6 Process-Related Meaning of the "CFC_NP111" CFC Chart 

CFC_NP111 
The CFC_NP111 is used for pump control. The blocks mean the following in this case: 
● The "CH_DI" block supplies the current state of the pump (on or off) at output "Q". 
● This value is interconnected to the "FB_ON" input (feedback ON) of the MOTOR block 

where it is evaluated. 
● The plant operator or a higher level controller controls the "MOTOR" block. 
● The "CH_DO" block takes the control command from the "QSTART" output of the 

"MOTOR" block and outputs this to the pump in the process. 
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5.3.7 Process-Related Meaning of the "CFC_NK11x" CFC Chart 

CFC_NK11x 
The CFC_NK11x is used for valve control. The blocks mean the following in this case: 
● The "CH_DI" block returns feedback on the status of the valve (open or closed) to the 

"VALVE" block. 
● The "VALVE" block switches the valve according to the setting made by an external 

controller or by an operator: The control command is passed on from the "QCONTROL" 
output via the "CH_DO" output driver to the valve. 

● The "VALVE" block can forward fault messages to the operator station. 
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5.3.7.1 How to Rename CFC Charts in the PH 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
A CFC chart you created is already in the ADDIT folder. All you need to do now is rename it. 
1. Select the"color_gs_MP/color_gs_Prj/Plant1/RMT1/FC111/ADDIT" folder in the tree view. 
2. Select the "CFC(1)" object in the detailed window. 
3. Select Edit > Object Properties. 

The "Properties CFC Chart" dialog box opens and the "General" tab is selected. 
4. Type the name "CFC_SETP" into the input box. 

The name of the chart real projects usually relates to a user-specific system for the 
identification of process tags. 
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5. Click "OK" to save your entries. 
Video  
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5.3.7.2 How to Insert New CFC Charts in the PH 

CFC charts to be inserted 
You must insert the following CFC charts in the form of new, empty CFC charts: 
● "CFC_FC111" 
● "CFC_LI111" 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the  

"color_gs_MP/color_gs_Prj/Plant1/RMT1/FC111" folder from the tree view. 
2. Select the menu command Insert > Plant Objects > 2 CFC. 

The CFC chart "CFC(1)" is inserted. When you insert new charts, PCS 7 first assigns the 
default name "CFC" followed by a consecutive number and activates the input mode for a 
new name. 

3. Enter the name "CFC_FC111" and press the Enter key. 
4. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1/ LI111" folder from the tree view. 
5. Select the menu command Insert > Plant Objects > 2 CFC. 

The CFC chart "CFC(1)" is inserted. 
6. Enter the name "CFC_LI111" and press the Enter key. 
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5.3.7.3 How to Insert the "MOTOR" Process Tag Type 

Introduction 
You have already stored the "MOTOR" process tag type in your master data library. You 
now only need to insert this process tag type into the plant hierarchy in your "color_gs" 
project. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the tree view entry  

"color_gs_MP/ color_gs_Lib/Process tag types/MOTORS". 
The detail view displays the process tag types you inserted into the master data library. 

2. Select the "MOTOR" CFC chart and then select the menu command Edit > Copy. 
3. Select the  

"color_gs_MP/ color_gs_Prj/Plant1/RMT1/NP111" folder from the tree view and then 
select the menu command Edit > Paste. 
The "MOTOR" CFC chart is inserted into the hierarchy folder and selected. 

4. Select the menu command Edit > Object Properties. 
The "Properties CFC Chart" dialog box opens. 

5. Change the default name "MOTOR" to "CFC_NP111" in the "Name" box. 
6. Click "OK" to save your entries. 
Video  
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5.3.8 Current Status of Your Project 

Completed Configuration Tasks 
In preparation for the actual creation of CFC charts, you have now completed the following 
configuration tasks: 
● You have stored all the necessary blocks and process tag types in the master data 

library. 
● You have hidden libraries that you do not require for the "color_gs" project so that only 

the "color_gs_Lib" master data library is still visible. 
● You have renamed and inserted new CFC charts in the plant hierarchy. 
● You have inserted the "MOTOR" process tag type in the plant hierarchy. 
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5.4 Working with the CFC Editor 

5.4.1 Introduction to the CFC Editor 

CFC Editor 
The CFC charts are actually edited, e.g., blocks are inserted and their parameters assigned, 
in the CFC Editor. As soon as you open a CFC chart, the CFC Editor opens. The editor 
always opens in the view in which it was closed the last time you worked with it. 
With its normal settings, the CFC Editor is divided up as follows: 
● On the left side of the editor you see the CFC chart displayed. If you have opened an 

empty CFC chart, you will simply see an empty space here. This is where you insert 
blocks as required to describe continuous processes. Afterwards, you assign parameters 
and interconnect the blocks. 

● On the right side of the editor you see the catalog containing the blocks, libraries, and 
CFC charts. 

All the work that you do with the CFC Editor is saved automatically by PCS 7. 

Additional information 
Detailed information about the CFC Editor is available in the corresponding CFC Online Help 
and in the SIMATIC,CFC for S7, Continuous Function Chart Manual. 
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5.4.2 CFC Chart in the CFC Editor 

CFC chart 
Each CFC chart can consist of up to 26 chart partitions. A new CFC chart consists of only 
one chart partition. Only one chart partition is necessary for the "color_gs" project. Each 
chart partition, in turn, consists of six sheets.  
You can select between two different views using buttons in the toolbar: 

● A single sheet:  

● Overview with six sheets:  
The status bar shows which sheet of which chart partition is currently being displayed. 

Switching from the Overview to a Single Sheet 
You can switch from the overview to the single sheet view by double-clicking on the required 
sheet. 
The individual sheets in the overview are arranged in the order shown below: 

 
 

Additional information 
Detailed information is available in the corresponding online help of the CFC and in the 
SIMATIC, CFC for S7, Continuous Function Chart Manual. 
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5.4.3 Catalog in the CFC Editor 

Opening the Catalog 
If it is not already open, open the catalog using the menu command View> Catalog menu. 

Organization of the catalog 
In the catalog you will see four tabs: 
● Blocks - here you will find the blocks sorted according to block families. You will not work 

in this tab in the "color_gs" project. 
● Charts - here you will find all the charts you created in the plant hierarchy, for example, 

CFC _FC111, CFC_LI111. The CFC chart that is currently open and displayed in the CFC 
editor is labeled by a small open folder. 

● Libraries - These contain all PCS 7 standard libraries and your master data library. 
You have already executed the "hide" function to hide all libraries in the "color_gs" project 
which you do not require to configure the system. This means that you can only see the 
"color_gs_Lib" library. 

● Unplaced blocks - here you will find blocks that are not displayed in a CFC chart. Within 
the "color_gs" project, this tab is not displayed since there are no "unplaced blocks" in 
your project. 

Additional information 
Detailed information is available in the corresponding CFC Online Help and in the SIMATIC, 
CFC for S7, Continuous Function Chart Manual. 
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5.4.4 Overview of the Configuration Steps for CFC Charts 

Overview 
To create CFC charts, always follow the steps below in the order given: 

 
Step What? 
 1 Open chart (Page 89) 
 2 Insert blocks 

Options: 
• Insert blocks in "CFC_SETP" 
• Insert blocks in "CFC_FC111" 
• Insert blocks in "CFC_LI111" 

 3 Assign parameters to blocks 
• Rename blocks 
• Specify input/output values 

 4 Interconnect blocks (Page 100) 

The "Insert blocks" step is skipped for process tag types. You now only have to configure 
and interconnect the process tag types. 

Information from the online help for the block 
 

 Note 
If you need additional information on the blocks, for example, the functions of the individual 
block inputs, select a block in the library or directly in the CFC chart and press the <F1> key. 
The online help for this block opens immediately. 
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5.4.5 How to Open the "CFC_SETP" CFC Chart 

Introduction 
To be able to place blocks in your CFC charts, you must now open the CFC chart. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1/ FC111/ ADDIT" folder from the tree view. 
2. Select the "CFC_SETP" object in the detail view, and then select the Edit  > Open Object 

command. 
The CFC editor opens. 

You can now edit the open chart. 

5.4.6 Assignment of Block Parameters in CFC Charts 

Assignment of Block Parameters 
Each block has a number of different I/Os that are displayed in a table of the properties 
dialog box. Click the column heading of the table to quickly find the inputs/outputs in this 
dialog box. The column is then sorted in ascending or descending order. 
The I/Os of a block can be both visible or invisible: You can only see invisible parameters in 
the properties of the block but not in the representation in the CFC chart. In the properties of 
the block, you can specify which I/Os in the CFC chart will be visible and which will be 
invisible. In the "Not Displayed" column, you need to deactivate the check box of the relevant 
I/O to make the I/O visible in the CFC chart. This function helps to make a CFC chart easier 
to read. In the "color_gs" project, you will accept the default settings. 
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5.4.7 How to Insert the Blocks into the "CFC_SETP" 

Requirements 
● The "CFC_SETP" CFC chart is open in the CFC editor -  

Storage location: "color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ FC111/ ADDIT". 
● The catalog is open. 

Procedure 
1. Switch to the "Libraries" tab in the catalog. 

The tab shows a view of the "color_gs_Lib" library. 
2. Open the "color_gs_Lib/S7 Program(1)\Blocks/ OPERATE" folder in the tree view. 
3. Drag-and-drop the "OP_A_LIM - FB46" block from the catalog to the CFC chart. 

This block is used to define the dosing volume. 
4. Insert further blocks into the CFC chart. 

Proceed as described for the "OP_A_LIM - FB46" block. 
– OP_A_LIM - FB 46: Dosing speed setting 
– OP_D - FB48: Specifying the reactor to which the raw material will be pumped 

5. Arrange the blocks in the CFC chart as shown below: 

 
 

6. Close the chart. 
 

 

 Note 
If a block is shown in blue or light gray after you have inserted it and if no block I/Os are 
displayed, it is covering an underlying block or extends beyond the edge of the sheet.  
In this case, you must move the block with the mouse so that it does not cover any other 
block and is within the limits of the sheet. 
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5.4.8 How to Assign Parameters for the Blocks in "CFC_SETP" 

Requirements 
● The "CFC_SETP" CFC chart is open in the CFC editor -  

Storage location: "color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ FC111/ ADDIT". 
● All blocks are inserted. 

Procedure 
1. Select the "1 OP_A_LIM" block and then select Edit > Object Properties.... 

The "Properties - Block" dialog box opens and the "General" tab is selected. 
2. Enter the name "PARA_DOS_RM1_QTY" in the "Name" input box. 

The "Enable operating and monitoring" check box is activated by default. 
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3. Switch to the "Inputs/Outputs" tab. 
Here you can configure the I/Os of a block. You will find the names of all inputs and 
outputs in the "Name" column. 

4. Position the cursor in the "Value" column of the "U" connection and overwrite the default 
value with the value "50". 

 
 

5. Position the cursor in the "Unit" column of the "U" connection. 
A drop-down list is displayed. 

6. Select the "m3/min" unit from the drop-down list. 
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7. Click "OK" to apply your settings. 
The name "PARA_DOS_RM1_QTY" is displayed in the header of the block in the CFC 
chart. 
When you create the process pictures, you will interconnect the I/Os of the blocks from 
the CFC charts with objects in the process pictures. The tag name is formed from the 
plant hierarchy, the CFC chart name, and the block name. You can find the name 
"PARA_DOS_RM1_QTY" as part of the tag name. 
The values of the I/Os are applied. 

8. Now change the names and parameter settings for the other blocks as shown in the table 
below. To do this, follow the procedure described in Steps 1 to 5. 
Some of the I/Os are not visible in the CFC chart. 

9. Close the chart. 
 

Block Name in project I/O Meaning Value Unit 
2 OP_A_LI
M 

PARA_DOS_RM1_VOL U* Setpoint for dosing   500 m3 

  U_HL Limit for entering the U 
parameter 

 500  

OP_D PARA_DOS_RM1_SEL IO* The dosing is performed in 
reactor 1. 

OFF  

 * Invisible in CFC. 
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5.4.9 How to Insert the Blocks into the "CFC_FC111" 

Requirements 
● The "CFC_FC111" CFC chart is open in the CFC editor -  

Storage location: "color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ FC111". 
● The catalog is open, and the "Libraries" tab is visible. 
● The "color_gs_Lib/S7 Programs(1)\ Blocks" folder is open in the tree view. 

Procedure 
1. Use a drag-and-drop operation to Insert the following blocks: 

– Folder "DRIVER": CH_AI - FC275: Signal processing of an analog input value 
– Folder "CONTROL": INT_P - FB40: Simulation of the dosing quantity 
– Folder "CONTROL": DOSE - FB63: Dosing of raw material 
– Folder "MATH_FP": MUL_R - FC63: Multiplies input values and returns the result at 

the output 
– Folder "CONTROL": CTRL_PID - FB61: Fill level monitoring and visualization of the 

level in the process mode 
– Folder "DRIVER": CH_AO - FC276: Processes an analog output value signal 

2. Arrange the blocks in the CFC chart as shown below: 

 
 

3. Close the chart. 
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5.4.10 How to Assign Parameters for the Blocks in the "CFC_FC111" 

Requirements 
● The "CFC_FC111" CFC chart is open in the CFC editor -  

Storage location: "color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ FC111". 
● All blocks are inserted. 

Procedure 
1. Open the "General" tab and "Inputs/Outputs" tab in the "Object Properties" dialog box for 

each block. 
2. Enter parameters for all blocks according to the table below. 
3. When you have entered the parameters for all block I/Os, click "OK" each time. 

Your settings are applied. 
4. Close the chart. 
 
Block Name in project I/O Meaning Value 
CH_AI INPUT_U SIM_ON* Simulation activated  1 
  MODE Measuring range 4 to 20 mA  

16#0203
  VHRANGE High measuring range  100 ** 
  SUBS_ON Enables a substitute value  1 
INT_P INT_P V_HL High limit volume summation 1000 

Liters  
 1000 

  TI Integration time  2 
DOSE DOSE SP_HLM* High limit of the setpoint for the 

dosing volume 
 1000 

  MO_PVHR* High display limit of the process value 
for the dosing volume 

 1000 

  MO_PVLR Low display limit of the process value 
for the dosing volume 

 0 

  SPEXON_L Interconnection for the 
internal/external switchover active 

 1 

  SPEXT_ON Default for the internal/external 
switchover 

 1 

MUL_R MUL_R IN2 Parameters for optional adaptation of 
the actual flow rate value  

 1 ** 

CTRL_PID CTRL_PID LIOP_MAN_SEL Interconnection automatic/manual 
active 

 1 

  LIOP_INT_SEL Interconnection for the 
internal/external switchover active 

 1 

  SPEXON_L Switch controller to external setpoint  1 
  GAIN Set the gain of the controller to 0.5  0.5 
CH_AO OUTPUT_LMN Not applicable   
* Invisible in CFC. 
** Default value 
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 Note 
Use a period as the decimal separator. 
For some input boxes, PCS 7 provides predetermined values that you can select from a 
drop-down list. This drop-down list is activated automatically when you position the cursor in 
the input box. 

 
 

 

 Note 
You assign the "MODE" I/O for the CH_AI block. You assign this parameter only because 
you have not configured any external I/O modules in this Getting Started. 
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5.4.11 How to Insert the Blocks in the "CFC_LI111" 

Introduction 
Now you have to create the "CFC_LI111" chart. The procedure is exactly the same as for the 
"CFC_FC111" chart. 

Requirements 
● The "CFC_LI111" CFC chart is open in the CFC editor -  

Storage location: "color_gs_MP/ color_gs_prj/ Plant1/ RMT1/ LI111". 
● The catalog is open. 
● The "color_gs_Lib/S7 Programs(1)\ Blocks" folder is open in the tree view. 

Procedure 
Drag-and-drop the following blocks to insert themm arrange them as shown in the figure and 
then close the chart: 
● Folder "DRIVER": CH_AI - FC275: This block reads the process value of an input module 

and makes the value read in available in CFC for further processing. 
● Folder "CONTROL": INT_P - FB40: This block is used to simulate the level of the raw 

material tank 1. 
● Folder "CONTROL": MEAS_MON - FB65: Fill level monitoring and visualization of the 

level in the process mode 
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5.4.12 How to Assign Parameters for the Blocks in the "CFC_LI111" 

Requirements 
● The CFC chart "CFC_LI111" is open in the CFC Editor - stored in the "color_gs_MP/ 

color_gs_prj/ Plant1/ RMT1/ LI111" folder. 
● All blocks are inserted. 

Procedure 
1. Open the "General" tab and "Inputs/Outputs" tab in the "Object Properties" dialog box for 

each block. 
2. Enter parameters for all blocks according to the table below. 
3. When you have entered the parameters for all block I/Os, click "OK" each time. 

Your settings are applied. 
4. Close the chart. 

 
Block Name in 

project 
I/O Meaning Value Unit 

CH_AI INPUT_U MODE Measuring range 4 to 20 mA  16#0203  
  VHRANGE High measuring range  500  
  SIM_ON Simulation value active  1  
  SIM_V Raw material tank level  500  
  SUBS_ON Enables a substitute value  1  
  SUBS_V Substitute value for SIM_V  500  
INT_P INT_P U Simulation of the raw material tank 

level 
 -10  

  V_HL High limit of the output value  500  
  TI Integration time 1.0**  
MEAS_MO
N 

LIA U_WH High warning limit = 450  m3  450 m3 

  U_WL Low warning limit = 7  m3  7 m3 
  U_AH High alarm limit = 490 m3  490 m3 
  U_AL Low alarm limit = 5 m3  5 m3 
  MO_PVHR* High display limit of the process value 

in the container 
 500 m3 

  MO_PVLR* Low display limit of the process value 
in the container 

 0 m3 

  HYS Hysteresis  1  
* Invisible in CFC. 
** Default value 

 

 Note 
You assign the "MODE" I/O for the CH_AI block. You assign this parameter only because 
you have not configured any external I/O modules in this Getting Started. 
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5.4.13 How to Assign Parameters for Blocks in the "CFC_NP111" 

Introduction 
You have already inserted the CFC_NP111 chart as a process tag type. For this chart, you 
still need to adapt the default parameter values to your "color_gs" project. 

 

 Note 
You do not have to adapt the names of the individual blocks when using process tag types. 

 

Requirement 
The "CFC_NP111" CFC chart is open in the CFC Editor - stored in the "color_gs_MP/ 
color_gs_prj/ Plant1/ RMT1/ NP111" folder. 

Procedure 
1. Open the "General" tab and "Inputs/Outputs" tab in the "Object Properties" dialog box for 

each block. 
2. Enter parameters for all blocks according to the table below. 
3. Click "OK". 

Your settings are applied. 
4. Close the chart. 
 

 
Block Name in 

project 
I/O Meaning Value 

CH_DI FB_RUN SIM_ON Switch simulation active  1 
  SUBS_ON Enables a substitute value  1 
MOTOR MOTOR MONITOR Deactivate monitoring Monitoring = Off 
  AUT_ON_OP* Activate automatic mode Mode = AUTO 
* Invisible in CFC. 
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5.4.14 Interconnection of Blocks in the CFC Charts 

Interconnection of Blocks 
Now, you will interconnect the inputs and outputs in the charts. You can interconnect the 
blocks conveniently by clicking on the graphic user interface of the CFC editor. To do so, 
click first on the output of a block and then on the input you want to interconnect the output 
with. After clicking on the input, the interconnection is displayed as a line. The CFC Editor 
automatically draws lines in the best position. The position of the lines has no impact on the 
function of the interconnection. 

 

 Note 
If you draw a connection incorrectly: 
Click on the line of the incorrect interconnection and select the Edit > Delete command. 

 

A Special Feature of the "CFC_SETP" and "CFC_NP111" Charts 
The CFC_SETP charts do not require any interconnection because this chart is used only for 
specifying setpoints and for storing operator commands. 
The CFC_NP111 chart does not require any interconnections since you used a process tag 
type for this chart so that all the interconnections are already made. 
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5.4.15 How to Interconnect Blocks in the "CFC_FC111" 

Requirements 
● The "CFC_FC111" CFC chart is open in the CFC Editor. 
● All blocks are inserted, renamed and configured. 

Procedure 
1. Click output "V" on the "INPUT_U" block. 
2. Click on input "U" of the "INT_P" block. 

The CFC editor automatically generates an interconnection line. 
3. Following the same procedure, interconnect additional blocks according to the table 

below. 
The CFC chart then appears as follows: 

 
 



Creating CFC charts  
5.4 Working with the CFC Editor 

 PCS 7 - Getting Started - Part 1 
102 Getting Started, 09/2007, A5E00857261-02 

4. Close the chart. 
 

Block Output Block Input 
INPUT_U V INT_P U 
INT_P V DOSE PV_IN 
MUL_R OUT CTRL_PID PV_IN 
CTRL_PID LMN OUTPUT_LMN U 
CTRL_PID LMN MUL_R IN1 
CTRL_PID LMN CTRL_PID LMNR_IN 

 
Video  
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5.4.16 How to Interconnect Blocks in the "CFC_LI111" 

Requirements 
● The "CFC_LI111" CFC chart is open in the CFC Editor.  
● All blocks are inserted, renamed and configured. 

Procedure 
1. Interconnect additional blocks according to the table below. 

The CFC chart then appears as follows: 

 
2. Close the chart. 

 
Block Output Block Input 
INPUT_U V INT_P VTRACK 
INT_P V LIA U 
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5.5 CFC charts in the process object view 

5.5.1 Use of the Process Object View for Valve Control 

Introduction 
Now work on the charts CFC_NK111 to CFC_NK114. Until now you have inserted the 
"VALVE" process tag type in your master data library and created the four hierarchy folders 
in the plant hierarchy. 

Working with the process object view 
To handle almost identical charts, you will now become familiar with an extremely convenient 
function in PCS 7: the process object view. This means that you do not need to open each 
individual chart in the CFC Editor and assign parameter; rather, you can modify values 
quickly in a table within the process object view. 
The following preparations are necessary for this: 
● Define the I/O in the process tag type for the process object view (Page Fehler! 

Textmarke nicht definiert.) 
As the process object view does not visualize all I/Os for reasons of clarity you must 
define the I/Os to be shown. You define this once in the process tag type in the master 
data library. 

● Rename process tag types and their insertion into the hierarchy folder (Page 107) 
You are going to copy the process tag type from the master data library to all the 
hierarchy folders in which you require the valve control.. 

● Edit parameter values in the process object view (Page 108) 
The next sections are going to demonstrate the benefits of a process object view: you 
can edit values quickly and easily in a table. 
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5.5.2 Procedure 

Requirements 
● The example project is open in SIMATIC Manager. 
● The process object view is activated 

Procedure 
1. Select the  

"color_gs_Lib/Process tag types/Valves/VALVE" object from the tree view. 
2. Select the menu command Options > Process Objects > Select I/Os.... 

The "Filter: Select Connections" dialog box opens. 
3. Activate the "Block" check box and enter the value "VALVE" in the input box. 

This setting only allows the display of "VALVE" block connections. 
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4. Click "OK". 
The "Select I/Os" dialog box opens. 

5. Click on the title of the "Parameters" column. 
This will display all I/Os in the upper rows that are activated in the "Parameters" column. 

6. Deactivate the check boxes of these I/Os. 
7. Activate the check boxes in the "Parameters" column for the following I/Os: 

– AUT_ON_OP 
– MONITOR 
– START_SS 

 

  Note 
If you click on the title of the "I/O" column, the I/Os are sorted in ascending or 
descending order. This makes it easier to find what you are looking for. 

 
 

8. Click "OK". 
The "Select I/Os" dialog box closes. 

9. Close the process object view. 
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5.5.2.1 How to Insert the "VALVE" Process Tag Type 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
Follow exactly the same procedure as for the "MOTOR" process tag type: 
1. Select the "VALVE" process tag type in the detail window of the "color_gs_MP/ 

color_gs_Lib/ Process tag types/VALVES" folder. 
2. Insert the "VALVE" process tag type in the following folders using the Edit > Copy and 

Edit  > Paste menu commands: 
– color_gs_MP/color_gs_Prj/Plant1/RMT1/NK111 
– color_gs_MP/color_gs_Prj/Plant1/RMT1/NK112 
– color_gs_MP/color_gs_Prj/Plant1/RMT1/NK113 
– color_gs_MP/color_gs_Prj/Plant1/RMT1/NK114 

3. Rename the inserted process tag types according to the table below. 
4. Close the plant view. 

 
Hierarchy folder Rename to: 
../RMT1/NK111 CFC_NK111 
../RMT1/NK112 CFC_NK112 
../RMT1/NK113 CFC_NK113 
../RMT1/NK114 CFC_NK114 

 
A detailed description is available in the section  
"How to insert the "MOTOR" process tag type" (Page 83). 
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5.5.2.2 How to Adapt the Parameters for "CFC_NK11x" 

Requirements 
● The example project is open in SIMATIC Manager. 
● The process object view is activated 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1" folder from the tree view. 
2. Select the "Blocks" tab. 

The data are updated. 
3. Select the "Block" entry from the "Filter by column" drop-down list. 

This activates the "Display" box. 
4. Enter the name of the block in the "Display" input box: "VALVE". 

The table is updated and shows you the "Valve" block for all four CFC charts. 
 

  Note 
If the name of the CFC chart is not fully displayed in the column, position the cursor 
between the "Chart" column and "Chart Comment" column and double-click. This adapts 
the column width automatically to the width of the entries. 

5. Enter the name "stop_valve1" in the "Block Comment" column for the "CFC_NK111" 
chart, and press the ENTER key. 
This updates the block comment at all connections of this chart. 

6. Change the block comment for the other CFC charts in the way shown in the table below. 
7. Select the "Parameters" tab. 

The data is updated. 
8. Select the "Block" entry from the "Filter by column" drop-down list. 

The "Display" input box is active. 
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9. Enter the name of the block in the "Display" input box: "VALVE". 
The table is updated. 
You see exactly three I/Os for each chart. 

 
 

10. Go to the "Value" column and enter the values as listed in the table below. The following 
applies to the the "Value" column: 
– Place the cursor in the appropriate field.. 

This changes the field to a drop-down box. 
– Select the desired item in the drop-down list. 

 
CFC chart Block comment 
CFC_NK112 stop_valve2 
CFC_NK113 stop_valve3 
CFC_NK114 stop_valve4 

 
 

 Note 
Depending on the size of your monitor, you may not be able to see the "Chart" column any 
more and, as a result, the assignment of the individual I/Os to a chart becomes difficult.  
The process object view offers you the following options:  
1. Position the cursor on the small box on the left next to the horizontal scroll bar and click.

This makes a vertical marker visible in the table. 
1. Hold down the mouse button and drag this vertical marker behind the "I/O" column. 
2. Release the mouse button. 

This splits the table window and you can navigate in the right side with the horizontal 
scroll bar in the table while the chart names are displayed on the left side. 
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CFC chart I/O Meaning Value 
CFC_NK111 START_SS Specify the initial valve state (open/closed)  0 
 MONITOR Disable monitoring of feedback from the 

process for the example 
Monitoring=off 

 AUT_ON_OP Switch the valve to automatic mode Mode=Auto 
CFC_NK112 START_SS See above  0 
 MONITOR See above Monitoring=off 
 AUT_ON_OP See above Mode=Auto 
CFC_NK113 START_SS See above  1 
 MONITOR See above Monitoring=off 
 AUT_ON_OP See above Mode=Auto 
CFC_NK114 START_SS See above  1 
 MONITOR See above Monitoring=off 
 AUT_ON_OP See above Mode=Auto 
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5.5.2.3 How to Specify the Type of Block Icon 

Introduction 
At this point you must start preparing for creation of process pictures. Since there are a few 
automatic functions for this, you can already make settings at this point. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The process object view is activated 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1" folder from the tree view. 
2. Select the "Blocks" tab. 

The program updates the data. 
3. Select the "Block" entry from the "Filter by column" drop-down list box. 

The program activates the "Display" input box. 
4. Enter the name of the block in the "Display" input box: "VALVE". 

The program updates the table and shows you the "Valve" block for all four CFC charts. 
5. Enter "2" in the "Block Icon" column for the following charts: 

– "CFC_NK113" 
– "CFC_NK114" 

6. Press ENTER. 
This sets horizontal alignment of the valve block icon in the process picture. 

 
7. Close the process object view. 
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5.5.2.4 How to Delete Interconnections to Addresses 

Introduction 
You use process tag types from the PCS 7 Library in your project for the NK111 to NK114 
valve controls and the NP111 motor control. These process tag types have default 
interconnections to input/output modules. Because you are working without real input/output 
modules in this Getting Started, a warning message appears during compilation. You have to 
delete these interconnections to avoid the warnings. 

Requirement 
● The example project is open in SIMATIC Manager. 
● The process object view is activated 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1" folder from the tree view. 
2. Select the "Signals" tab. 

The program updates the data. 
3. Click in the column heading for the "Signal" column to sort the entries in the column. 
4. Select all entries and press the <DEL> key. 

– "digital output" 
– "feedback run" 
– "feedback open" 
– "feedback closed" 

 
 

5. Close the process object view. 
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5.5.3 Current Status of Your Project 

Completed Configuration Tasks 
You have completed the following tasks during CFC configuration: 
● You have inserted blocks in the CFC Editor, assigned parameters for the blocks and 

interconnected them. 
● You have used the process object view to assign parameters to the same process tag 

types. 
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Creating SFC charts 6
6.1 Overview of SFC Charts 

The Theory -- What is SFC? 
Sequential function chart (SFC) is a sequential control system with a step-by-step sequence. 
Depending on the conditions, control passes from one state to the next. With a sequential 
control system, functions such as CFC charts are controlled and selectively processed by 
means of operating mode and state changes.  You create SFC charts in the SFC Editor. 
When you created the "color_gs" project with the PCS 7 wizard, PCS 7 automatically created 
an SFC chart. This chart is still empty. You will now use the SFC Editor to edit the SFC chart 
for the "color_gs" project. 
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6.2 Working with the SFC Editor 

6.2.1 Introduction to the SFC Editor 

SFC Editor 
As soon as you open an SFC chart, the SFC Editor opens. The SFC Editor is always opened 
in the view in which it was closed the last time you worked with it. 
Like the CFC Editor, the SFC Editor provides you with a graphic user interface that allows 
the convenient creation of sequential control systems. 
A sequential control system essentially consists of two basic elements:  
● Transition: 

A condition which controls the execution of a step. Transitions are represented by small 
rectangles in the SFC chart. 

● Step: 
The step consists of actions that are performed in three phases. 
– Initialization 
– Execution 
– Completion 

Initialization is performed once as soon as the step becomes active. It is executed until the 
follow-up transition is satisfied. When this is the case, the completion phase of the step is 
performed once. When the completion phase is finished, the step becomes inactive and the 
follow-up step becomes active. 
Steps are represented by large rectangles in the SFC chart. 

New SFC chart in the SFC Editor 
When you open a new SFC chart in the SFC Editor, you will first see two steps and one 
transition: 
● START" step 
● Transition 1 
● END" step 
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6.2.2 Important Functions in the SFC Editor 

Important Functions in the SFC Editor 
In the following section, we introduce you to the main functions of the SFC Editor that you 
will require for configuring the SFC charts for your "color_gs" project. 
You use the element bar of the SFC Editor to build up your sequential control system. The 
buttons have the following meaning: 

 
Button Meaning 

 
Enable selection" button 

When this button is enabled, you can select individual objects of 
the SFC chart, for example, the steps and transitions. A selected 
step or a selected transition is displayed in blue. 

 
Insert step + transition" button 

When this button is enabled, the cursor changes to a small cross 
and a circle with a bar across. When you move the cross to a 
position in the chart where insertion of a step or a transition is 
possible, the circle turns into the icon for "Step with Transition". At 
the same time, a green line indicates where the "Step with 
Transition" will be inserted. 

 
Insert alternative branch" button"

When this button is active, you can insert an alternative branch. 
This means that depending on the defined transition either one or 
the other sequence is processed. 

None of the other buttons are used in the "color_gs" project. 

Additional information 
Detailed information about the SFC editor is available in its Online Help system and in the 
SIMATIC SFC for S7; Sequential Function Chart Manual. 
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6.2.3 Properties of Steps and Transitions 

Introduction 
In order to edit the names and values of the steps and transitions, you will work in the 
"Properties" dialog box. You do not need to reopen the dialog box every time for each step 
and transition. Instead, you can move directly to the next transition or the next step and to 
transitions and steps of an alternative branch in this dialog box. 

Navigation Buttons 
The following navigation buttons are available to you: 

 
Button Meaning 

 
Arrow down" button" 

Use this to switch to the subsequent transition/step 

 
Arrow up" button" 

Use this to switch to the previous transition/step 

 
Right arrow" button and 

 
Left arrow" button 

Use this to switch to the adjacent transition/step 

"Properties" Dialog Box 
The dialog box has four different tabs. These tabs will be introduced briefly below. 
Tabs in the "Properties" Dialog Box for a Step: 
● General – here, you make the general settings, such as changing the name for the step.  
● Initialization – the action you define here is only processed once when the step is 

activated. 
● Processing – the action you define here is processed cyclically until the next transition is 

satisfied. 
● Termination – the action you define here is only processed once when the step is 

terminated. 
Tabs in the "Properties" Dialog Box for a Transition: 
● General – here, you make the general settings, such as changing the name for the 

transition.   
● Condition – in this tab, you specify the condition that decides when the next step in the 

sequential control system will be enabled. 
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6.2.4 Overview of the Configuration Steps for SFC Charts 
 

Overview 
To create SFC charts, you perform the steps listed below: 

 
Step What? 
 1 Move SFC Chart (Page 119) 
 2 Rename SFC Chart (Page 120) 
 3 Open SFC Chart (Page 121) 
 4 Define Technological Structure of the Sequential Control System (Page 122) 
 5 Rename Steps (Page 125) 
 6 Rename Transitions (Page 128) 
 7 Configure Steps (Page 130) 
 8 Configure Transitions (Page 137) 
 9 Optimize the Run Sequence (Page 140) 

6.2.5 How to Move an SFC Chart 

Introduction 
The SFC chart "SFC(1)" created by the PCS 7 "New Project" wizard when you created the 
"color_gs" project is stored in the "ADDIT" hierarchy folder. Since the charts are stored in the 
plant hierarchy according to their relevance, you will need to move the SFC chart created 
automatically by the PCS 7 Wizard to the relevant hierarchy folder. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1/ FC111/ ADDIT" folder from the tree view. 
2. Select the "SFC(1)" object in the detailed window. 
3. Select the Edit > Cut command. 
4. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1" folder from the tree view. 
5. Select the Edit > Paste command. 

The program inserts the selected process tag types. 
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6.2.6 How to Rename the SFC Chart 

Introduction 
To keep the naming consistent and clear within your project, you will need to change the 
default names. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1" folder from the tree view. 
2. Select the "SFC(1)" object in the detailed window. 
3. Select the Edit > Object Properties command. 

The "Properties CFC Chart" dialog box opens with active "General" tab. 
4. Change the default name "SFC(1)" to "SFC_RMT1" in the "Name" box. 
5. Click "OK" to save your entries. 
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6.2.7 How to Open the "SFC_RMT1" SFC Chart 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1" folder from the tree view. 
2. Select the "CFC_RMT1" object in the detail view, and then select the Edit  > Open Object 

command. 
The SFC editor opens. The "Start" and "End" steps and transition 1 already exist. 
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6.2.8 Technological Structure of the Sequential Control System 

Technological Sequence 
The following section provides you with an overview of the technological sequence of the 
individual steps and transitions in the sequential control system for the "color_gs" project. 
Name of the Step Function 
START Defaults:  

Changing the dosing controller to manual mode 
Switching the dosing controller to external 
Setting the units to automatic mode 
Stopping dosing 

DOSE_REA1 
DOSE_REA2 

Query:  
Should Reactor 1 or Reactor 2 be used for dosing?  

INIT_LINE1 
INIT_LINE2 

Controllers: 
Open valves of the respective branch 
Turn on the pump 
Switch the dosing controller to an external setpoint 

INIT_1_OK 
INIT_2_OK 

Query: 
Is the pump turned on? 
Is the controller set to "External Setpoint"? 

INIT_DOSE Controllers: 
Set the setpoint for the dosing speed 
Set the dosing controller to automatic mode 
Set the setpoint for dosing volume 
Start dosing 

INIT_OK Query: 
Dosing started ? 
Dosing volume (setpoint actual value) < 500 liters? 

SLOW_DOWN Controller: 
Reduce the dosing speed shortly before reaching the required dosing 
volume 

END_DOSE Query: 
Dosing ended? 

CLOSE_LINE Controllers: 
Close all valves 
Turn off the pump 
Switch the dosing controller to manual mode  
Set dosing speed to 0 
Stop dosing 

CLOSE_OK Query: 
Is the pump turned off? 

END Reset: 
Switch the dosing controller to internal 
Close valves 
Turn off motor 

 
The plant operator can start, control, and monitor this chart on the operator station. 
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6.2.9 How to Create the Sequential Control System in the SFC Chart 

Introduction 
When you insert steps and transitions, the SFC Editor assigns continuous numbers. You 
then replace these numbers with descriptive, plant-specific names. 

Requirements 
● The "SFC_RMT1" SFC chart is open in the SFC Editor. 
● The"START" and "END" steps and "Transition 1" already exist. 

Procedure 
1. Select the View > Toolbar command if the toolbar buttons for inserting steps and 

transitions are hidden. 
This opens the toolbar 

2. Click the "Insert Step + Transition" button. 

 
The cursor transforms into a small cross and a circle with a bar. 

3. Position the cursor below Transition 1 until a green line is displayed and insert the object 
by clicking it. 
The program inserts step "3" and transition "2" into the SFC chart. 

4. Click the "Insert alternative branch" button. 

 
5. Position the cursor below the "START" step until a green line is displayed and insert the 

object by clicking it. 
The program inserts an alternative branch directly below the "START" step: The 
transitions "3" and "4" are inserted parallel to each other and step "4" below them. 

6. Click the "Insert Step + Transition" button. 

 
7. Position the cursor at the following positions and insert a step + transition: 

– Below transition 3 – step 5 and transition 5 are inserted 
– Below transition 4 – step 6 and transition 6 are inserted 
– Below transition 2 – step 7 and transition 7 are inserted 
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Result 
Your SFC chart should now appear as follows:  
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6.2.10 How to Rename Steps 

Requirements 
● The "SFC_RMT1" SFC chart is open in the SFC Editor. 
● All steps and transitions have been inserted 

Procedure 
1. Click the "Select" button. 

 
2. Select step "5". 
3. Select the menu command Edit > Object Properties. 

The "Properties" dialog box opens and the "General" tab is selected. 
The default entry "5" is already selected in the "Name" box. 

4. Change the "5" in the "Name" box to "INIT_LINE1". 

 
 

5. Click "Apply". 
The new name is saved. 

6. Click the "Down arrow". 
This brings you to step "4". 

7. Change the "4" in the "Name" box to "INIT_DOSE" and click "Apply". 
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8. Navigate to the other steps with the arrow buttons and change the names according to 
the table below. 
Each time you enter a new name, click "Apply". 

9. Click "Close". 
This saves your settings and closes the "Object Properties" dialog box. 

 
Default name New name 
 5 INIT_LINE1 - finished 
 4 INIT_DOSE - finished 
 3 SLOW_DOWN 
 7 CLOSE_LINE 
 6 INIT_LINE2 
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Result 
The changed names of the individual steps are displayed in the SFC chart. 
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6.2.11 How to Rename Transitions 

Introduction 
Just as you renamed the steps, you must also replace the default names of all transitions 
with descriptive, plant-specific names. Use the same procedure as you did for changing the 
names of the steps. 

Requirement 
The "SFC_RMT1" SFC chart is open in the SFC Editor. 

Procedure 
1. Select transition "3" and then select the menu command Edit > Object Properties.  

The "Object Properties" dialog box opens and the "General" tab is selected. 
2. Replace the default name in the "Name" box with a plant-specific name.  

The plant-specific names are listed in the following table. 
3. Each time you enter a name, complete the change by clicking the "Apply" button. 
4. Use the arrow buttons to move from one transition to the next. 
5. Click "Close".  

Your settings are saved and the "Object Properties" dialog box closes. 
 

 
Default name New name 
 3 DOSE_REA1 
 5 INIT_1_OK 
 1 INIT_OK 
 2 END_DOSE 
 7 CLOSE_OK 
 4 DOSE_REA2 
 6 INIT_2_OK 
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Result 
The changed names of the transitions are displayed in the SFC chart. 
Your SFC chart should now appear as follows:  
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6.3 Setting parameters 

6.3.1 How to Assign Parameters to the Steps of the SFC Chart 

Introduction 
From SFC, you assign values to the block inputs of the CFC charts. The initial settings for 
the sequence of the dosing process are made with the first "START" step. 
Each step for which you have defined an action is displayed in dark gray. This means that 
you can see at a glance whether or not a step has already had parameters assigned. 

Requirements 
● The "SFC_RMT1" SFC chart is open in the SFC Editor. 
● The names of the steps and transitions have been adapted. 

Procedure 
1. Click "START". 

The "Properties" dialog box opens and the "General" tab is selected. 
2. Switch to the "Initialization" tab.  

This tab displays an empty list with statement lines and the cursor is positioned in the left 
column of the first row. 

3. Click "Browse". 
The "Browse" dialog box opens with active "Plant view" tab.  
In this dialog, the plant hierarchy is displayed in the left section and the I/Os of the block 
you have selected in the plant hierarchy are shown in the right section. 
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4. Select the "Plant1/ RMT1/ FC111/ CFC_FC111/ CTRL_PID" block from tree view. 
The section on the right side shows all corresponding block connections. 

 
 

5. Double-click on the "AUT_L" input. 
The "Browse" dialog box goes to the background and the selected block I/O along with its 
full path is entered as the first address in line 1.  
The cursor is automatically positioned in the right column of line 1. 
 

 

  Note 
If you cannot read the name of the block I/Os, increase the width of the column. 

 
6. Enter the value "0" in this input box. 
7. Click "Apply". 

The value "0" is automatically replaced by "FALSE". The first assignment in the "Start" 
step is now complete. 
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The dialog box now appears as follows: 

 
 

8. Click the button with the number "2". This button is arranged directly in front of the 
statement line. 
This positions the cursor in the left column of the second line. 

9. Repeat steps 3 through 9 to define the remaining addresses for the "START" step. You 
will find the information you require in the table below. 

10. Click "Apply". 
11. Click the arrow button to navigate to the other steps and enter the addresses according to 

the tables below. 
 

 

 Note 
The addresses in the table are specified in the following format: 
[chart folder\chart name\block I/O] 
The"Plant1\RMT1" component is omitted because it is identical for all objects. This keeps the 
table easy to understand. As soon as you insert an additional plant or unit in the "color_gs" 
project, you must, of course, also pay attention to the assignment of the chart to the plant 
hierarchy. 
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No. Address 1 Address 2 Meaning 
 1 Completed already: 

FC111\CFC_FC111\ CTRL_PID.AUT_L 
FALSE Controller manual 

 2 FC111\CFC_FC111\CTRL_PID.SP_EXT FC111\ADDIT\CFC_SET
P\PARA_DOS_RM1_QT
Y.V 

Setpoint for flow control  

 3 FC111\CFC_FC111\CTRL_PID.LMN_SE
L 

FALSE No tracking  

 4 FC111\CFC_FC111\DOSE.L_START FALSE Dosing stopped 
 5 FC111\CFC_FC111\INT_P.TRACK TRUE Track integrator  
 6 LI111\CFC_LI111\INT_P.TRACK TRUE Track integrator 
 7 NK111\CFC_NK111\VALVE.AUT_ON_O

P 
Auto Valve in automatic mode

 8 NK112\CFC_NK112\VALVE.AUT_ON_O
P 

Auto Valve in automatic mode

 9 NK113\CFC_NK113\VALVE.AUT_ON_O
P 

Auto Valve in automatic mode

 10 NK114\CFC_NK114\VALVE.AUT_ON_O
P 

Auto Valve in automatic mode

 11 NP111\CFC_NP111\MOTOR.AUT_ON_
OP 

Auto Motor in automatic 
mode 

 12 LI111\CFC_LI111\INT_P.HOLD FALSE Hold output value 

 
 

 Note 
When entering the addresses, verify that you have selected the required step based on the 
title bar of the "Properties" dialog box. 
If you have inadvertently closed the "Properties" dialog box, double-click on the step you are 
currently editing to reopen the dialog box.  
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6.3.2 Parameters for the Steps 

Parameters for the "INIT_LINE1" Step 
The following table shows the parameters for the "INIT_LINE1" step: 

 
No. Address 1 Address 2 Meaning 
 1 NK111\CFC_NK111\VALVE.AUTO_OC TRUE Open valve 
 2 NK112\CFC_NK112\ VALVE.AUTO_OC TRUE Open valve 
 3 NK113\CFC_NK113\ VALVE.AUTO_OC TRUE Open valve 
 4 NP111\CFC_NP111\MOTOR.AUTO_ON TRUE Turn on motor 

Parameters for the "INIT_LINE2" step 
The following table shows the parameters for the "INIT_LINE2" step: 

 
No. Address 1 Address 2 Meaning 
 1 NK111\CFC_NK111\VALVE.AUTO_OC TRUE Open valve 
 2 NK112\CFC_NK112\ VALVE.AUTO_OC TRUE Open valve 
 3 NK114\CFC_NK114\VALVE.AUTO_OC TRUE Open valve 
 4 NP111\CFC_NP111\MOTOR.AUTO_ON TRUE Turn on motor 

Parameters for the "INIT_DOSE" Step 
The following table shows the parameters for the "INIT_DOSE" step: 
 
No. Address 1 Address 2 Meaning 
 1 FC111\CFC_FC111\CTRL_PID.SP_EX

T 
FC111\ADDIT\CFC_SET
P\PARA_DOS_RM1_QT
Y.V 

Active setpoint for flow 
control 

 2 FC111\CFC_FC111\CTRL_PID.AUT_L TRUE Controller automatic mode
 3 FC111\CFC_FC111\DOSE.SP_EXT FC111\ADDIT\CFC_SET

P\ 
PARA_DOS_RM1_VOL.V 

Active setpoint for dosing 
volume  

 4 FC111\CFC_FC111\DOSE.L_START TRUE Start dosing 
 5 FC111\CFC_FC111\INT_P.TRACK FALSE Integrator after setpoint 

correction 
 6 FC111\CFC_FC111\INPUT_U.SIM_V 50.0 Simulation: 50 liters/min 

flow simulated 
 7 FC111\CFC_FC111\INPUT_U.SUBS_V 50.0 Substitute value for the 

simulation value SIM_V 
 8 LI111\CFC_LI111\INT_P.TRACK FALSE No correction for 

integrator  
 9 LI111\CFC_LI111\INPUT_U.SIM_V FC111\ADDIT\CFC_SET

P\ 
PARA_DOS_RM1_VOL.V 

Simulation value for the 
dosing quantity 

 10 LI111\CFC_LI111\INPUT_U.SUBS_V FC111\ADDIT\CFC_SET
P\ 
PARA_DOS_RM1_VOL.V 

Substitute value for the 
simulation value SIM_V 
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Specify run time - "INIT_DOSE" Step 
1. Change to the "General" tab. 
2. Enter the value "8s" in the "Minimum" box in the "Run times" group. 
3. Click "Apply" 

PCS 7 automatically changes the value to "T#8s". 

Parameters for the "SLOW_DOWN" Step 
The following table shows the parameters for the "SLOW_DOWN" step: 

 
No. Address 1 Address 2 Meaning 
 1 FC111\CFC_FC111\CTRL_PID.SP_EXT 10.0 Reduction of the flow 

setpoint  
 2 FC111\CFC_FC111\INPUT_U.SIM_V 10.0 Simulation: 10 liters/min 

flow simulated 
 3 FC111\CFC_FC111\INPUT_U.SUBS_V 10.0 Substitute value for the 

simulation value SIM_V 

Parameters for the "CLOSE_LINE" Step 
The following table shows the parameters for the "CLOSE_LINE" step: 
 
No. Address 1 Address 2 Meaning 
 1 NK111\CFC_NK111\VALVE.AUTO_OC FALSE Close valve 
 2 NK112\CFC_NK112\ VALVE.AUTO_OC FALSE Close valve 
 3 NK113\CFC_NK113\ VALVE.AUTO_OC FALSE Close valve 
 4 NK114\CFC_NK114\VALVE.AUTO_OC FALSE Close valve 
 5 NP111\CFC_NP111\MOTOR.AUTO_ON FALSE Turn off motor 
 6 FC111\CFC_FC111\CTRL_PID.LMN_SEL TRUE Correction of the manipulated 

variable to 0 value  
(close valve) 

 7 FC111\CFC_FC111\CTRL_PID.SP_EXT 0.0 Active setpoint for flow control 
 8 FC111\CFC_FC111\CTRL_PID.AUT_L FALSE Controller manual mode  
 9 FC111\CFC_FC111\DOSE.L_START FALSE Dosing stopped 
 10 FC111\CFC_FC111\INPUT_U.SIM_V 0.0 Simulation: Flow volume  

0 liters/minute simulated 
 11 FC111\CFC_FC111\INPUT_U.SUBS_V 0.0 Substitute value for the simulation 

value SIM_V 
 12 LI111\CFC_LI111\INT_P.HOLD TRUE Track integrator 
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Parameters for the "END" Step 
The following table shows the parameters for the "END" step: 

 
No. Address 1 Address 2 Meaning 
 1 FC111\CFC_FC111\CTRL_PID.AUT_L FALSE Reset input 
 2 FC111\CFC_FC111\CTRL_PID.LMN_SEL FALSE No correction of manipulated 

variable 
 3 NK111\CFC_NK111\VALVE.AUTO_OC FALSE Close valve 
 4 NK112\CFC_NK112\ VALVE.AUTO_OC FALSE Close valve 
 5 NK113\CFC_NK113\ VALVE.AUTO_OC FALSE Close valve 
 6 NK114\CFC_NK114\VALVE.AUTO_OC FALSE Close valve 
 7 NP111\CFC_NP111\MOTOR.AUTO_ON FALSE Turn off motor 
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6.3.3 How to Assign Parameters to the Transitions of the SFC Chart 

Introduction 
A transition contains the conditions according to which a sequential control system passes 
control from one step to the next. In principle, you assign parameters for the transitions in the 
same way as for the steps.  

Requirements 
● The "SFC_RMT1" SFC chart is open in the SFC Editor. 
● The default names of the steps and transitions have been adapted. 

Procedure 
1. Click the "DOSE_REA1" transition. 

The "Properties" dialog box opens with active "General" tab. 
2. Change to the "Condition". 

This tab returns a blank list, that is, the statement lines. The cursor is positioned in the left 
column of the first line. The layout of the dialog box is the same as you saw when the 
assigning parameters for the steps. 

3. Assign the parameters for the "DOSE_REA1" transition. You will find the entries required 
in the following table. Below you can see an overview of the steps as a reminder: 
– For address 1, click the "Browse" button to open the "Browse" dialog box and select 

the relevant I/O 
– Enter address 2 
– Apply your settings 
– Select a new line 
– etc. 

4. Select the new transition and enter the addresses. 
 

 

  Note 
When entering the addresses, verify that you have selected the required transition based 
on the title bar of the "Properties" dialog box. 
Just as with the parameters for steps, the addresses in the table are specified in the 
following format: 
[chart folder\chart name\block I/O]. 
The plant hierarchy is omitted. 
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6.3.4 Parameters for the Transitions 

Parameters for the "DOSE_REA1" transition 
The following table shows the parameters for the "DOSE_REA1" transition: 

 
No. Address 1 Operato

r 
Address 2 Meaning 

 1 FC111\ADDIT\CFC_SETP\ 
PARA_DOS_RM1_SEL.Q0 

= FALSE Dosing in reactor 1? 

 2 FC111\ADDIT\CFC_SETP\ 
PARA_DOS_RM1_VOL.V 

> 0.0 Dosing volume greater than 
0? 

 

Parameters for the "INIT_1_OK" transition 
The following table shows the parameters for the "INIT_1_OK" transition 
 

 
No. Address 1 Operato

r 
Address 2 Meaning 

 1 NP111\CFC_NP111\MOTOR.QRUN = TRUE Motor on? 
 2 FC111\CFC_FC111\ 

CTRL_PID.QSPEXTON 
= TRUE Controller set to external 

setpoint? 

 

Parameters for the "INIT_OK" transition 
The following table shows the parameters for the "INIT_OK" transition 
 

 
No. Address 1 Operato

r 
Address 2 Meaning 

 1 FC111\CFC_FC111\DOSE.QSTRTDOS = TRUE Dosing started ?  
 2 FC111\CFC_FC111\DOSE.ER <  200.0 Dosing quantity:  

Setpoint – actual value < 200 
 liters? 

 3 FC111\CFC_FC111\DOSE.ER >  0.0 Dosing quantity:  
Setpoint – actual value 0 
> liters? 
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Parameters for the "END_DOSE" transition 
The following table shows the parameters for the "END_DOSE" transition: 
 

 
No. Address 1 Operato

r 
Address 2 Meaning 

 1 FC111\CFC_FC111\DOSE.QEND_DOS = TRUE Dosing ended?  

 

Parameters for the "CLOSE_OK" transition 
The following table shows the parameters for the "CLOSE_OK" transition: 
 

 
No. Address 1 Operato

r 
Address 2 Meaning 

 1 NP111\CFC_NP111\MOTOR.QRUN = FALSE Motor off? 

 

Parameters for the "INIT_2_OK" transition 
The following table shows the parameters for the "INIT_2_OK" transition: 
 

 
No. Address 1 Operato

r 
Address 2 Meaning 

 1 NP111\CFC_NP111\MOTOR.QRUN = TRUE Motor on? 
 2 FC111\CFC_FC111\ 

CTRL_PID.QSPEXTON 
= TRUE Controller set to external 

setpoint? 

 

Parameters for the "DOSE_REA2" transition 
The following table shows the parameters for the "DOSE_REA2" transition: 
 

 
No. Address 1 Operato

r 
Address 2 Meaning 

 1 FC111\ADDIT\CFC_SETP\ 
PARA_DOS_RM1_SEL.Q0 

= TRUE Dosing in reactor 2? 

 2 FC111\ADDIT\CFC_SETP\ 
PARA_DOS_RM1_VOL.V 

> 0.0 Dosing volume greater than 
0? 

 
Close the SFC chart. 
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6.3.5 How to Optimize the Run Sequence 

Introduction 
PCS 7 provides you with a function for optimizing the run sequence based on the data flow. 
You use this function when you have completed the configuration of the CFC and SFC 
charts. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. In the tree view, select any folder in which you have saved a CFC chart. 
2. Select a CFC chart from the detail view, and then select the menu command Edit > Open 

Object. 
The chart opens in the CFC editor. 

3. Select Options > Optimize run sequence.... 
The message dialog "The run sequence of the blocks will be changed ...." opens. 

4. Click "OK". 
The run sequence is optimized. 

5. Close the CFC chart. 
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6.3.6 Current Status of Your Project 

Completed configuration tasks 
What have you learned during the SFC configuration? 
● You have worked with standard functions such as renaming and opening. 
● You have created a sequential control system with graphic support. 
● You have renamed and assigned parameters to the steps and transitions of the 

sequential control system. 
● You have optimized the run sequence. 
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Compiling, downloading and testing the charts 7
7.1 Overview of Compiling, Downloading, and Testing 

Overview 
This tutorial will explain the following to you: 
● How to compile the program you have created with CFC and SFC. 
● How to download your program to the CPU. 
● How to run your program in test mode. 
This allows you to check the correct functionality of the charts. You already been introduced 
to the "Download" function when you downloaded the hardware configuration. 
You perform two steps in conjunction with creating the chart: 
● First, you compile and download the blocks and charts – for this task, you use the 

"Compile and Download Objects" function. 
● Then, you test the program – you can test both in the SFC Editor and in the CFC Editor. 
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7.2 How to Compile and Download CFC and SFC Charts 

Introduction 
You have created the CFC and SFC charts for your "color_gs" project. These charts must be 
compiled and loaded in a CPU for the automation functions to be executed by the AS. The 
compile and download operation are started in a common dialog box and run one after the 
other. 

Requirements 
● The green "RUN" LED on the CP is active. 
● The CPU is in "STOP" mode. 
● The example project is open in SIMATIC Manager. 
● The component view is activated. 
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Procedure 
1. Select the "color_gs_MP/ color_gs_Prj/ SIMATIC 400(1)"  

folder from the tree view. 
2. Select the menu command PLC > Save and Compile Objects.... 

The "Save and Compile Objects" dialog box opens. 
3. Click "+" to expand the tree view. 

The view shows a structure of the "color_gs" project which is basically similar to the 
component view of SIMATIC Manager. 
The view shows status or operating state information for each object: 
 

 
 

 
4. Select the "Compile" and "Download" check boxes for the "Charts" object. 
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5. Select the "Charts" entry and click "Edit..." in the "Settings for Compilation/Download" 
area. 
The "Compile Program / Download to Target System" dialog box opens and the "Compile 
Charts as Program" tab is selected. The "Entire program" option is automatically selected 
since you are starting the compile and download operation for the first time. 
 

 

  Note 
If you have discovered errors in your program during testing, you must correct your CFC 
and SFC charts to eliminate the errors. When you restart the compiling and downloading 
thereafter, make sure that you select the "Changes only" option.  
This will save you a considerable amount of time when compiling and downloading. 
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6. Activate the "Generate module drivers" check box.  
This option generates the module drivers for the signal-processing blocks. 
 

 

  Note 
You can remove empty runtime groups by selecting the menu command Edit > Delete 
Empty Runtime Groups. 

 

 
 

 
7. Click "OK" to apply your settings. 

The dialog closes and the message "Remember that if you download later (...), the blocks 
will be deleted on the CPU" opens. 

8. Click "OK". 
9. Check the settings of the following check boxes in the lower area of the "Compile and 

Download Objects" dialog box: 
– Compile only: deactivated 
– Do not load if compilation error is detected activated 
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10. Click the "Start" button to start the compile and download operation. 
The message "Downloading program changes during operation can, in the case of 
malfunctions or program errors, cause serious damage to personnel and equipment!" 
Make sure..." opens. 

11. Click "OK". 
The message dialog "If you want to download changes online, please make sure that ... 
Do you want to continue?" opens. 

12. Click "Yes". 
The compile and download operation starts. 
 

 

  Note 
The progress display indicates which step PCS 7 is currently performing, for example: 
• "Compiling and downloading object" 
• "Compiling charts as program" 

 
When the operation is finished, the log file opens in a text editor. 
 

13. Ignore the message: 
" ...-> Object compilation was executed (with warnings). 
The message is generated because you have not yet integrated I/O modules in your 
project. 

14. Close text editor. 
The status in the "Charts" line is now "downloaded". 
 

 

  Note 
If warnings or errors are shown in the log file following compilation, select the "Charts" 
object in the tree view and click "Single Object". This opens the "Logs" dialog box. There 
you can view the detailed warnings and error messages. 

 
15. Click "Close" in the "Compile and Download Objects" dialog box. 

The dialog box closes. 
16. Start the CPU. 
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7.3 Testing the Program 

Introduction 
You can test your program both in the SFC Editor and in the CFC Editor. In test mode, you 
can watch how the values change during the course of the process. Using test mode, you 
can make sure that your configured sequential control system runs free of errors. 

Test mode in SFC 
The test is made in the SFC Editor that you already got to know when you created the SFC 
chart: The "Properties" dialog box plays a central role in test mode. 
If you double-click on a step or a transition in the SFC chart, the "Properties" dialog box 
opens. Just as during creation of the SFC chart, you can use the arrow buttons to change 
from one step or transition to the next. In test mode, the dialog boxes also provide additional 
information: 
● In the properties dialog of a step, you see the actual values on the left beside address 1 

and the setpoints on the right beside address 2. 
● In the properties dialog of a transition, you see the respective current values to the left of 

address 1 and to the right of address 2. 
 

 

NOTICE  
 

You can modify all values in the white fields. Remember, however, that these values are 
written directly into your configuration data and therefore change the parameters of your 
SFC chart. 
While working through the Getting Started, you will not change any values; rather, you 
will use the "Properties" dialog boxes only for the purpose of monitoring. 

 

Test mode in CFC 
You start the test mode in CFC in the CFC Editor. You will be able to have the process 
values displayed at the individual block I/Os and to monitor the changes. 
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7.4 How to Test the Program in the SFC Editor 

Introduction 
After you have compiled and downloaded the program you can run it in test mode. This way 
you can check if the sequential control system is working and the program is running 
correctly. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "SFC_RMT1" SFC chart is open in the SFC Editor. 
● The CPU is in "RUN" mode. 

Working in test mode 
1. Select the menu command Test > Test mode. 

The program enables test mode. 
– In the title bar of the SFC Editor, the name "SFC_RMT1 – color_gs_Prj\Plant1\RMT1 

ONLINE" is shown on a colored background. 
– In the lower part of the SFC editor, you can see the status of the program, the 

operating mode, and the step control mode. The operating mode is set to "MANUAL" 
by default. The current step control mode is displayed in the drop-down list and is set 
to "T" by default. 

– In the lower part of the SFC Editor, there are also buttons for controlling the SFC 
chart, for example, for starting, holding, resuming.  

2. Select the menu command Test > Step Control Mode > T or M. 
This mode activates an additional "O" command button next to the transition while the 
SFC chart is running. 
The run sequence reacts as described by the table below. 

3. Click the "Start" button to run the program. 
The SFC chart starts. 
– Each step that is currently being executed is displayed in light green and with a small 

arrow pointing right. 
– Steps that have already been worked through are displayed in dark green and with a 

small check mark. 
– Transitions that are active but not yet satisfied are shown on a brown background. 
– If you performed your configuration correctly, the entire SFC chart will be worked 

through to the end and all the steps will turn dark green and have a check mark beside 
them. Otherwise, you can click the "C" button to manually enable the next step 
although the transition is not satisfied. 

4. Select the menu command Test > Test mode. 
Test mode closes. 
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Characteristics of the sequential control system 
 
If the chart… … the sequential control system will do the following: 
is free of errors the sequential control system is executed step-by-step according to the configured 

parameters. You do not need the button. 
contains errors the sequential control system stops if the transition is not satisfied. You can click the "C" 

button to pass control to the next step regardless of whether the transition is satisfied. 
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7.5 How to Test the Program in the CFC Editor 

Introduction 
You can test CFC charts in the CFC Editor in the same way as SFC charts. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 
● The "SFC_RMT1" SFC chart is open in the SFC Editor. 
● The "CFC_FC111" CFC chart is open in the CFC Editor. 

Procedure 
1. Select the menu command Test > Test mode. 

Test mode is activated. 
2. Press the "CTRL" key and select the following blocks: 

– CTRL_PID 
– INPUT_U 
– DOSE 

3. Select the menu command Test > Monitoring On. 
All block connections which are enabled for debugging in the block properties are 
displayed. 

4. Switch to the "SFC_RMT1" SFC chart. 
5. Click the "Start" toolbar button. 

This starts the program. 
6. Switch to the "CFC_FC111" chart. 

You can monitor all changes to values in this chart: for example, the current value of the 
dosed volume is displayed at the  "PV_OUT" output of the "DOSE" block. 
 

 

  Note 
Arrange the windows one beside the other to be able to watch the CFC and the SFC 
chart at the same time in test mode. 

 
7. Select the menu command Test > Test mode. 

This closes test mode. 
8. Close the SFC Editor and the CFC Editor. 
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7.6 Current Status of Your Project 

Completed Configuration Tasks 
By this time, you have completed almost all of the configuration steps in SIMATIC Manager 
and in the CFC Editor and SFC Editor. You have compiled and downloaded this 
configuration, and you have observed the project execute in the SFC and CFC Editors. 
This enabled you to make sure that your configuration is thus far error-free. If you find that 
your project has errors when it runs in the test mode, it is much easier to located the error at 
this stage than after the entire project is completed. 
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Configuring the operator station 8
8.1 Operator Station in Process Mode 

Purpose of the Operator Station 
The plant operator can operate and monitor the process on the operator station (OS) in 
process mode. So-called process pictures are displayed to the operator for this purpose. The 
automation system (AS) controls the process (open-loop and closed-loop control) and the 
OS reads the process values from the AS and displays the values graphically in the process 
pictures. Warnings and alarms are also displayed in the process pictures as soon as process 
values reach or exceed certain specified limits. This allows the operator to identify the 
location in the plant at which a problem occurs. 
You will create one process picture for your "color_gs" project that will allow you to observe 
the fill level of the raw material container, the status of the valves etc.  

8.2 Configuring the Operator Station 

The operator station in the project 
At the time you created a project with the PCS 7 "New Project" wizard, PCS 7 automatically 
created an operator station. You have already configured this operator station in HW Config. 
You have not, however, created a network connection for this OS as you did for the 
communication between the automation system and the engineering station to enable you to 
download data from the ES to the AS. This is not necessary for the "color_gs" project 
because the engineering station and the operator station are on the same computer and the 
operator station uses the same connection to the AS as the ES. 

Process pictures in the project 
The PCS 7 wizard also creates pictures automatically in the plant hierarchy, which you then 
configure in the OS. Larger projects have multiple process pictures for the various 
components of the plant. For the "color_gs" project, you only have to configure a single 
picture. During configuration you will nevertheless become familiar with all the basic 
functions of the OS. 
Pictures are labeled with the following icon:  
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8.3 Working in the SIMATIC Manager 

8.3.1 Preparations in SIMATIC Manager 

Overview 
Before you start to configure in the OS, there are a few preliminary steps to be performed in 
SIMATIC Manager: 

 
Step What? 
 1 Adapt picture names and activate the function for creating block icons (Page 158) 
 2 Delete unnecessary pictures (Page 160) 
 3 Create block icons (Page 161) 
 4 Compile OS  (Page 164) 

Editing the picture properties 
Since the PCS 7 "New Project" wizard has already created pictures, these pictures have 
default names, just like the CFC chart. You first have to adapt these default names to suit 
your project requirements by assigning short descriptive names to them. 
You also need to activate the function for creating block icons. 

Deleting unnecessary pictures 
When you create a project with the PCS 7 wizard, pictures are automatically inserted in 
every hierarchy folder of the plant hierarchy. Since you only require one picture in your 
"color_gs" project, you must remove the unnecessary pictures from the PH. 

Creating block icons 
PCS 7 provides you with the "Create block icons" function. Block icons are inserted in 
process pictures and provide the operator with the most important information on a process 
tag at a glance. For example, in the block icon for a controller, the operator sees the process 
value (PV), the setpoint (SP) and the manipulated value (OUT). The block icon for a 
controller is displayed in a process picture as shown below: 
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Compiling the OS 
You must execute the "Compiles OS" function after you finish configuring all of the data in 
SIMATIC Manager and before you start configuring the OS data of the OS. All the data from 
SIMATIC Manager, such as variables, messages, texts, plus the hardware and connection 
configurations must be "made known" to the OS. 

Starting the OS 
You have to start the OS to continue configuring it. You then perform other steps in WinCC 
Explorer. 



Configuring the operator station  
8.3 Working in the SIMATIC Manager 

 PCS 7 - Getting Started - Part 1 
158 Getting Started, 09/2007, A5E00857261-02 

8.3.2 How to Edit Picture Properties 

Introduction 
You make the following settings for editing the picture properties: 
● Change the name of the picture 
● Select the option for creating block icons 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure for Changing the Picture Name 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1" folder from the tree view. 
2. Select the picture "Picture(3)" in the detailed window. 
3. Select the Edit > Object Properties command.  

The "Properties - WinCC Picture: Picture(3)" dialog box opens with active "General" tab. 
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4. Change the default name "Picture(3)" to "RMT1" in the "Name" box. 

 
 

5. Click "Apply" to enter your settings. 

Procedure for Creating Block Icons 
1. Change to the "Block icons" tab. 
2. Select the "Derive block icons from the plant hierarchy" check box. 
3. Click "OK" to save your entries. 

The program closes the dialog box and displays the new picture name in the plant 
hierarchy. 

Video  
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8.3.3 How to Delete Unnecessary Pictures 

Introduction 
The PCS 7 "New Project" wizard creates a picture in every hierarchy folder by default. In the 
"color_gs" project, you require only one picture since all the required data can be 
represented clearly in one picture. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "Plant1" folder in the tree view. 
2. Select the picture "Picture(2)" in the detailed window. 
3. Press <DEL>. 

The "Delete" dialog box opens. 
4. Click "Yes". 

The program deletes the picture. 
5. Repeat steps 1 through 4 for the following folders in the plant hierarchy: 
 

 
Name of the Folder Name of the Picture 
FC111 Picture(4) 
ADDIT Picture(5) 
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8.3.4 How to Create Block Icons 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 
● The option for creating block icons is selected. 
You can information about these settings in the section "How to Work with Picture Properties 
(Page 158)". 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ Plant1/ RMT1" folder from the tree view. 
2. Select the Options > Plant Hierarchy > Create/Update Block Icons... command. 

The "Create/Update Block Icons" dialog box opens. The list contains the pictures for 
which block icons have been created. In this Getting Started, the picture is called 
"Plant1\RMT1\RMT1". 
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3. Check the following settings: 
– Check box in front of the "Plant1\RMT1\RMT1" picture is selected. 
– The value "1" is entered in the "Lower hierarchy levels included" box. 

 
 



 Configuring the operator station 
 8.3 Working in the SIMATIC Manager 

PCS 7 - Getting Started - Part 1 
Getting Started, 09/2007, A5E00857261-02 163 

4. Click "OK". 
The program starts generation of the block icons.  
The message dialog "For any later... you must subsequently compile the participating 
operator stations... Do you want to view the function log now?". 

 
 

5. Click "No". 
The program completes generation of the block icons and closes the dialog box. 

For the moment, you cannot see any visible results of this function. Only when you open the 
process picture for the "color_gs" project do the block icons that were created become 
visible. 
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8.3.5 How to Compile the OS 

Introduction 
Before configuring the data in the OS, you have to compile the OS. With this function, all the 
data from SIMATIC Manager, such as variables, messages, texts, plus the hardware and 
connection configurations are "made known" to the OS. Do not confuse compiling with 
downloading: When you compile, the data remains on the engineering system computer – it 
is simply made known to the OS so that you can access this data during configuration. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated. 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ [name of the SIMATIC PC station]" entry from the tree view. 
2. Select the menu command PLC > Save and Compile Objects.... 

The "Save and Compile Objects" dialog box opens. 
3. Open the tree view and select the "Compile" check box for the "OS(1)" object. 
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4. Select the "OS(1)" object and click "Edit". 
The "Which areas do you want to assign to operator station OS(1)?" dialog box opens. 
You can ignore this setting as you have not yet created more than one area / one OS in 
this project. 
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5. Click "Next >". 
The "Select the network connections for the S7 programs associated with the areas" 
dialog box opens. 
In the "S7 programs and network connections" group, you will find the entry "S7 
connection" and the subnet "Sym. conn.": This is the connection that the automation 
system and operator station use for communication and that you already created in 
NetPro. 

 
 

6. If no connection is displayed here, click "Connection...". 
Select the S7 connection you have made in NetPro from the "Select network connection" 
dialog box and then click "OK". 
The selected connection is entered. 

7. Click "Next". 
The "Select the data you want to compile and the scope of the compilation" step opens. 
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8. Select the following check boxes and options: 
 

 
Area Check box / option 
"Data" "Tags and messages" 

"SFC visualization" 
"Picture tree" 

"Scope" "Entire OS with memory reset" 

 

 
 

1. Click "Apply". 
2. The dialog box "Settings: Download OS" opens. 

The message dialog "If you want to download changes online... Do you want to 
continue?" opens. 

3. Click "Yes". 
Compilation is started and a progress bar is displayed. 
When compilation is completed, the log file opens in a text editor to show you whether or 
not the compilation was executed without error. 

4. Close the text editor. 
5. Click "Close" in the "Compile and Download Objects" dialog box. 
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8.3.6 How to Start the OS 

Introduction 
You have now completed all the preparation steps for configuring the OS in SIMATIC 
Manager, and you can now start to configure the OS. To do so, first open the OS. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Select the  

"color_gs_MP/ color_gs_Prj/ SIMATIC PC-Station/ WinCC Application/ OS(1)" object from 
the tree view. 

2. Select the Edit > Open Object command. 
the PCS 7 OS - WinCC Explorer opens. 
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8.4 Working on the OS 

8.4.1 Structure of the OS - WinCC Explorer 

Introduction 
WinCC Explorer provides you with a series of editors that you can use to configure an OS. 
But for configuring the OS you will only use a few of these editors. 

What is the basic structure of WinCC Explorer ? 
In principle, the structure of WinCC Explorer is very similar to Windows Explorer:: 
● In the left pane, there is a navigation window. Here, you will find all the editors for 

configuring the PCS 7 OS. 
● In the right pane, there is a detailed window in which detailed information on the entry 

selected in the navigation window is displayed. 
You only work with Graphics Designer in the "color_gs" project. This is the tool you use to 
create process pictures. You do not require any other editors to configure the OS. 
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8.4.2 Function of process pictures 

Process Pictures 
Process pictures represent the process-related equipment to the operator. The process is 
operated here and system statuses are displayed. 
The process picture you will create for the "color_gs" project already exists in the plant 
hierarchy in SIMATIC Manager. 
You edit the process picture in the "Graphics Designer" editor. You insert the desired static 
and dynamic objects and interconnect them. 
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8.5 Working in general with the Graphics Designer 

8.5.1 Introduction to the Graphics Designer 

User Interface 
The Graphics Designer is one of the editors of the OS. The user interface of the Graphics 
Designer is structured as follows: 
● On the left side, you will see a color palette that you can use to assign certain colors to 

the objects. 
● In the middle is the drawing board on which you insert the objects for the process picture. 
● In the right section, you will see the object palette. This is the library containing the 

various standard objects provided by the Graphics Designer. You will also see a style 
palette on the right side that you use to format the objects. 

Libraries 
The libraries of the Graphics Designer contain a wide selection of ready-to-use graphic 
elements, such as piping and valves. You can modify these elements or add to them and 
store them in your own project libraries so that they are available to you at any time. 

Objects 
The Graphics Designer distinguishes between two different types of objects: 
● Static objects – these objects are purely drawing objects as you would find in a drawing 

program, for example lines, circles, polygons or static text. 
● Dynamic objects -- these objects are made dynamic via a connection to a block I/O (tag). 

In process mode these objects always display the current values of a process tag of the 
process cell. In the "color_gs" project, you will get to know various dynamic objects. 
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8.5.2 How to Open a Process Picture 

Introduction 
You edit the process picture in the OS. You use the "Graphics Designer" editor for this. 

Requirement 
The example project is open in WinCC Explorer. 

Procedure 
1. Select the "Graphics Designer" entry on the navigation window. 

The detail view shows all pictures belonging to the project. All the default pictures and 
template pictures provided by PCS 7 are, of course, also displayed. These can be 
identified by the "@" character in front of the name. 

2. Double-click the "RMT1.pdl" picture file in the detail view. 
The process picture opens in Graphics Designer.  
The view shows that this process picture already contains objects although you have not 
yet inserted any. These are the block icons that you created in the process picture with 
the "Create block icons" function in SIMATIC Manager. You can also see that the block 
icon for the valve has been inserted both in the horizontal alignment and vertical 
alignment variants. These two variants are influenced by the setting in the process object 
view in the "Picture Objects" tab that you made when assigning parameters for the CFC 
charts. 

 
  

 

  Note 
The sequence of the block icons in your process picture may differ from the sequence in 
the diagram above 
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8.5.3 How to Open the Various Toolbars 

Introduction 
The most important toolbars and palettes are open by default. If you inadvertently close 
toolbars or palettes, you should know how to make them visible again. 

Requirement 
The process picture is open in the Graphics Designer. 

Procedure 
1. Select the menu command View > Toolbars. 

The "Toolbars" dialog box opens. Here, you see all the toolbars provided by the Graphics 
Designer. 

2. Make the same settings for the toolbars as shown in the screenshot of the dialog box: 

 
 

3. Click "OK" to apply your settings. 
This displays the selected toolbars in the object palettes. 

The object palette contains two tabs: 
● "Standard" tab 
● "Controls" tab 
In Getting Started, you will only use the "Standard" tab. 
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8.5.4 Objects in the Graphics Designer 

Objects in the Graphics Designer 
Before you get started on the actual configuration in the Graphics Designer, it is time for 
some theory relating to the various objects that you will use to create the "RMT1.pdl" 
process picture. These objects include the following: 
● Static Objects 
● Text Fields 
● I/O fields 
You also receive some background information on interconnecting tags – this is the way you 
create the relationship between the process picture and the process tag. 

8.5.5 What Are Static Objects? 

Static Objects 
To visualize equipment, such as a pipe or a tank, you require static objects.  These objects 
do not change while in process mode; in other words, they are not influenced by a status or 
by a value of a process tag. 

8.5.6 What Are Text Fields? 

Text Fields 
In a text field, you can enter any information that you want the plant operator to see in the 
process picture. You can, for example, insert a text field to allow you to label objects and to 
simplify the assignment of the picture objects to the process for the operator. You can enter 
any text in these text fields and can position the text fields anywhere in the process picture.  
For the "color_gs" project, you will insert text fields with appropriate labels for all the process 
tags. 
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8.5.7 What Are I/O Fields? 

I/O fields 
I/O fields are used for inputting and outputting values. There are different types of I/O fields: 
● Output field 
● Input field 
● Combined input and output field 
I/O fields can process different data formats, such as binary, decimal, string, hexadecimal. 
Just as for all other objects, you can also select different formats and make different settings 
for I/O fields. 
In the "color_gs" project, you will use an I/O field to selectively control dosing to either 
reactor 1 or 2.  

8.5.8 How Does Tag Interconnection Work? 

Tag interconnection 
Tag interconnection is a central function when you create process pictures: Objects are 
entered in the process picture that represent the process values of a process tag in the 
process mode. With the tag interconnection, you create the connection between the object in 
the process picture and the actual process tag. This enables the OS to receive data from the 
AS, to display the data in the process picture and to update the data. 
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8.6 Creating the process picture 

8.6.1 How to Insert Pipes and a Tank into the Process Picture 

Requirements 
● The "RMT1" process picture is open in the Graphics Designer. 
● The block icons are available. 

Do not yet start editing these icons. You must first create a picture of the equipment with 
the static objects before you can move the icons to the positions where they require 
information. 

Procedure 
1. Select the menu command View > Library. 

This opens the OS libraries. 
2. Select the "Global Library/PlantBlocks/Tanks/Tank4" and move it to the drawing board 

using a drag-and-drop operation. 
 

 

  Note 
Click on the "Eyeglasses" button in the toolbar to obtain a preview of the graphic objects.

Video 

 
 

3. Drag additional objects to the drawing board as shown in the table below. 
4. Close the library. 
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5. Select an object and adapt its size and position to match the following picture: 
– You can move the object by positioning the mouse pointer on the object, holding down 

the mouse button and dragging the object to the required location. 
– You can increase or decrease the size of the object by positioning the mouse pointer 

on the corner handles of the object, holding down the mouse button, and dragging to 
make the object larger or smaller. 

 
Name of the object Number Path in the library 
Horizontal pipes  3 x Global Library/PlantElements/Pipes - Smart Objects/3D Pipe 

Horizontal 
Vertical pipes  5 x Global Library/PlantElements/Pipes - Smart Objects/3D Pipe Vertical 
Angle  1 x Global Library/PlantElements/Pipes - Smart Objects/3D Pipe Elbow 1 
Angle  1 x Global Library/PlantElements/Pipes - Smart Objects/3D Pipe Elbow 2 
Angle  1 x Global Library/PlantElements/Pipes - Smart Objects/3D Pipe Elbow 3 
Angle  1 x Global Library/PlantElements/Pipes - Smart Objects/3D Pipe Elbow 4 
Control valve  1 x Global Library/Symbols/Valves/30 
Tanks representing reactors  2 x Global Library/Siemens HMI Icon Library/Tanks/Tank1 
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8.6.2 Labeling the Parts of the Plant 

Overview 
The parts of the plant are labeled in three separate steps: 
 
Step What? 
 1 Insert and Format Text Field (Page 179) 
 2 Set Text Field (Page 180) 
 3 Duplicate Text Field (Page 181) 

8.6.3 Step 1 - How to Insert a Text Field 

Requirements 
● The "RMT1.pdl" process picture is open in the Graphics Designer. 
● The static objects have been inserted. 

Procedure 
1. Select "Standard Objects/Static Text" in the object palette. 
2. Use the mouse to navigate to the drawing area. 

The mouse pointer transforms into a small text input symbol. 
3. Draw a text field next to the reactor. 

A rectangle is inserted and the text within it is already selected. 
4. Change this text to "Reactor 1". 
5. Press the Enter key to apply the text. 
6. Now format the text field using the Style Palette: 

– Select the text field and click on the "Line weight/invisible" entry. 
This hides the frame of the text field. 

– Select the text field and click on the "Fill pattern/transparent" entry. 
This makes the color of the text field transparent. 

Video  
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8.6.4 Step 2 - How to Set the Text Field 

Requirements 
● The "RMT1.pdl" process picture is open in the Graphics Designer. 
● The text field is inserted and selected. 

Procedure 
1. Select the menu command View > Properties. 

The "Object Properties" dialog box opens with active "Properties" tab. 
2. Select the "Static text" entry from the tree view. 

The detail view shows the name of the text field and the level. 
3. Switch to the detail view and then double-click the "Static Text 1" input box in the "Static" 

column. 
You can now edit text in this input box. 

4. Type in the name "Reactor 1" and then press ENTER. 
This saves this name and displays it in the top row. If you are working on the drawing 
board, this name will be displayed as a tooltip whenever you move the mouse over the 
object. 

5. Select the "Static Text/Font" entry in the tree view. 
6. Switch to the detail view. Double-click the value "no" in the box next to the "bold" 

attribute. 
The values changes from "no" to "yes" and the text is assigned the "bold" attribute. 

7. Close the "Object Properties" dialog box. 
All changes are shown. 

Video  
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8.6.5 Step 3 - How to Duplicate the Text Field 

Requirements 
● The "RMT1.pdl" process picture is open in the Graphics Designer. 
● The text field is inserted. 
● The settings for text fields have been made. 

Procedure 
To avoid having to repeat all the settings you made for the first text field, you duplicate the 
existing text field and simply overwrite the existing text.  
1. Select the text box if it is no longer marked and then select the Edit > Duplicate 

command. 
The program duplicates the text box. 

2. Double-click in the text box and change the text to "Reactor 2". 
The duplication functions automatically sets all other formats. 

3. Select the View > Properties command. 
4. Change the object name to "Reactor 2" in the detailed window. 
5. Position the text field next to the object. 
6. Repeat steps 1 to 5 to create the following text fields: 

– Raw material tank 
– RMT 1 part of the plant 

7. Open the properties for the text field "Unit RMT 1" and the entry "Static Text/Font in the 
tree view. 

8. Switch to the detailed window and enter the value "16" for the "Font Size" attribute. 
9. Close the "Object Properties" dialog box. 
10. Position the text fields as follows: 

– Raw material tank – left next to the raw material tank 
– RMT 1 part of the plant – in the upper left corner of the process picture 

11. Select the File > Save command. 
The program saves the process picture. 
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8.6.6 Current status of the process picture... 

Result 
Now that you have inserted the tank, the pipes, and the labeling, your process picture should 
look like the one below: 
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8.6.7 How to Connect the Raw Material Tank with the Process Value 

Introduction 
The tank you inserted in your process picture represents the raw material tank. In order to 
display the current fill level of the raw material tank in process mode, you now connect this 
tank with the relevant block. 

Requirements 
● The "RMT1.pdl" process picture is open in the Graphics Designer. 
● The static objects have been inserted. 

Procedure 
1. Select the "Tank4" object which represent the raw materials tank. 

The name of the object is shown in the tooltip that appears when you place the cursor on 
the object. 

2. Select the View > Properties command. 
The "Object Properties" dialog box opens with active "Properties" tab. Tank4" is selected 
in the tree view and the "Object name" and "Layer" attributes are displayed in the detailed 
window. 

3. Change to the detail view and then double-click the "Tank4" input box in the "Static" 
column. 
You can now edit text in this input box. 
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4. Enter the name "Raw material tank1" and press the "Enter" key. 

 
 

5. Select the "Tank4/Tag Assignment" entry in the tree view. 
6. Change to the detailed window. Position the cursor on the "light bulb" icon for the "Fill 

Level" attribute, and open the context menu. 
7. Select Tag... 

The tag selection dialog box opens. 
8. Select the "ES tags" check box from the "Data source" group and deactivate the "WinCC 

tags" check box. 
The tree view displays the ES tags. 

9. Select the  
 "ES tags/ Plant1/ RMT1/ LI111/ CFC_LI111/ LIA" entry from the tree view. 
The detail view displays all ES tags. 
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10. Select the "U" variable in the detailed window: 
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11. Click "OK". 
The program writes the tag and its full path to the "Dynamic" column. 

 
 

12. Double-click the value "100" at the "Maximum value" attribute in the "Static" column. 
The "Value input" dialog box opens. 

13. Enter the value "600" in the "Maximum value" input box and click "OK". 
The program saves this value. 

14. Accept the parameters for the minimum value. 
15. Close the "Object Properties" dialog box. 
16. Select the File > Save command. 

The program saves the process picture. 
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8.6.8 How to Position the Block Icons 

Introduction 
Your process picture already contains block icons that you inserted in SIMATIC Manager 
using the "Create/Update Block Icons" function. PCS 7 has automatically inserted these 
block icons sequentially in the upper section of the process picture. If you take a look at the 
block icons, you will see that PCS 7 has automatically created block icons in the horizontal 
and vertical directions based on the settings for the block in the CFC chart.  
You must position these block icons in accordance with the plant structure. 

Requirements 
● The "RMT1.pdl" process picture is open in the Graphics Designer. 
● The block icons are available. 
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Procedure 
1. Select the "..._NK111/VALVE" block icon and drag it to the required position so that the 

valve display in the block icon is positioned exactly between the pipes. 
2. Follow the same procedure for all other block icons and position them in accordance with 

the following graphic: 

 
 

3. Select the File > Save command. 
The program saves the process picture. 
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8.6.9 Inserting I/O Fields for Operator Control 

Overview 
You will provide two opportunities for operator control in your process picture: 
● Reactor selection 
● External/internal setpoint output 
You start by configuring the reactor selection – this involves three steps. Afterwards, you 
basically follow the same procedure to configure the setpoint output: 

 
Step What? 
 1 Insert I/O field (Page 189) 
 2 Format I/O field (Page 192) 
 3 Insert Explanatory Text (Page 193) 
 4 Configure Default Setpoint Value (Page 194) 

8.6.10 Step 1 - How to Insert the I/O Field 

Requirements 
● The "RMT1.pdl" process picture is open in the Graphics Designer. 
● The object palette is visible. 
● The style palette is visible. 

Procedure 
1. Select the "Smart Objects/I/O Field" entry in the object palette. 
2. Use the mouse to change to the drawing area. 

The mouse pointer transforms into a small I/O box icon. 
3. Draw a rectangle between the reactors by holding down the mouse button. The size of 

the rectangle should correspond with the size of your I/O box. 
The "I/O field configuration" dialog box opens. 

4. Click the "Tag selection dialog" button next to the "Tag" box. 
The "Tags - Project" dialog box opens. 

5. Select the "ES tags" check box from the "Data source" group. 
The tree view displays the ES tags. 

6. Select the entry "ES Tags/Plant1/RMT1/FC111/ADDIT/CFC_SETP/ 
PARA_DOS_RM1_SEL" from the tree view. 
The detail view displays all tags. 
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7. Select the variable "I0" in the detailed window. 

 
 

8. Click "OK" to save your entries. 
The program enters the tag into the "Tag" input box. 
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9. Make sure that the "Both" option is selected. 

 
 

10. Click "OK" to save your entries. 



Configuring the operator station  
8.6 Creating the process picture 

 PCS 7 - Getting Started - Part 1 
192 Getting Started, 09/2007, A5E00857261-02 

8.6.11 Step 2 - How to Format the I/O Field 

Requirements 
● The "RMT1.pdl" process picture is open in the Graphics Designer. 
● The I/O field has been inserted. 

Procedure 
Format the I/O field in the same way as you formatted the text fields. 
1. Select I/O field 1. 
2. Format using the style palette: 

– Click on the "Line Weight/Invisible" entry. 
This hides the text field frame. 

– Click on the "Fill pattern/transparent" entry. 
The text field color is now transparent. 

3. Select the menu command View > Properties. 
The "Object Properties" dialog box opens with active "Properties" tab. 

4. Select the "I/O field" entry from the tree view which contains the properties of the input 
box. 
The detail view shows the name of the text box and the level. 

5. Switch to the detail view and then double-click the "IOField1" input box in the "Static" 
column. 
You can now edit text in this input box. 

6. Type in the name "SEL_REAK" and then press ENTER. 
This saves this name and displays it in the top row. 

7. Select the "I/O Field/Font" entry in the tree view and change the value of the "Bold" 
attribute to "Yes" in the detailed window. 

8. Select the "I/O Field/Output/Input" entry in the tree view and change the value of the 
"Data Format" attribute to "Binary" in the detailed window. 

9. Close the "Object Properties" dialog box. 
All changes are shown. 
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8.6.12 Step 3 - How to Add Explanatory Text 

Requirements 
● The "RMT1.pdl" process picture is open in the Graphics Designer. 
● The I/O field has been inserted and formatted. 

Procedure 
The plant operator also has to know what can be set with this I/O field. You use a text field in 
order to provide this explanation. You have already used text fields when labeling the plant. 
1. Insert a text field – use the "Standard Objects/ Static Text" object to do this. 
2. Enter the following text: "Select reactor: 0 = Reactor 1, 1 = Reactor 2". 

Press <Shift + Return> to create a line break. 
3. Format the text fields using the style palette: 

– Frame invisible – "Line Weight/Invisible" setting 
– Fill transparent – "Fill Pattern/Transparent" setting 

4. Drag a frame around the I/O field and the explanatory text – use the "Standard 
Objects/Rectangle" " object for this purpose. 

5. Format the text fields using the style palette: 
– Thickness of the frame – "Line Weight/3 Pixel" setting 
– Fill transparent – "Fill Pattern/Transparent" setting 

6. Position the objects as shown in the figure below: 

 
 

7. Lasso all the objects with the mouse. 
8. Select the menu command Edit > Group > Group. 

This groups all the objects into a single object and makes it easier to move them. 
9. Position the objects between the reactors. 
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8.6.13 Step 4 - How to Insert the Setpoint Output 

Procedure 
Proceed as with the selection between reactor 1 and 2; the section below provides an 
overview of the steps:  
1. insert an I/O field using the tag 

"Plant1/RMT1/FC111/CFC_FC111/DOSE/SPEXT_ON". 
2. Specify the properties for the I/O field in the style palette: 

– Frame: invisible – style palette setting "Line Weight/Invisible" 
– Fill: transparent – style palette setting "Fill Pattern/Transparent" 

3. Specify the properties for the I/O field in the "Properties" dialog box: 
– I/O Field" property – "Object Name" attribute: "SEL_SP" 
– Font" property – "Bold" attribute: "Yes" 
– Output/Input" property – "Data Format" attribute: "Binary" 

4. Insert explanatory text field: "Input setpoint, 0 = internal (operator), 1 = external (CFC 
chart)" 

5. Format the text field via the style palette: 
– Frame: invisible – "Line Weight/Invisible" setting 
– Fill: transparent – "Fill Pattern/Transparent" setting 

6. Insert a whole frame – object palette, "Standard Objects/ Rectangle" object 
7. Format the whole frame via the style palette: 

– Line weight of frame -- "Line Weight/3 Pixel" setting 
– Fill: transparent – "Fill Pattern/Transparent" setting 

 
 

8. Group the objects by calling the Edit > Group objects > Group command. 
9. Position grouped objects in the lower section on the left. 
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8.6.14 How to Complete the Work 

Procedure 
1. Insert an arrow between the actuator and the "..._FC111/CTRL_PID" block icon to 

indicate the relationship between the process tag and the block icon. 
2. Insert an arrow between the raw material tank and the block icon ".../CFC_LI111/LIA" to 

indicate the relationship between the process tag and the block icon. 
3. Position the setpoint selection above the block icon ".../CFC_FC111/DOSE". 
4. Then position all other objects. 
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Result 
Your process picture should now appear as shown below: 

 
 

 
1. Select the File > Save command. 

The program saves the process picture, including all changes and additions. 
2. Close the Graphics Designer. 
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8.6.15 Current Status of Your Project 

Completed Configuration Tasks 
At this point, your project is complete, thus enabling you to activate process mode. You have 
become acquainted with the following functions during the OS configuration: 
● Setting the picture properties in SIMATIC Manager 
● Creating block icons 
● Compiling the operator station 
● Creating a process picture in the Graphics Designer with a variety of objects, for 

example, static and dynamic objects  
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Working in runtime 9
9.1 Planning the user interface 

9.1.1 Operator Station in Process Mode 

Operator control and monitoring options in process mode 
In process mode, the "color_gs" project provides various opportunities for operator control 
and monitoring of the process. 
With the block icons, you have the following options: 
● Observe the state of the valve: valve open or closed 
● Observe the state of the pump: pump active or inactive 
● Changing from a block icon to the associated faceplate 
With I/O fields, you have the following options: 
● Selecting the reactor 
● Selecting whether the setpoint is read from the CFC chart or whether the plant operator 

can specify the setpoint externally 
● Assigning the setpoint for the dosing volume in the faceplate 
You can also monitor the CFC and SFC charts. You were already introduced to this function 
when testing the charts. 
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9.1.2 User Interface in Process Mode 

Structure 
To allow you to monitor and operate the process yourself, here is a brief explanation of the 
user interface of PCS 7 in process mode. 
The user interface in process mode is divided into four areas: 
● Message line 

Displays the most recent message with the highest priority. 
● Overview area 

Lets you select the areas of a plant and view these by means of the various command 
buttons In your "color_gs" project, you have only one button, namely "RMT1" because 
your plant consists of only one part.  
Next to each button there are four other small buttons which you can use to view alarms 
and warnings from the sublevel hierarchy. If you click in this area, you automatically 
change to the process picture in which the alarm or warning originated.  
The arrow key on the extreme right opens a tree view in which you can select a sublevel 
of the hierarchy. 

● Process picture 
Returns the associated process picture, depending on the area you selected in the 
overview. In your "color_gs" project, the plant picture you created in the Graphics 
Designer is displayed. 
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● Button set 
Can be used to call various functions which you can select in process mode. In the 
"color_gs" project, you will only get to know the buttons that are important for this project. 
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9.2 Operator control and monitoring in process mode 

9.2.1 How to Activate Process Mode 

Requirements 
● WinCC Explorer is open. 
● The example project is open. 

Procedure for Activating Process Mode 
1. Select the File > Activate command. 

The progress bar and start screen open. 

 
 

2. Click on "RMT1" in the overview area. 
This displays the process picture which you created in Graphics Designer. 
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9.2.2 How to Start the Process 

Introduction 
To enable operator control and monitoring of all functions that you have configured, you now 
just have to start the dosing process. 
Dosing is started using the SFC chart. You start the SFC directly in process mode without 
having to change back to SIMATIC Manager. 
There are two ways to start the process: 
● Using the block icon "..../RMT1/SFC_RMT1" 
● Using a button in the button set 

Starting using the block icon 
1. Click on the "..../RMT1/SFC_RMT1" block icon. 

The associated faceplate opens. 

 
 

2. Click the "Start" button. 
The "SFC Operation" dialog box opens. 

3. Click "OK". 
The sequential control system starts and you can follow the process in your process 
picture. 

4. Click "Section". 
This opens the detailed display of the SFC chart. This display corresponds to the display 
of the SFC chart in the SFC Editor. 

5. Double-click on a step in the SFC chart to view additional details about the current status 
of the SFC chart. 
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Starting using the button set 

1. Click "Change Button Set":  
The second button set is displayed. 

2. Click "SFC Visualization".  
The "Open SFC" dialog box opens. Since you only have one OS and one SFC chart in 
your project, only this OS is displayed in the tree view and only the SFC chart in the detail 
window. 

 
 

3. Select the "RMT1/FC111/SFC_RMT1" chart in the detailed window and click "OK". 
A greatly reduced overview of the SFC chart opens. 
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4. Click on this overview. 
The detailed display of the SFC chart appears. This detailed display is comparable to the 
display that you worked with when testing the SFC chart in the SFC Editor. 

 
 

5. Position this detailed display so that you can see your entire process picture. 
6. Click "Start". 

The "SFC Operation" dialog box opens. 
7. Click "OK". 

The sequence control system starts: You can monitor the process both in your process 
picture and in the detailed display of the SFC chart. The representation in the SFC chart 
is no different from the representation you know from the test mode. 
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9.2.3 How to Stop the Process 

Procedure 
If you do not want the process to run right through to the end, you can stop it manually: 
1. Click "Stop" in the detail view of the SFC chart. 

The "SFC operation" dialog box opens. 
2. Click "OK". 

This pauses the process. 
3. Now click "Reset" and then "OK" in the "SFC Operation" dialog box. 

This resets all values to the input values. 

9.2.4 How to Control the Process by Means of the Process Picture 

Operator process control 
There are several ways of influencing the process in the process mode using the process 
picture: 
● Select Reactor (Page 207) 
● Open Faceplate (Page 207) 
● Define Setpoint Value (Page 208) 
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9.2.5 How to Specify the Reactor 

Procedure 
1. Position the mouse pointer on the I/O field in the "Select reactor" area. 

The mouse pointer is transformed into a text selection symbol. 
2. Click on the I/O field. 

The I/O field is shown on a gray background. 
3. Enter the required number to select the reactor: 

– If you want to dose in reactor 1: 0 
– If you want to dose in reactor 2: 1 

4. Press ENTER. 
The new value is saved after a brief delay and the displayed in this area. 
Video  

 
 

5. Restart the process and review the results. 

9.2.6 How to Open the Faceplates 

Procedure 
1. Start the process 
2. Click the block icon "..._FC111/CTRL_PID". 

The corresponding faceplate opens with active "Standard" tab. 
3. Select other tabs using the drop-down list box. For your "color_gs" project, the following 

views are of interest: 
– Standard – here, you can see, for example, the setpoint and actual value of the 

controller displayed as specific values and in graphic form. 
– Parameters – here, you can, for example, modify certain values. Using the "Bar HL" 

and "Bar LL" boxes you can modify the graphic display for the "Standard" tab. 
– Limits – here, you can see, for example, the alarm limits that you defined in the CFC 

chart for this block. 
4. Close the faceplate. 
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9.2.7 How to Change the Setpoint 

Introduction 
The setpoint is changed in two steps: 
● First, you define whether the process uses the external or internal setpoint. 
● Then, you enter the specific setpoint. 

Step 1: Specify setpoint output 
1. Position the cursor on the I/O field in the "Input setpoint" area. You already created this 

area in the process picture. 
The mouse pointer is transformed into a text selection symbol. 

2. Click on the I/O field and enter the required number of the method for the setpoint output 
as shown in the table below. 

3. Press ENTER. 
The new value is saved after a brief delay and the displayed in this area. 

 
If the setpoint … … enter the following number: 
will be read from the CFC chart  1 
will be entered manually by the operator  0 
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Step 2: Enter the setpoint 
1. Click the block icon ".../CFC_FC111/DOSE. 

The corresponding faceplate opens with active "Standard" tab. 

 
 

2. Open the "Setpoint" drop-down list. 
The "SP" dialog box opens. 

3. Activate "Internal" check box. 

 
 

4. Click "Run". 
The "Setpoint" input box is activated. 

5. Click on the "Setpoint" input box. 
The "Setpoint" dialog box opens. 
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6. Click in the input box and enter the required value. 

 
 

7. Click "Run". 
The value is entered in the input box. 

8. Close the faceplate. 
The modified value is displayed in the block icon. 

9. Restart the process and review the results. 
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9.2.8 How to Work with Messages 

Introduction 
Messages are displayed to you as follows: 
● In the message line 
● In a separate message list 

Message line 
While the process is running, warnings and alarms with messages are displayed in the 
message line of your screen. The message line contains the latest message with the highest 
priority. 
Click the button to the right of the message line to acknowledge the messages. 

Message list 
You can also view all the messages and alarms in a list.  
1. Click the "Change Button Set" button: 

 
2. Click "Message System": 

 
The message list is displayed. 

3. Acknowledge the messages as shown in the table below. 
4. Click on the buttons in the button area to navigate to the various message and alarm lists. 
5. Click the "Previous Graphic" button in the button area: 

 
This returns you to the "RMT1" process picture. 

 
 
If you … … then  
want to acknowledge a single message  click "Acknowledge single messages". 

 
This acknowledges the message that is labeled at the start of the line with a 
triangle. 

want to acknowledge all messages click "Acknowledge all visible messages". 
 

 



Working in runtime  
9.2 Operator control and monitoring in process mode 

 PCS 7 - Getting Started - Part 1 
212 Getting Started, 09/2007, A5E00857261-02 

9.2.9 How to Exit Process Mode 

Procedure 
1. Click the "Change Button Set" button in the button area. 

 
2. Click the "Exit Runtime" button: 

 
 
The "Exit Runtime" dialog box opens. 

 
 

3. Click "Deactivate". 
This exits process mode. 

4. Close WinCC Explorer. 
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Performing additional tasks 10
10.1 Introduction to the Additional Task 

Additional Task 
In the "color_gs" project, two identically configured raw material tanks are required. The 
additional task is to configure the second raw material tank "RMT2". But do not worry: You 
do not need to work through all steps again but will use the automatic functions of PCS 7. 
You will find that the copying function of PCS 7 will save you many steps by performing 
these steps for you automatically in the background. 
When you create the second raw material tank, you will work largely on your own. You have 
already become familiar with many of the required dialog boxes during configuration of the 
first raw material tank. Therefore, in this section, we will not prescribe detailed step-by-step 
instructions but will simply specify the order in which you must make the configuration, giving 
you a general guideline on how to proceed.  



Performing additional tasks  
10.2 How to Copy the Existing 'RMT1' Part of the Plant 

 PCS 7 - Getting Started - Part 1 
214 Getting Started, 09/2007, A5E00857261-02 

10.2 How to Copy the Existing 'RMT1' Part of the Plant 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 
● Configuration of the RMT1 plant component is complete and free of errors. 

Procedure 
1. Select the "Copy / Paste" function in Windows to copy the "RMT1" hierarchy folder to the 

"Plant1" hierarchy folder. 
SIMATIC Manager generates a copy of the "RMT1" hierarchy folder, names it "RMT1(1)" 
and saves it to the "Plant1" hierarchy folder. The names of the objects, for example, 
CFC/SFC charts are appended a consecutive number. 
In the destination hierarchy folder, the cross-references to CFC blocks which are defined 
in the dynamic objects of the OS pictures are automatically updated when you copy / 
move hierarchy folders which contain CFC charts and process pictures. 
 

 

NOTICE  
 

If you copy or move charts and pictures individually, in other words, you copy or move 
them not within the hierarchy folder, the references of the dynamic objects are lost and 
they must be linked to the blocks again in the pictures. 

 
2. Change the names of the hierarchy folder and the objects in the individual hierarchy 

folders according to the table below: 
 

Hierarchy folder New name Object contained – old name New name 
RMT1(1) RMT2 RMT1(1)" process picture RMT2 
  SFC_RMT1(1) SFC_RMT2 
FC111 FC112 CFC_FC111(1) CFC_FC112 
ADDIT ADDIT2 CFC_SETP(1) CFC_SETP2 
LI111 LI112 CFC_LI111(1) CFC_LI112 
NK 111 NK115 CFC_NK111(1) CFC_NK115 
NK112 NK116 CFC_NK112(1) CFC_NK116 
NK113 NK117 CFC_NK113(1) CFC_NK117 
NK114 NK118 CFC_NK114(1) CFC_NK118 
NP111 NP112 CFC_NP111(1) CFC_NP112 

 



 Performing additional tasks 
 10.2 How to Copy the Existing 'RMT1' Part of the Plant 

PCS 7 - Getting Started - Part 1 
Getting Started, 09/2007, A5E00857261-02 215 

Your plant hierarchy should now appear as follows: 
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10.3 Preparation for Process Mode 

Preparation 
New charts and a new process picture were created when plant component RMT1 was 
copied to create RMT2. This new information must now be downloaded to the automation 
system and "made known" to the OS. 
You use the central "Compile and Download Objects" function for this purpose. In this 
situation, PCS 7 provides you with the option of compiling and downloading only the 
changed information. This reduces the time required for the compile and download 
operation. In your "color_gs" project, this is not yet a problem since the project is small. 
When configuring large plants, this option gains in significance. 
Once the compile and download operation is complete, you need to adapt the RMT2 process 
picture. 
Then you can activate process mode and test the functions. 
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10.4 How to Compile and Download the Changes 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 
● The CPU is in "RUN-P" mode. 

Procedure 
1. Select the "color_gs_Prj" project in the tree view. 
2. Select the menu command PLC > Save and Compile Objects.... 

The "Charts" object status is changed. 
3. Activate the check boxes as follows: 

 
 

 



Performing additional tasks  
10.4 How to Compile and Download the Changes 

 PCS 7 - Getting Started - Part 1 
218 Getting Started, 09/2007, A5E00857261-02 

 

  Note 
If you see the status "undefined" for all objects in the "Compile and Download Objects" 
dialog box, click "Status" in the "Update" area. 
This updates the status. 

 
4. Select the "Charts" object and click the "Edit" button. 

The "Compile Program / Download to Target System" dialog box opens. 
5. Set the following: 

– Activate the "Changes only" check box in the "Scope" group. 
The CPU only remains in process mode if you activate this option. 

– Activate the "Generate module drivers" check box. 

 
 

 
6. Click "OK". 

The settings are applied and the "Download S7" tab is displayed. 
7. Select the "Changes" option and click "OK". 

The settings are now applied. 
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8. Select the "OS(1)" object and click "Edit". 
The "Which areas do you want to assign to operator station OS(1)?" dialog box opens 
and the existing "RMT1" plant component and the new "RMT2" plant component are 
displayed in the list. Both are automatically assigned to the OS (1). 
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9. Click "Next >". 
The "Select the network connections for the S7 programs associated with the areas" 
dialog box opens. Both OS areas are shown in the left pane and the network connection 
that you have created in NetPro is shown in the right pane. 

 
 

 
10. Click "Next >". 

The "Select the data you want to compile and the scope of the compilation" dialog box 
opens. 

11. Activate the following check boxes and options: 
– "Data" group: "Tags and messages" 
– "Data" group: "SFC visualization" 
– "Data" group: "Picture tree" 
– "Scope" group: "Changes" 
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12. Click "Apply". 
The dialog box closes. 

13. Click "Start". 
The compile and download operation is started, and the message dialog "Downloading 
program changes during operation...." opens. 

14. Click "OK". 
The message dialog "If you want to download changes online, please make sure that.... 
Do you want to continue?" opens. 

15. Click "Yes". 
The compile and download operation starts and the log file is opened in the text editor. 

16. Close the text editor. 
17. Click "Close" in the "Compile and Download Objects" dialog box. 

10.5 How to Adapt the OS Configuration 

Requirement 
The example project is open in WinCC Explorer. 

Procedure 
1. Open the "RMT2" process picture in the Graphics Designer. 
2. Change the header text to "RMT2 part of the plant". 
3. Save the process picture. 
4. Close the Graphics Designer. 
Additional changes are not necessary because all the block icons in the process picture 
along with their associated interconnections were updated by the copy operation and the 
subsequent compilation operation. 
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10.6 How to Start Process Mode 

Requirements 
● The OS is compiled. 
● The example project is open in WinCC Explorer. 
● The follow-up work has been performed in the "RMT2" process picture. 

Procedure 
1. Select File > Activate in WinCC Explorer. 

This function changes to operation in process mode. 
The overview area displays a button named "RMT2". You monitor the units separately by 
toggling the views using the "RMT1" and "RMT2" buttons. 
The button of the unit which is currently visualized is marked with a color. 

2. Click the "RMT2" button in the overview area. 
3. Change the button set and then click "SFC Visualization". 

The program opens the "Open SFC" dialog box. 
The detail view shows two SFC charts: the SFC chart from "RMT1" and the SFC chart 
from "RMT2". 

4. Select the "../RMT2" SFC chart and start the sequential control system. 
 

 

  Note 
You can find detailed information about this under "Working in Process Mode – Operator 
Control and Monitoring in Process Mode". 

 
5. Perform the following steps in process mode: 

– Change between the parts of the plant 
– Change the setpoint output. 
– Specify the reactor selection. 
– … 

Additional information 
You can find detailed information about this in the section "Working in Process Mode". 
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Starting and adapting the example 11
11.1 Example Project "color_gs" 

Example project "color_gs" 
With Getting Started, you also receive the PCS 7 project "color_gs" that has already been 
fully configured. You can open and start this project on your computer. Since we assumed a 
specific hardware configuration when creating the project, you will need to adapt the 
hardware configuration if you use different hardware components. 
The overview shows you how to open and adapt the example project: 
● Open the example project (Page 224)  
● Adapt the hardware of the example project (Page 225)  
● Adapt the blocks for the example project (Page 226)  
● Adapt the project data for the example project (Page 228)  
● Compile and download the example project (Page 229)  
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11.2 Procedure 

11.2.1 How to Open the Example Project 

Requirement 
SIMATIC Manager is open. 
 

 

 Note 
The example project comes in the form of a ZIP file that you extract using a PCS 7 function. 

 
 

Procedure 
1. Select the menu command File > Retrieve..... 

The "Retrieve - Select Archive" dialog box opens. 
2. Open the folder "SIEMENS/ STEP7/ Examples_MP". 
3. Select the "color_gs.zip" file, and click "Open". 

The "Select Destination Directory" dialog box opens, and the "S7proj" folder is selected - 
this is the default storage location for all PCS 7 projects. 

4. If you … 
– want to accept the default folder, click "OK". 
– have created a separate folder for the example project, navigate to this folder and then 

click "OK". 
Retrieval from the archive is then started. 
After retrieval from the archive, the "Retrieve from Archive" message window opens. 

5. Click "OK". 
Another message dialog opens: 
"Multiproject 'color_gs' has been retrieved from the archive. Do you want to open it now?". 

6. Click "Yes". 
The example project opens. 
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11.3 How to Adapt the Hardware for the Example Project 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated. 

Procedure 
1. Activate the required network adapter in the configuration console. 

You can detailed information about this in the section: 
 "How to make the settings in the Configuration Console" (Page 26). 

2. Select the network adapter (communications processor) you want to use for 
communication with the engineering station. 
You can information about this in the section: 
 "How to select the network adapter in Simatic Shell" (Page 27). 

3. Configure the AS: 
– Select your component from the hardware catalog and drag it to the slot in which our 

component is inserted. This overwrites component that we used with your component. 
– Make the settings for the CP and the network connections. 
You can detailed information about this in the section: 
 "How to configure the AS" (Page Fehler! Textmarke nicht definiert.). 

4. Rename the PC station. 
You can detailed information about this in the section: 
 "How to rename the PC Station" (Page 42). 

5. Configure the OS: 
– Set the network adapter and network connections. 
You can detailed information about this in the section: 
 "How to configure the PC Station of the OS" (Page 43). 

6. Configure the network connection in NetPro and download the PC station. 
You can detailed information about this in the section: 
 "How to make the settings in NetPro" (Page 46). 
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11.4 How to Adapt the Blocks for the Example Project 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "PCS 7 Library V7.0" is open and selected. 

Procedure 
1. Go to the tree view and select the entry  

"PCS 7 Library V7.0/Blocks+Templates/Blocks" 
The detail view displays all blocks. 

2. Select all blocks that are also contained in your library. 
3. Drag-and-drop the blocks to the "color_gs_MP/color_gs_Lib/S7 Program(1)/Blocks" 

master data library. 
The "Insert function block" dialog box opens. 

4. Click "All". 
This replaces all blocks in the master data library with the blocks from the current version 
of the PCS 7 library. 

5. Select "color_gs_MP/color_gs_Lib/S7 Program(1)/Charts" in the tree view. 
6. Select the process tag type "VALVE". 
7. Select the menu command Edit > Open Object. 

the process tag type opens in the CFC editor. 
8. Select the menu command View > Block types. 

The "Block Types" dialog box opens. 
9. Select all blocks in the "Chart Folder" group and click "New Version". 

The "Set format" dialog box opens. 
10. Click "Yes" to implement the formats. 

The "Import New Version" dialog box opens if the process tag types still contain blocks 
from an older version. 

11. Click "Yes" to update the blocks. 
The "Import New Version" dialog box opens and display all identical block types. 

12. Click "Yes". 
The dialog box closes. 

13. Click "Close". 
14. Close the CFC editor. 
15. Select "color_gs_MP/color_gs_Lib/S7 Program(1)/Blocks" in the tree view. 
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16. Select the menu command Options > Charts > Update block types. 
The "Update Block Types" wizard opens. 
– In the "Select the S7 programs to be checked" step, select all the files of the the 

"color_gs" project. The check boxes for all folders of all S7 programs are activated by 
default. 

– Click "Continue". 
– All block types are activated by default in the step "Select the block type to be 

updated". 
– Click "Finish". 

The "Set Format" dialog box opens. 
– Click "Yes" to implement the formats. 

The log file opens when the update of the blocks and block instances is completed. 
17. Click "Close" in the log. 
18. Compile the AS after the block import. 
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11.5 How to adapt the project data for the example project 

Requirements 
● The example project is open in SIMATIC Manager. 
● OS(1) is selected in the Component view. 

Procedure 
1. Select the menu command Edit > Object Properties. 

The "s7omwinx" dialog box opens. 
2. Click "Yes" to open the project on a local computer which operates in server mode 

WinCC Explorer opens. 
3. Select the OS(1)/Computer entry in the navigation window. 
4. Double-click on the computer symbol in the detailed window. 
5. Enter the name of the computer on which you open the project in the "Computer name" 

input field. 
You can find this name in the Station Configuration Editor. 

6. Click "OK". 
7. Acknowledge the "Change computer name" message with "OK". 

The computer symbol is not crossed out red in the dialog box. 
8. Close the WinCC Explorer and open it again. 

The computer name has now been applied. 
9. Select the entry "OS Project Editor". 
10. Select the Open command from the shortcut menu. 

The OS project editor opens. 
11. Accept the default settings and click "OK". 

The OS project editor configures the project. 
12. Close the WinCC Explorer. 
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11.6 How to Compile and Download the Example Project 

Requirements 
● The example project is open in SIMATIC Manager. 
● The CPU is in "STOP" mode. 
● The hardware is adapted. 
● The blocks and project data are adapted. 

Procedure 
1. Select the "color_gs_Prj" project in the tree view. 
2. Select the menu command PLC > Save and Compile Objects.... 

The "Save and Compile Objects" dialog box opens. 
3. Select the following check boxes: 

– color_gs_Prj/[name of the PC station]/Configuration: "Compile" 
– color_gs_Prj/[name of the PC station]/WinCC Application/OS(1): "Compile" 
– color_gs_Prj/SIMATIC 400(1)/Hardware: "Compile" and "Download" 
– color_gs_Prj/SIMATIC 400(1)/[Name of the CPU]/Charts: "Compile" and "Download" 

4. Select the "Charts" object and click the "Edit" button. 
The "Compile Program / Download to Target System" dialog box opens. 

5. Activate the following check boxes and options: 
– "Scope" group: "Entire program" 
– Additional settings: "Generate module drivers" 

6. Click "OK". 
7. Select the "OS(1)" object and click "Edit". 
8. In the "Which areas do you want to assign to the operator station OS(1)?" dialog box, 

assign the "RMT1" and "RMT2" plant components to OS (1). 
9. Select the S7 connection in the "Select the network connections for the S7 programs 

associated with the areas" dialog box. 
10. In the "Select the data you want to compile and the scope of the compilation" dialog box, 

select the following check boxes: 
– "Data" group: "Tags and messages" 
– "Data" group: "SFC visualization" 
– "Data" group: "Picture tree" 
– "Scope" group: "Entire OS with memory reset" 
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11. Click "Apply". 
12. Click "Start". 

The compile and download operation starts. 
The message "Downloading program changes during operation can, in the case of 
malfunctions or program errors, cause serious damage to personnel and equipment! 
Make sure..." opens. 

13. Click "OK". 
The message dialog "If you want to download changes online, please make sure that ... 
Do you want to continue?" opens. 

14. Click "Yes". 
The log file opens in the text editor to show you whether or not compilation and the 
download were successfully completed. 

15. Close the text editor. 
16. Start the CPU of the AS. 

Working in the OS 
1. Switch to the component view of SIMATIC Manager. 
2. Open the OS. 

You can detailed information about this in the section: 
"How to start the PCS 7 OS (Page 168)". 

3. Activate process mode. 

Additional information 
You can detailed information about this in the section: 
"The operator station in process mode (Page 199)". 
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