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Preface 1
Purpose of this documentation 

Getting Started - Part 2 introduces the PCS 7 functions you can use for fast and effective 
configuration of you plant. These functions are especially convenient for configuring large, 
complex plants. 
Getting Started - Part 2 is intended for users who have already worked through  
Getting Started - Part 1. 

Required basic knowledge 
You should already have knowledge in the following areas: 
● Microsoft operating system Windows XP, Windows Server 2003 
● Basic knowledge in the field of process automation 
● Functions and configuration of SIMATIC S7 (S7-400, STEP 7) 
● Functions and configuration of SIMATIC NET (network components, transmission media) 
You should also be familiar with the basic functions of PCS 7. This includes all functions 
described in Getting Started - Part 1. Detailed instructions are provided for all functions that 
were not covered in Getting Started - Part 1. If necessary, you can refer back to the detailed 
descriptions in Getting Started - Part 1.  

Validity of the documentation 
This documentation is valid for the software package Process Control System;  
PCS 7 Toolset V7.0. 
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Guide 
Getting Started - Part 2 is a continuation of Getting Started - Part 1. In this Getting Started, 
you will configure a unit for the color project. In doing so you will become familiar with 
functions of rational engineering. You will find important background information needed to 
understand the individual topics and, of course, detailed step-by-step instructions for 
performing the configuration. 
You are also provided with a completed "color_gs" example project for Getting Started 2, 
which is archived in "color_gs2.zip". This is installed along with the system documentation of 
PCS 7.  You open this project on an existing engineering station (ES) in order to view the 
configuration data and compare the data with your own configuration data. You activate the 
project on an operator station (OS) in order to operate and monitor the process. 
 

 

 Note 
To test the example project in process mode, the hardware configuration of the project must 
correspond to your actual hardware configuration. If necessary, replace the hardware 
components in the example project with the actual hardware components present. 
Further information may be found in Getting Started - Part 1. 
Start > Simatic > Documentation > English > PCS 7 Getting Started Part 1 (Online Help) or 
PCS 7 Getting Started Part 1 (PDF) 

 
  

 

 Note 
Many preparatory tasks that you will do in Getting Started - Part 2 were already described in 
detail in Getting Started - Part 1. Therefore, they are only described in outline form in this 
part of Getting Started. You can find detailed information in Getting Started - Part 1. This is 
part of the system documentation for PCS 7 that is included in the standard installation of 
PCS 7.  
Select the following menu command to open Getting Started - Part 1: 
Start > Simatic > Documentation > English > PCS 7 Getting Started Part 1 (Online Help) or 
PCS 7 Getting Started Part 1 (PDF) 
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Conventions 
In this Getting Started, all the instructions are given using their full menu commands. You 
can also activate the majority of functions via the context menu or by double-clicking.  

 

 Note 
In this documentation the designations of elements of the user interface are specified in the 
language of this documentation. If you have installed a multi-language package for the 
operating system, some of the designations will be displayed in the base language of the 
operating system after a language switch and will, therefore, differ from the designations 
used in the documentation. 

 
In PCS 7, you can use standard Windows functions in many situations: 
● Multiple selection using the "CTRL" and "Shift" keys 
● Column sorting in tables by clicking on the column header 
● Use of drag & drop instead of copy and paste 
If you open the HTML version of Getting Started, you can run video sequences. You can 
follow along step-by-step in these video sequences. Video sequences are indicated by the 
following icon: 

 Video 
 

Click on the word "Video" to start a video sequence. You start and stop the video sequences 
using the corresponding commands in the context menu. 
The individual tutorials in Getting Started build on each other so that you will create your own 
complete PCS 7 project step-by-step. For this reason, you should work through all the 
tutorials in the specified sequence. 

PCS 7 glossary 
You can find a PCS 7 glossary defining the most important technical terms used in the 
documentation on the DVD SIMATIC PCS 7; Manual Collection or within the PCS 7 software 
through the help menu SIMATIC Manager (menu command Help > Topics > "Glossary" 
button). 
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Additional information 
You will find detailed background information and general context in the following manuals, 
which you can use for reference purposes: 
● Configuration manual Process Control System PCS 7; Engineering System 
● Configuration manual Process Control System PCS 7; Operator Station 
These manuals are stored as follows: 
● as PDF files on the DVD "PCS 7 Engineering Toolset V7.0" 
● In the PCS 7 software in SIMATIC Manager.  

They can be accessed there using Start > Simatic > Documentation > 
[required language] from the menu. 

If you wish to familiarize yourself with specific topics in greater depth, refer to the appropriate 
manuals, for example, for SFC and CFC. 

Additional support  
If you have further questions about the use of products presented in this manual, contact 
your local Siemens representative:  
A list of Siemens representatives is available at:  
http://www.siemens.com/automation/partner  
A guide to the technical documentation for individual SIMATIC products and systems is 
available at:  
http://www.automation.siemens.com/simatic/portal/html_00/techdoku.htm  

Training center  
We offer courses to help you get started with the S7 automation system. Contact your 
regional training center or the central training center in D 90327 Nuremberg, Federal 
Republic of Germany.  
By phone: +49 (911) 895–3200  
Internet: http://www.sitrain.com 
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Technical Support  
You can contact Technical Support for all A&D products  
● using the Support Request Web form  

http://www.siemens.com/automation/support-request  
● By telephone: + 49 (180) 5050-222  
● By fax: + 49 (180) 5050-223  
You can find additional information about our Technical Support online at: 
http://www.siemens.com/automation/service 

Service & Support on the Internet  
In addition to our paper documentation, our complete knowledge base is available to you on 
the Internet at:  
http://www.siemens.com/automation/service&support  
There, you will find the following information:  
● Newsletters providing the latest information on your products  
● A search engine in Service & Support for locating the documents you need  
● A forum where users and experts from all over the world exchange ideas  
● Your local contact partner for Automation & Drives in our Contact Partners database  
● Information about on-site service, repairs, spare parts, and much more under "Services 
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Preparations for Getting Started - Part 2 2
2.1 Prerequisites for Getting Started 

2.1.1 Requirements for working through Getting Started - Part 2 

Introduction 
To be able to work through Getting Started, the following requirements must be met for the 
components below: 
● Hardware (Page 14) 
● Software (Page 16) 
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2.1.2 Hardware requirements for Getting Started - Part 2 

Hardware components 
The hardware requirements for Getting Started - Part 2 are identical to those for  
Getting Started - Part 1. You require the following hardware components:  

 
Hardware component Version used in Getting Started Other version possible 
PG or PC with a standard 
network card 

3Com EtherLink III IS Yes 

Rack UR2 Yes 
Power supply PS 407 10A Yes 
CPU CPU 417-4, firmware V 3.1 or higher No 
CP 443-1 6GK7 443-1 EX11-0XE0, 

Firmware 2.0 or higher with a fixed MAC 
address 

No 

Memory card   
Crossover cable  No 

  
 

NOTICE  
To implement the configuration described in Getting Started, you must have at least have 
the CPU and the CP. 

 
  

 

 Note 
You can find detailed information on the hardware requirements in Getting Started - Part 1. 

 
  

 

 Note 
You can find detailed information about setting up the PC station in the manual Process 
Control System PCS 7; PC Configuration and Authorization 
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Additional hardware components 
You also require the following components for an actual simulation using I/O modules:  

 
Hardware component Version used in Getting Started Other version possible 
IM 153-1 6ES7 153-1AA03-0XB0 Yes 
Digital input module 6ES7 321-1BH01-0AA0 Yes 
Digital output module 6ES7 322-1BH01-0AA0 Yes 
Analog input module 6ES7 331-7KF01-0AB0 Yes 
Analog output module 6ES7 332-5HD01-0AB0 Yes 
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2.1.3 Software requirements for Getting Started - Part 2 

Software components 
The following software must be installed: 
● Windows XP Professional, Windows Server 2003 
● Internet Explorer  6.0 
● Message Queuing Service 
● SQL Server 
● Software package PCS 7 Engineering Toolset 

If you have questions about installing the PCS 7 software, read the Readme file on the 
installation DVD or contact Customer Support. 
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2.2 Introduction to the project for Getting Started 

2.2.1 System configuration for the 'color_gs' project 

Structure 
The system configuration for Getting Started - Part 2 is identical to that for Getting Started - 
Part 1. 

 
 

You can find detailed information on the system configuration in Getting Started - Part 1 
under "System configuration for the "color_gs" project". 
 

 

 Note 
Note that the system configuration and the hardware settings are designed specially for the 
requirements of this Getting Started.  
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2.2.2 Introduction to the overall project 

Plant description 
In this Getting Started, you will configure a fully automatic dye production plant. You were 
already introduced to the overall project in detail in Getting Started - Part 1.  
The following is a summary of the individual phases of the production process: 

Phase I - Raw materials 
The raw materials are fed as follows: 
● The liquid raw materials are fed from two raw material tanks selectively to either 

Reactor 1 or Reactor 2. 
● The solid raw materials are fed from three silos to a weigh hopper and from there into a 

mixing tank. 
  

 

 Note 
The liquid raw material feed was configured in Getting Started - Part 1. 

 
  

Phase II – Production 
The products are produced in the reactors by agitating, heating and cooling the raw 
materials together with the additives. Valves and actuators are used to control the 
temperature in the reactors. 
When necessary, water from a filtration plant can be introduced into the reactors using a flow 
controller. 

Phase III - Holding phase 
The product is pumped to a holding tank for postprocessing. 

Phase IV – Filling 
After the holding phase, the product is temporarily stored in a filling tank. From there, it is 
filled into bulk-tank trucks or small packing drums. 

Phase V – Cleaning 
All parts of the plant can be cleaned by a cleaning-in-place (CIP) system. The resulting 
wastewater is collected in a separate effluent tank and disposed of. 
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2.2.3 Task definition for Getting Started - Part 2 

Task definition for Getting Started - Part 2 
You will configure the following for Reactor 1 of the overall plant described above: 
● Phase II: Production with agitation and heating 
● Phase III: Draining the holding tank 
The following sub-processes are not described in Getting Started because you will become 
acquainted with all functions of rational engineering in phases II and III: 
● Phase II: Cooling and the filtration system 
● Phase III: Tempering 
● Phases IV and V 
You provide for all other parts of the plant in the form of hierarchy folders in the plant 
hierarchy. The actual configuration process is not described in Getting Started. 

 

 Note 
Getting Started gives a detailed description of how to configure the REAC1 part of the plant. 
You will configure REAC2 on your own. In doing so, you use all of the functions that you 
have learned in Getting Started - Parts 1 and 2. 
Examples: 
• Using the process object view 
• Using process tag types 
• Using SFC types 
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Graphic representation of the "REAC1" and "REAC2" parts of the plant 
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2.2.4 Overview of configuration tasks 

Configuration sequence 
You configure the parts of the plant in the following configuration steps: 
● Retrieving the "color_gs" project from the archive 
● Adapting the hardware configuration using symbolic names 
● Adapting the plant hierarchy 
● Creating simulation charts for use with chart-in-chart technique 
● Creating process tag types and process tags 
● Creating other CFC charts 
● Creating an SFC type and an SFC instance 
● Compiling and testing 
● Creating custom icons for use in process pictures 
● Modifying a standard block icon for multiple usage 
● Creating a process picture 
● Operating SFC instances in process mode 
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2.3 Making the preparations 

2.3.1 Overview of default settings 

Use of the"color_gs" project from Getting Started - Part 1 
With the aid of this Getting Started, you will continue the configuration of the "color_gs" 
example project from Getting Started - Part 1.  
We recommend using the ready-to-use "color_gs" example project. It is automatically 
installed with the PCS 7 setup program. This ensures that all configuration steps have been 
performed and all folders, charts, etc., have been named in accordance with the instructions 
in Getting Started - Part 1. Getting Started - Part 2 is based on this. 

Settings for the supplied example project 
If you use the supplied example project, you must first perform the following configuration 
steps. You can then continue with configuration and compile, download and test the project. 
  

 

 Note 
The following configuration steps are presented in brief here. You can find detailed 
descriptions in Getting Started - Part 1. 

 
  

 
Step What? 
 1 Making settings in the Configuration Console (Page 23) 
 2 Selecting the communications processor (Page 24) 
 3 Retrieving the project from the archive (Page 25) 
 4 Adapting the hardware configuration of the AS (Page 26) 
 5 Renaming a PC station (Page 29) 
 6 Adapting the name of the OS (Page 30) 
 7 Adapting the configuration of the OS (Page 31) 
 8 Making settings in NetPro (Page 32) 
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2.3.2 How to make the settings in the Configuration Console 

Procedure 
1. Open the Configuration Console using the Windows command Start > SIMATIC > 

SIMATIC NET > Configuration Console. 
2. In the tree view, select the network adapter to be used for communication between 

 the automation system and the OS using the entry "SIMATIC NET 
Configuration/Modules/[name of network adapter]". 

3. Select the entry "General". 
4. In the detailed window, select the entry "Configured mode" in the "Mode of the module" 

list. 
5. Click the "Apply" button. 

Your settings are entered. The network card is now activated. 
6. Select the "Address" entry. 

All the address details of the selected network card are displayed in the detailed window. 
7. Make a note of the "Ethernet(MAC) address" because you will need this to subsequently 

configure the hardware. 
8. Select the entry "Access points". 
9. Double-click the "S7ONLINE" access point in the detailed window.  

The "Properties of S7ONLINE" dialog box opens. 
10. In the "Assigned Interface Configuration" drop-down list, select the entry "PC internal 

(local)" and save your setting by clicking "OK". 
11. Specify "PG mode" as the module operating mode for all other network cards. 
12. Close the configuration console. 
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2.3.3 How to select the communications processor in Simatic Shell 

Introduction 
Below, you will select the communications processor that is used to configure the PC 
stations. 

 

 Note 
If a PC station is used as a single-station system with no connection to other PC stations, the 
following configuration steps are not necessary. 

 

Procedure 
1. Select the PC station (workstation) in the tree view of Windows Explorer. 
2. Select the "Simatic Shell" folder. 
3. Select Settings in the context menu. 

The "Select Terminal bus" dialog opens. 
4. Select the network adapter (communications processor) you want to use to establish 

communication with the engineering station. 
5. Click "OK". 
6. Confirm the next dialog box. 
This initializes the communications processor. 
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2.3.4 How to retrieve the project from the archive 

Introduction 
The basic project is supplied in a zip file with PCS 7. You extract the zip file using a PCS 7 
function. 
  

 

 Note 
The following configuration steps are presented in brief here. You can find detailed 
descriptions in Getting Started - Part 1. 

 
  

Requirement 
SIMATIC Manager is open. 

Procedure 
1. Select File> Retrieve from Archive... from the menu. 
2. Open the"SIEMENS/STEP 7/Examples_MP" folder. 
3. Select the "color_gs.zip" file, and click "Open". 
4. Select the required destination folder. 

The retrieval starts. On completion of retrieval from the archive, the "Retrieve from 
Archive" message window opens. 

5. Click "OK". 
The message dialog "The multiproject 'color_gs_MP' has been retrieved from the archive. 
Do you want to start it now?" dialog box opens. 

6. Click "Yes". 
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2.3.5 How to adapt the hardware configuration of the AS 
 

 Note 
The following configuration steps are presented in brief here. You can find detailed 
descriptions in Getting Started - Part 1. 

 
  

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/SIMATIC 400(1)" folder in the tree view. 
2. Select the "Hardware" object in the detail window and select Edit > Open Object from the 

menu. 
3. Select the CP desired from the hardware catalog.  

If you are using another version of the CP in your project, drag it to the same position as 
the existing CP. 

4. Click "Yes" In the first message box and "OK" in the second message box. 
5. Select the CP 443-1 and select the menu command Edit > Object Properties..... 
6. Click the "Properties" button and enter the MAC address that is printed on your CP in the 

"Properties - Ethernet interface" dialog box. 
7. Clear the "IP protocol is being used" check box. 
8. Select the entry "Ethernet (1)" in the "Subnet" list. 
9. Click "OK" in the "Properties - Ethernet interface" dialog box and then click "OK" in the 

"Properties – CP 443-1" dialog box. 
The CP is adapted for Getting Started - Part 2. 

10. Close HW Config. 
11. When the "Save changes in SIMATIC 400(1)?" message box appears, click "Yes". 



 Preparations for Getting Started - Part 2 
 2.3 Making the preparations 

PCS 7 - Getting Started - Part 2 
Getting Started, 09/2007, A5E00857270-02 27 

2.3.6 How to adapt the blocks for the example project 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "PCS 7 Library V7.0" is open and selected. 

Procedure 
1. Go into the tree view and select the entry  

"PCS 7 Library V7.0/Blocks+Templates/Blocks" 
All blocks are displayed in the detailed window. 

2. Select all blocks that are also contained in your library. 
3. Drag the blocks into the master data library "color_gs_MP/color_gs_Lib/S7 

Program(1)/Blocks". 
The "Insert Function Block" dialog opens. 

4. Click "All". 
This replaces all blocks in the master data library with those from the current version of 
the PCS 7 library. 

5. Select "color_gs_MP/color_gs_Lib/S7 Program(1)/Charts" in the tree view. 
6. Select the process tag type "VALVE". 
7. Select Edit > Open Object from the menu. 

The process tag type is opened in the CFC Editor. 
8. Select Options > Block Types... from the menu. 

The "Block Types" dialog box opens. 
9. Select all blocks in the "Chart Folder" group and click "New Version". 

The "Convert Format" dialog box opens. 
10. Click "Yes" to convert the format. 

If blocks from an older version are in the process tag types, the "Import New Version" 
dialog box opens. 

11. Click "Yes" to update the blocks. 
The "Import New Version" dialog box opens and all identical block types are displayed. 

12. Click "Yes". 
The dialog box closes. 

13. Click "Close". 
14. Close the CFC editor. 
15. Select "color_gs_MP/color_gs_Lib/S7 Program(1)/Blocks" in the tree view. 
16. Select Options > Charts > Update Block Types... from the menu. 

The "Update Block Types" wizard opens. 
– In the "Select the S7 programs to be checked" step, select the "color_gs" project. The 

check boxes for all folders of all S7 programs are activated by default. 
– Click "Continue". 
– All block types are activated by default in the step "Select the block type to be 

updated". 
– Click "Finish". 

The "Convert Format" dialog box closes. 
– Click "Yes" to convert the formats. 

When the update is completed, the log opens and all the block instances in your 
project have been updated. 

17. Click "Close" in the log. 
18. Compile the AS after the block import. 
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2.3.7 How to adapt the project data for the example project 

Requirements 
● The example project is open in SIMATIC Manager. 
● OS(1) is selected in the Component view. 

Procedure 
1. Select Edit > Open Object from the menu. 

The "s7omwinx" dialog box opens. 
2. Click "Yes" if you want to open the project on the local computer.  

WinCC Explorer opens. 
3. Select the entry "OS Project Editor". 
4. In the context menu, select the Open command. 

The OS project editor opens. 
5. Accept the default settings and click "OK". 

The OS project editor updates the project data. 
6. Select the menu command File > Activate. 

Process mode is activated. 
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2.3.8 How to rename the PC station 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Go to the tree view and select the object  

"color_gs_MP/color_gs_Prj/SIMATIC PC-Station(1)". 
2. Select Edit > Rename from the menu. 
3. Enter the name of the local computer as it appears in the network and confirm your entry. 

 

  Note 
You will find the name of your local computer under "System Properties" in the Windows 
Control Panel. 

  
The icon of the PC station is labeled with a yellow arrow in the component view. 
  

 

 Note 
If the PC station is not labeled with a yellow arrow, update the on-screen display using the 
<F5> key. 
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2.3.9 How to adapt the name of the OS 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/[Name of PC station]/WinCC Application/OS(1)" 

object in the tree view. 
2. Select Edit > Open Object from the menu. 
3. The message box "The configured server is not available. Do you want to open the 

project using the local computer as the server?" opens. Click "Yes". 
4. Select the entry "OS(1)/computer" in the tree view of WinCC Explorer. 
5. Select the displayed computer in the detailed window, and select Edit > Properties from 

the menu. 
6. Enter the name of the local computer in the "Computer name" box. 
7. Click "OK". 

 

  Note 
You will find the name of your local computer under "System Properties" in the Windows 
Control Panel. 

8. The message "The name of the computer '[name of the computer]' has changed. The 
change....." appears. Click "OK". 

9. The message "Change computer name" appears. Click "OK". 
10. Close WinCC Explorer. 
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2.3.10 How to adapt the configuration of the OS 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/[Name of the PC Station]" object in the tree view. 
2. Select the "Configuration" entry in the detail window and select Edit > Open Object from 

the menu. 
3. If you are using a different network card in your project, select the desired network card 

from the hardware catalog. Drag this to slot 2 as well. 
This overwrites the existing network adapter. 

4. Click "Yes" In the first message box and "OK" in the second message box. 
5. Select the network card and select Edit > Object Properties... from the menu. 

The "Properties - IE General" dialog box opens. 
6. Click on the "Properties" button in the "General" tab. 
7. Enter the MAC address that you noted from the configuration console into the 

"MAC address" box. 
8. Clear the "IP protocol is being used" check box. 
9. Select the entry "Ethernet (1)" from the "Subnet" list. 
10. Click "OK" in the "Properties – Ethernet Interface IE General" dialog box. 
11. Click "OK" in the "Properties – IE General" dialog box. 
12. Select Station > Save and Compile from the menu. 
13. Close HW Config. 
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2.3.11 How to make settings in NetPro 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Go to the tree view and select the object  

"color_gs_MP/color_gs_Prj/[name of your local computer]/WinCC Application". 
2. Select the "Connections" entry in the detailed window and select Edit > Open Object from 

the menu. 
NetPro opens. 

3. Select the "WinCC Application" object for the SIMATIC PC station. 
4. Select the S7 connection in the lower detailed window and then select the menu 

command Edit > Object Properties. 
The "Properties - S7 Connection" opens. 

5. Check if the correct connection partners have been selected: 
  
Local Partner 
Interface "[Network card of the OS]", e.g., 
IE General 

Interface "[CP of the AS]", e.g., CP 443-1 

  
6. Click "OK". 
7. Select Network > Save and Compile... from the menu. 

The "Delete system data completely from the automation system and replace with offline 
system data. Are you sure?" dialog box opens. 

8. Select the "Compile and check everything" check box in the dialog box and click "OK". 
Once the compilation is completed, the "Outputs for consistency check" window opens. 

9. Open SIMATIC Manager. Mark the PCstation and select PLC > Configure... from the 
menu.  
The "Configure" dialog opens. 

10. Select the required target computer in the "Accessible computers" list. Click "Configure".  
The dialog box “Configure: <Selected Station>” opens. 

11. To perform and apply the remote configuration, follow the instructions in the online help of 
the "Configure: <Selected Station>" dialog box. The configuration data are transferred to 
the PC station. You must still download the network settings to this PC station to activate 
the network connections. 

12. Select the PC station and then the menu command PLC > Download. 
The message dialog "This action will overwrite the configuration data that are already .... 
Do you still want to download?" opens. 

13. Click "Yes". 
The message dialog "Stop Target Modules" opens. 

14. Click "OK". 
The download is completed. 

15. Exit NetPro. 
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Configuring the hardware 3
3.1 Principle of simulation with hardware components 

3.1.1 Implementing simulation with hardware 

Simulation options 
In Getting Started - Part 1, you worked completely without input/output modules because all 
values were simulated using CFC charts. In this part of Getting Started, you have two 
options: 
● You can simulate all process values using CFC charts.  

You will configure the required simulation charts as you create CFC charts. 
● You can simulate certain states of process tags directly using input/output modules 

(distributed I/O ).  
You add these input/output modules and interconnect them with the corresponding block 
inputs/outputs in the CFC charts. To keep the number of input/output modules as low as 
possible, several block inputs/outputs are interconnected to one input in the case of the 
digital input module. 

Bus systems 
Due to the additional distributed I/O, you will need two different buses:  
● Plant bus - Industrial Ethernet: Bus for communication between the ES/OS and AS 
● Fieldbus - PROFIBUS DP: Bus for communication between the distributed I/O and AS 

Overview 
You perform the following steps to add the distributed I/O: 

 
Step What? 
 1 Modify the name of the plant bus (Page 34) 
 2 Adding the distributed I/O (Page 35) 
 3 Assigning symbolic names (Page 38) 
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3.1.2 How to change the name of the plant bus 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/SIMATIC 400(1)" folder in the tree view. 
2. Select the "Hardware" object in the detail window and select Edit > Open Object from the 

menu. 
HW Config opens. 

3. Select the "CP 443-1" in the "UR2" window and then the menu command Edit > Object 
Properties... 
The "Properties - CP 443-1 (R0S5)" dialog box opens and the "General" tab is active. 

4. Click the "Properties" button. 
The "Properties - Ethernet Interface CP 443-1 (R0S5)" dialog box opens. 

5. If the "Ethernet (1)" entry is not yet selected, select it now in the "Subnet" list and click the 
"Properties" button. 

6. Enter the name "Plant bus" in the "Name" box of the "Properties - Industrial Ethernet" 
dialog box, and click "OK". 

7. Click "OK" in the "Properties - Ethernet interface" dialog box and "OK" in the "Properties - 
CP 443-1" dialog box. 
The name of the Ethernet bus is changed. 
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3.1.3 How to add the distributed I/O 

Requirement 
HW Config of the example project is open. 

Procedure 
1. Select "PROFIBUS(1)". 

PCS 7 has automatically created this bus when creating the project. 
2. Select Edit > Object Properties... from the menu. 

The "Properties - DP Master System" dialog box opens. 
3. Click "Properties". 

The "Properties - PROFIBUS" dialog box opens, and the "General" tab is active. 
4. Enter the name "Fieldbus" in the "Name" box. 
5. Change to the "Network settings" tab and check the following settings: 

– Transmission rate: 1.5 Mbps 
– Profile: DP 

6. Click "OK". 
The dialog box closes. 

7. Click "OK" in the "Properties – DP Master System" dialog box. 
The name "Fieldbus" is now assigned to the subnet. 

8. Open the hardware catalog and select the component  
PROFIBUS-DP/ET 200M/IM 153-1" component with order number 6ES7 153-1AA03-
0XB0 and move it onto the "Fieldbus" DP Master system using a drag-and-drop 
operation. 
The "Properties - PROFIBUS Interface IM 153-1" dialog box opens. 

9. Select the entry "3" from the "Address" list, and click "OK" . 
The dialog box closes and the IM 153-1 is inserted. 
Video  

  
 

10. Select the "IM 153-1" object. 
The associated slots are displayed in the lower part of the window. 
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11. Select the following input/output modules from the hardware catalog and move them onto 
the slots of the IM 153-1 using a drag-and-drop operation: 

 
Module type Location in the hardware catalog Order number Slot 
Digital input module DI-300/SM 321 DI16xDC24V 6ES7 321-1BH01-0AA0  4 
Digital output module DO-300/SM 322 

DO16xDC24V/0.5A 
6ES7 322-1BH01-0AA0  5 

Analog input module AI-300/SM 331 AI8x12Bit 6ES7 331-7KF01-0AB0  6 
Analog output module AO-300/SM 332 AO4x12Bit 6ES7 332-5HD01-0AB0  7 

 
12. Select Station > Save from the menu. 

Result 
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3.2 Function and use of symbolic names 

3.2.1 Using symbolic names 

Introduction 
The input/output modules are inserted in HW Config. You now assign descriptive symbolic 
names to the inputs and outputs of these modules. You use these names for interconnecting 
the process tags with the input and output modules. This makes working with the confusing 
absolute addresses much easier. 
  

 

 Note 
Note the special feature in this example project: 
The inputs and outputs of several process tags of the same type are interconnected to one 
input/output of an input/output module. The input of a digital input module is, for example, 
interconnected with several valves. This procedure minimizes the hardware required to 
implement the example project. 
In a real project you always interconnect each block input/output with just one input/output of 
an input/output module. 

 
  

Syntax of the symbolic names 
The assignments of absolute addresses to the symbolic names are listed in the tables on the 
following pages. The corresponding process tag for each symbolic name is given in the 
comments. All variable name components in the symbolic names are represented by an "x".  
The symbolic name "NK31x_open" means: 
● "NK" stands for the process tag (in this case a "valve") 
● "31" stands for the part of the plant (in this case for the "REAC1" part of the plant) 
● "x" stands for the variable name component 
● "open" stands for the state of the process tag (in this case "open") 
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3.2.2 How to assign symbolic names 

Requirement 
HW Config of the example project is open. 

Procedure 
1. Select the "IM 153-1" module in the work area. 

All input/output modules that you inserted during hardware configuration are displayed in 
a list window. 

2. Select the "DI16xDC24V" module in the list. 
3. Select Edit > Symbols... from the menu. 

The "Edit Symbols" dialog box opens. All absolute addresses of the inputs of these 
modules are specified for you in a list. 

4. Position the cursor in the "Symbol" column next to the address "I 0.0". 
5. Enter the value "NK31x_open" and press the <TAB> key. 

The value you entered is applied and the system automatically enters the data type as 
"BOOL". 

6. Switch to the "Comment" column. 
7. Enter the appropriate comment in the table and press the <TAB> key.  

This automatically moves the cursor to the next line in the "Symbol" column. 
Video  
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8. Repeat steps 4 to 6 and enter the values corresponding to the table under "Symbolic 
Names for the Digital Input Module (Page 40)". 

  
 

 Note 
Click on the "Apply" button to save the interim statuses of your entries.  
Use the Windows "Copy and Paste" function to quickly edit the texts in the "Comment" 
column. 

 
  

 
 

9. Click "OK" to save your entries.  
The "Edit Symbols" dialog box closes. 

10. In the list window, select the following modules and assign them symbolic names. To do 
so, perform steps 3 through 9. The symbols are listed in the corresponding tables: 
– DO8xDC24V/0.5A - "Symbolic names for the digital output module (Page 41)" 
– AI8x12Bit - "Symbolic names for the analog input module (Page 42)" 
– AO4x12Bit - "Symbolic names for the analog output module (Page 42)" 

11. Once you have assigned all of the symbolic names, select Station > Save and Compile 
from the menu. 
Your entire hardware configuration is saved. 

12. Close HW Config. 
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3.2.3 Symbolic names for the digital input module 

Overview 
All symbolic names for the digital input module are listed in the following table:  

 
Address Symbolic 

name 
Data type Comment 

I 0.0 NK31x_open BOOL Valves Reactor 1, open 
NK311, NK312, NK313, NK314, NK315 

I 0.1 NK32x_open BOOL Valves Reactor 2, open 
NK321, NK322, NK323, NK324, NK325 

I 0.2 NR3x1_on BOOL Agitator Reactors 1, 2, ON 
NR311, NR321 

I 0.3 NP3x1_on BOOL Pump Reactors 1, 2, ON 
NP311, NP321 

I 0.4 NK31x_close BOOL Valves Reactor 1, closed 
NK311, NK312, NK313, NK314, NK315 

I 0.5 NK32x_close BOOL Valves Reactor 2, closed 
NK321, NK322, NK323, NK324, NK325 

  



 Configuring the hardware 
 3.2 Function and use of symbolic names 

PCS 7 - Getting Started - Part 2 
Getting Started, 09/2007, A5E00857270-02 41 

3.2.4 Symbolic names for the digital output module 

Overview 
All symbolic names for the digital output module are listed in the following table:  

 
Address Symbolic 

name 
Data type Comment 

Q 0.0 NK311_copen BOOL Valve Reactor 1 NK311 open 
Q 0.1 NK312_copen BOOL Valve Reactor 1 NK312 open 
Q 0.2 NK313_copen BOOL Valve Reactor 1 NK33 open 
Q 0.3 NK314_copen BOOL Valve Reactor 1 NK314 open 
Q 0.4 NK315_copen BOOL Valve Reactor 1 NK315 open 
Q 0.5 NK321_copen BOOL Valve Reactor 2 NK321 open 
Q 0.6 NK322_copen BOOL Valve Reactor 2 NK322 open 
Q 0.7 NK323_copen BOOL Valve Reactor 2 NK323 open 
Q 1.0 NK324_copen BOOL Valve Reactor 2 NK324 open 
Q 1.1 NK325_copen BOOL Valve Reactor 2 NK325 open 
Q 1.2 NR311_con BOOL Agitator Reactor 1 NR311 ON 
Q 1.3 NR321_con BOOL Agitator Reactor 2 NR321 ON 
Q 1.4 NP311_con BOOL Pump Reactor 1 NP311 ON 
Q 1.5 NP321_con BOOL Pump Reactor 2 NP321 ON 

  



Configuring the hardware  
3.2 Function and use of symbolic names 

 PCS 7 - Getting Started - Part 2 
42 Getting Started, 09/2007, A5E00857270-02 

3.2.5 Symbolic names for the analog input module 

Overview 
All symbolic names for the analog input module are listed in the following table:  

 
Address Symbolic 

name 
Data type Comment 

IW 512 LI311 WORD Fill level measurement Reactor 1 
LI311 

IW 514 LI321 WORD Fill level measurement Reactor 2 
LI321 

IW 516 LI311_V WORD Drainage rate Reactor 1 
LI311 

IW 518 LI321_V WORD Drainage rate Reactor 2 
LI321 

IW 520 TC311 WORD Temperature control Reactor 1 
TC311 

IW 522 TC321 WORD Temperature control Reactor 2 
TC321 

3.2.6 Symbolic names for the analog output module 

Overview 
All symbolic names for the analog output module are listed in the following table:   

 
Address Symbolic 

name 
Data type Comment 

QW 512 LI311_c WORD Fill level Reactor 1 
LI311 

QW 514 LI321_c WORD Fill level Reactor 2 
LI321 

QW 516 TC311_c WORD Temperature Reactor 1 
TC311 

QW 518 TC321_c WORD Temperature Reactor 2 
TC321 
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Working in the plant hierarchy 4
4.1 Adapting the plant hierarchy 

Introduction 
You already know how to work with the plant hierarchy (PH) from Getting Started - Part 1. In 
Getting Started - Part 2, you extend the PH to include all objects required for the overall 
project. 
You insert all folders and process pictures you require for the overall plant.  
Note: Not all charts and process pictures are configured in this Getting Started. 

Task definition 
The following folders and process pictures must be added to the existing plant hierarchy: 

 
Name of the  
hierarchy folder 

Meaning Process picture Relevant to  
Getting Started - Part 2 

WEIGHT Dosing solids WEIGHT no 
REAC1 Production REAC1 yes 
HOLD Holding phase HOLD no 
FILL Filling FILL no 

 
You performed the generic settings in Getting Started - Part 1. Do not make any further 
settings at this point. 
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4.2 How to expand the plant hierarchy 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Prj/Plant1" 
2. Select Insert > Technological Objects > 1 Hierarchy Folder from the menu. 

The new hierarchy folder "Unit(3)" is inserted. 
3. Change its name to "WEIGHT". 
4. Select the hierarchy folder in the detailed window and select Edit  > Object Properties... 

from the menu. 
The "Properties - Hierarchy Folder" dialog box opens. 

5. Check the following settings in the "OCM Attributes" tab: 
– The "Name of the hierarchy folder is part of the HID" check box is activated. 
– The "No modification when renaming the hierarchy folder" check box is cleared. 

6. Click "OK". 
The dialog box closes and the settings are applied. 

7. Repeat steps 1 to 6 to create the following hierarchy folders: 
– REAC1 
– HOLD 
– FILL 
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Result 
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4.3 How to add process pictures 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/Plant1/FILL" folder in the tree view. 
2. Select Insert > Technological Objects > 5 Picture from the menu. 

The new object "Picture(9)" is inserted. 
3. Enter the name "FILL". 
4. Insert additional process pictures in the following folders:  

 
Folder Name of the process picture 
HOLD HOLD 
REAC1 REAC1 
WEIGHT WEIGHT 
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Using textual interconnections 5
5.1 What are textual interconnections? 

Textual interconnections 
Textual interconnections are used if no interconnection partner is yet available. If an 
interconnection is made to the block input/output of a CFC chart that has not yet been 
created and configured, then a textual interconnection is used. 
Textual interconnections can be used in configuring both CFC and SFC charts.  
Textual interconnections can only be made to block inputs.  

Types of textual interconnections 
There are two basic types of textual interconnections: 
● Textual interconnection as path reference: 

You enter the specific path to the block input to which the interconnection is to be made. 
The syntax is as follows: 
[name of the CFC chart]\[name of the block].[name of the I/O] 
In this case, the chart does not need to exist yet. 

● Textual interconnection as character string: 
This textual interconnection functions as a placeholder. This placeholder is given a 
descriptive name and can be replaced manually at a later time by specifying a path. The 
path is specified as described previously. This type of textual interconnection is mainly 
used for the creation of process tag types: You enter a string in the process tag type. This 
is not a random string: It should indicate the path reference that must be specified when 
creating individual process tags. 

Textual interconnections in this getting started 
In this Getting Started, you will encounter the textual interconnections in the following places:  
● When making corrections to the RMT1 and RMT2 parts of the plant:  

Here you delete the default interconnections not required from the PCS 7 process tag 
types. 

● When working with process tag types:  
Here you learn how to use textual interconnections in the import files. 

● When working with SFC charts:  
Here you learn how to use textual interconnections when entering the parameters for 
steps and transitions. 
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5.2 Textual interconnections in CFC charts 

Textual interconnections as path references 
During CFC configuration, textual interconnections are used as path references when the 
corresponding connection partner is not yet available. 
  

 

 Note 
In CFC configuration, textual interconnections can only be used for block inputs. 

 
  

Cross-chart interconnections 
During CFC configuration, textual interconnections as path references also enable cross-
chart interconnections to already existing connection partners. 
Standard creation of a cross-chart interconnection: 
1. You click on a block output of chart 1. 
2. You change to chart 2. 
3. There, you click on the corresponding block output of the interconnection partner. 

Creating a cross-chart interconnection using textual interconnection: 
4. You specify the path reference to the block output of the corresponding interconnection 

partner on the block input of chart 2. 
The textual interconnection is made immediately. 

Representation in the sheet bar 
A textual interconnection is shown in the sheet bar of the CFC chart. 
● As long as there is no actual interconnection partner to which the textual interconnection 

refers, it is identified with a yellow triangle. 
● As soon as an actual interconnection partner is available, the yellow triangle is deleted 

and the textual interconnection is replaced by a real interconnection. The complete 
interconnection at the block output and at the block input of the interconnection partner is 
displayed. 

By double-clicking on the interconnection in the sheet bar, you change to the corresponding 
I/O in the CFC chart as usual. 
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5.3 Textual interconnections in SFC charts 

Textual interconnections as path references 
As in CFC configuration, textual interconnections are used as path references when the 
corresponding connection partner is not yet available.  
You enter the textual interconnection as a path reference to the block input/output in the SFC 
chart.  
  

 

 Note 
When using textual interconnections in SFC charts, you can execute textual interconnections 
to block inputs and block outputs. 

 
  

Representation in the "Properties [Step]" or "[Transition]" dialog box 
As with CFC charts, textual interconnections that are not closed are identified by the color 
yellow as follows:  
● in SFC charts by yellow highlighting 
● In CFC charts by a yellow triangle 
In this case, this applies to all block inputs/outputs for the "REAC2" part of the plant since 
you have not yet created any CFC charts for it.  
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Configuring CFC charts with the use of rational 
functions 6
6.1 Overview of the work in CFC 

Configuration tasks 
During CFC configuration, you will perform the following configuration steps: 
● Expand the master data library. 

In the "REAC" part of the plant, you use additional blocks that you have previously stored 
in the master data library. 

● Corrections in the plant sections "RMT1" and "RMT2" 
These corrections are necessary to combine the plant sections RMTx and REACx. 

● Create and use the simulation charts 
The statuses of the valves, motors, etc., are simulated using these charts. 

● Work with process tag types 
Using this function you can conveniently create process tags of the same types. 
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6.2 Expanding the master data library 

6.2.1 Expanding the master data library 

Introduction 
You are familiar with the master data library from Getting Started - Part 1: There you stored 
all the blocks required for the example project "color_gs". For Getting Started - Part 2, you 
require some additional blocks. Before you begin to create the CFC charts, you must save 
them in the master data library. 

Blocks from the various libraries 
 

Object  
name 

Symb. 
name 

Meaning Type of  
block 

Library 

FB51 PT1_P Time delay of an input signal Technological block PCS 7 Library V70
FC256 ADD4_P Calculates the sum of up to 

4 values 
Technological block PCS 7 Library V70

SFB5 TOF Delay of output signal for 
temperature control to maintain 
the maximum temperature for 
longer 

System function block Standard library 

SFB4 TON Reset of valves System function block Standard library 
SFB3 TP Reset of valves System function block Standard library 
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6.2.2 How to store the additional blocks 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Select File > Open... from the menu. 
2. Select the "Libraries" tab and select the following libraries: 

– "PCS 7 Library V70" 
– "Standard Library" 

3. Click "OK". 
4. Click "OK" in the message box "The project or the "Standard Library..." is on a write-

protected medium or.....". 
All libraries are opened in the component view. 

5. Copy the following blocks from the standard libraries to your master data library in the 
folder  
"<color_gs_MP>/color_gs_Lib/S7-Program(1)/Blocks". 
 

 

  Note 
Select the window of the appropriate library. 
Activate the detailed view in all of the libraries. It provides you with more information 
about the blocks. 

  
 

Library/folder Blocks 
PCS 7 Library V70/Blocks + Templates/Blocks • FB51 

• FC256 
Standard Library/System Function Blocks/Blocks • SFB3 

• SFB4 
• SFB5 

  
6. Close the libraries. 
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6.3 Simulation charts and chart-in-chart technique 

6.3.1 Implementing simulation with CFC charts 

Simulation options 
You simulate the statuses of the process tags, for example, the fill level of the reactor or the 
valve states. Two options are available: 
● Via the input and output modules  

You have already configured these during hardware configuration. You have inserted the 
input and output modules and assigned the relevant symbolic names. 

● Using special simulation charts 
These charts simulate data, such as values for the fill level. You will configure these 
simulation charts now. 

You can choose between these two simulation types. For this purpose you will create the 
special "GENERAL" CFC chart. It facilitates this selection on the OS in process mode. You 
can use it to simulate selectively using CFC charts or using input/output modules, provided 
that you have connected input/output modules. 
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6.3.2 Function of the simulation charts 

Necessary simulation charts 
For each process tag type, you create a CFC chart for the simulation. The "REAC1" part of 
the plant requires the following simulation charts: 
● SIMV:  

Simulation of the valve state 
open or closed 

● SIMMO: 
Simulation of a motor state 
on or off 

● SIMREAC: 
Simulation of the fill level in the reactors 

Chart-in-chart technique 
When using the simulation charts, you will become acquainted with a function of rational 
engineering:  
This is the chart-in-chart technique.  
This involves inserting one CFC chart into another. The inserted chart then becomes the so-
called hierarchical chart and the other the top chart. This enables you to use a CFC chart 
repeatedly once it has been created.  
 

Example 
You create a simulation chart for a valve.  
You can insert this simulation chart as a hierarchical chart in the top chart for the "valve" 
process tag.  
You can open and, if necessary, edit the hierarchical chart from the top chart at any time.  
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Chart inputs/outputs 
The following procedure simplifies the use of a hierarchical chart in a top chart: 
You define the so-called chart inputs/outputs.  
These are specific inputs/outputs that you need for interconnecting to the top chart or to 
other CFC charts. The display of a hierarchical chart is therefore the same as the display of 
a block: all chart I/Os are shown like the I/Os of a block and are interconnected in the same 
way. 
You store the "hierarchical charts" in your master data library to ensure that you have fast 
and easy access to them. 
  

 

NOTICE  
Note that if you make subsequent changes in the original simulation chart, these changes 
are not automatically applied to all the locations where the chart has been used.  
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6.3.3 Function of the "General" CFC chart 

"GENERAL" CFC chart 
Besides the simulation charts, you require a special chart for the simulation: 
This is the "GENERAL" CFC chart. 
This CFC chart fulfills two purposes: 
● Selection of the simulation mode by the plant operator 
● Resetting the monitoring error for the valves 

Selection and activation of the simulation mode 
You create the simulation either using input and output modules or using simulation charts. 
You select the simulation mode via an operator control block. The output of this operator 
control block is interconnected to the "SIM_ON" input of the input blocks. 
The simulation method is automatically set to simulation using CFC charts on CPU startup. It 
can be switched over to simulation using input/output modules during process mode by 
means of the operator control block. 

Reset of valves 
The "GENERAL" CFC chart also fulfills another function:  
It resets the monitoring error for all valves that occurs immediately after starting in process 
mode.  
Without the "GENERAL" CFC chart, the plant operator would have to reset this monitoring 
error manually for each valve in the faceplate in order for the SFC chart to be executed. This 
would require too much effort in this project. At CPU startup, the "General" chart sets the 
"L_RESET" input for every valve temporarily to "1". 
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6.3.4 How to insert CFC charts for REAC1 
  

 

 Note 
The simulation charts and the "General" CFC chart are stored in different folders: 
• Simulation charts are stored in the "Templates" folder of the master data library to ensure 

fast access for reuse purposes. 
• The "General" CFC chart is stored in the "REAC1" folder. 

 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/Plant1/REAC1" folder in the tree view. 
2. Select Insert > Technological Objects > 2 CFC from the menu, and insert a new CFC 

chart with the name "GENERAL". 
3. Select the "color_gs_MP/color_gs_Lib/Templates" folder in the tree view. 
4. Select Insert > Technological Objects > 2 CFC from the menu, and insert new CFC 

charts there with the names listed below. 
– SIMV 
– SIMMO 
– SIMREAC 
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6.3.5 How to Create the "General" Chart 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/Plant1/REAC1" folder in the tree view, and open 

the "GENERAL" CFC chart. 
This also opens the catalog. 
  

 

  Note 
If the catalog is not open by default, select View > Catalog from the menu. 
The catalog is then opened on the right of the window. 

  
2. Select the "Libraries" tab, and drag the "OP_D" block from the "color_gs_Lib\ S7 

Program(1)\ Blocks\\Operate" library. 
This is the operator control block for selecting the type of simulation. 

3. Select the "OP_D" block and select Edit > Object Properties... from the menu. 
4. Enter the following parameters as listed in the table: 

– General" tab: Name of the block 
– "I/O" tab: Values of the I/Os  

 
Name of the block I/O Value 
ACT_SIM LINK_I   1 

  
5. Save your entries by clicking "OK". 

At this point, you will not be creating any further entries or interconnections. 
6. Open the "color_gs_Lib\S7 Program(1)\Blocks\IEC_TC" library in the catalog. 
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7. Use drag-and-drop to insert additional objects, and arrange them according to the graphic 
below. 
– TP 
– TON 

TP 

ACT_SIM 

TON 

 
 

8. Enter the parameters according to the following table:  
 

Block Name I/O Value 
IN  1 TP RESET_TP 
PT  2s 

TON RESET_TON PT  1s 

  
9. Make the following interconnections. You know the procedure from  

Getting Started - Part 1:  
 

Block I/O Block I/O 
RESET_TP Q RESET_TON IN 
RESET_TP Q ACT_SIM LINK_ON 

  
10. Close the "GENERAL" CFC chart. 



 Configuring CFC charts with the use of rational functions 
 6.3 Simulation charts and chart-in-chart technique 

PCS 7 - Getting Started - Part 2 
Getting Started, 09/2007, A5E00857270-02 61 

6.3.6 How to create the "SIMV" simulation chart 

Overview 
You create the "SIMV" CFC chart in three steps: 
  
Step What? 
 1 Insert blocks (Page 61) 
 2 Configure connections (Page 63) 
 3 Make Interconnections (Page 64) 

6.3.7 Step 1 - How to insert blocks into "SIMV" 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go the the tree view and select the folder  

"color_gs_MP/color_gs_Lib/Templates", and open the "SIMV" CFC chart. 
The chart is opened in the CFC editor. 

2. Use a drag-and-drop operation to insert the blocks listed in the table in the specified order 
and arrange them to correspond to the figure below. 

  
 

 Note 
The table provides information about the name of the storage folder and the function of the 
blocks. 
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Storage in the catalog  Block 
  Tab Folder 

Function 
  

SEL_R Blocks "MULTIPLX" Depending on the value at output 
VALVE.QCONTROL of the top chart, one of 
the inputs is activated and interconnected to 
the input of the integrator. 

INT_P Libraries "color_gs_Lib\S7 Program(
1)\Blocks\Control" 

Generates a time integral for the input value 

  

SEL_R INT_P 
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6.3.8 Step 2 - How to assign parameters for the inputs and outputs of "SIMV" 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "SIMV" CFC chart is open in the CFC Editor. 

Procedure 
1. Select the desired block and select Edit > Object Properties... from the menu. 
2. Enter the following parameters as listed in the table: 

– General" tab: Name of the block 
– "I/O" tab: Values of the I/Os  

 
Block Name I/O Meaning Value 

IN0 This value is switched through to the 
INT_P block when input "K" = 1.  

 16.0 SEL_R SEL_OPEN_CLOSE

IN1 This value is switched through to the 
INT_P block when input "K" = 0.  

 -16.0 

INT_P SIM_DELAY V_HL Upper limit of the integrated value  100 * 

 * default 
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6.3.9 Step 3 - How to interconnect the inputs and outputs of "SIMV" 
 When interconnecting, you make the interconnection between the individual blocks - you 
have already done this frequently - as well as the interconnection to the chart inputs/outputs.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The "SIMV" CFC chart is open in the CFC Editor. 

Procedure 
3. Interconnect the inputs and outputs as listed in the table: 

 
Block Output Block Input 
SEL_OPEN_CLOSE OUT SIM_DELAY U 

  
4. Select View > Chart Inputs/Outputs from the menu. 

The interface editor opens to allow you to edit the chart inputs/outputs. 
5. Select the "Interface/IN" entry in the tree view. 

An empty input line is displayed in detailed window. 
6. Drag block I/O "K" from the "SEL_OPEN_CLOSE" block to the "Name" field of the 

interface editor. 
An interconnection is displayed in the sheet bar. It is identified with a white triangle. This 
interconnection identifies an interconnection to a chart input/output. The name of the 
block input/output is applied by default in the "Name" box of the interface editor. 

7. Click in the "Name" box and change the default name to "CONTROL". 
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8. Enter the other parameters in the entry line: 
– The "Data type" "Bool" and the initial value "FALSE" are set automatically. 
– Click in the "Comment" field, and enter the text "Control output VALVE.QCONTROL". 
  

 

  Note 
If the whole text does not fit into the edit box, increase the column width until it fits. 

  

 
 

9. Select the "Interface/OUT" entry in the tree view of the interface editor. 
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10. Use a drag-and-drop operation to move the following block inputs/outputs to the "Name" 
box, and define the parameters in accordance with the following table:  

 
Block Block  

I/O 
Name of  
chart I/O 

Data type of 
chart I/O 

Comment for chart I/O 

SIM_DELAY QVHL FBOPEN BOOL Feedback value 
VALVE.FBOPEN 

SIM_DELAY QVLL FBCLOSE BOOL Feedback value 
VALVE.FBCLOSE 

  
 

 Note 
You do not have to enter an initial value for outputs. 

 
Video   

 
 

11. Select View > Chart Inputs/Outputs from the menu. 
The interface editor is closed. 

12. Close the "SIMV" CFC chart. 
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6.3.10 How to create the "SIMMO" simulation chart 
To create the "SIMMO" simulation chart you use basically the same procedure as described 
for the "SIMV" chart. Brief instructions for the procedure are given below along with tables 
containing the required values.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Lib/Templates", and open the "SIMMO" CFC chart via the detail 
view. 

2. Drag the following blocks to insert them and arrange them as shown in the figure below: 
 

Storage in the catalog  No. Block 
Tab Folder 

Function 

 1 SEL_R Blocks "MULTIPLX" Depending on the value at 
output MOTOR.QSTART 
of the top chart, one of the 
inputs is activated and 
interconnected to the input 
of the integrator. 

 2 INT_P Libraries "color_gs_Lib\S7 Program(1) 
\Blocks\Control" 

Generates a time integral 
for the input value 

  

SEL_R INT_P 
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3. Select each individual block, select Edit > Object Properties... from the menu, and enter 
the following parameters: 

 
Block Name I/O Meaning Value 

IN0 This value is switched through to the INT_P 
block when the value of QSTART from the 
"MOTOR" block is "1". 

 50.0 SEL_R SEL_RUN_STOP

IN1 This value is switched through to the INT_P 
block when the value of QSTART from the 
"MOTOR" block = "0". 

 -50.0 

INT_P SIM_DELAY V_HL High limit of the integrated value  100 * 

 * default 
  
4. Make the following output-input interconnection: 

 
Block Output Block Input 
SEL_RUN_STOP OUT SIM_DELAY U 

  
5. Select View > Chart Inputs/Outputs from the menu, and drag the following chart 

inputs/outputs to associate them with parameters: 
 

Interface 
interface editor 

Block Block  
I/O 

Name of chart 
I/O 

Data type of 
chart I/O 

Comment for chart 
I/O 

IN SEL_RUN_STOP K START Bool Control output 
MOTOR.QSTART 

OUT SIM_DELAY QVHL FBRUN Bool Feedback value  
MOTOR.FB_ON 

  
6. Close the CFC chart. 
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6.3.11 How to create the "SIMREAC" simulation chart 
As was the case with the CFC chart for motor simulation, we present brief instructions for the 
procedure along with tables containing the required values.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Lib/Templates", and open the "SIMREAC" CFC chart via the 
detail view. 

2. Drag the following blocks to insert them and arrange them as shown in the figure below: 
 

Storage in the catalog  No. Block 
Tab Folder 

Function 

 1 AND 
4 x 

Blocks BIT_LGC Controls whether RMT1 or RMT2 is 
feeding REAC1 or REAC2 

 2 OR 
2 x 

Blocks BIT_LGC Controls whether RMT1 or RMT2 is 
feeding REAC1 or REAC2 

 3 SEL_R 
3 x 

Blocks "MULTIPLX" The fill level of the reactor is simulated 
based on which action has just taken 
place: 
• If raw material feed is taking place, 

the dosing amount from RMT1 or 
RMT2 is used as the input value 
for the integrator. 

• When a drainage process is 
occurring, a negative value is used 
as the input value for the 
integrator. 

 4 INT_P Libraries "color_gs_Lib\S7 Program(1)
\ 
Blocks\CONTROL" 

Generates a time integral for the 
respective input value 

 5 ADD4_P Libraries "color_gs_Lib\S7 Program(1)
\ 
Blocks\MATH" 

Adder, generates the sum of the input 
values 
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SEL_R

INT_P

SEL_R

SEL_R

ADD4_P

AND

AND

AND

AND

OR

OR

 
 

3. Select each individual block, select Edit > Object Properties... from the menu, and enter 
the following parameters:  

 
Block Name I/O Meaning Value 
AND1 RMT1_REAC1  If the pump from RMT1 is running and the 

valve to REAC1 is open, then the fill level for 
REAC1 is simulated. 

 

AND2 RMT1_REAC2  If the pump from RMT1 is running and the 
valve to REAC2 is open, then the fill level for 
REAC2 is simulated. 

 

AND3 RMT2_REAC1  If the pump from RMT2 is running and the 
valve to REAC1 is open, then the fill level for 
REAC1 is simulated. 

 

AND4 RMT2_REAC2  If the pump from RMT2 is running and the 
valve to REAC2 is open, then the fill level for 
REAC1 is simulated. 

 

OR1 RMT1_REAC1_or_2  Depending on the AND operation, dosing 
takes place from RMT1 to REAC1 or to 
REAC2. 

 

OR2 RMT2_REAC1_or_2  Depending on the AND operation, dosing 
takes place from RMT2 to REAC1 or to 
REAC2. 

 

SEL_R1 RMT1 IN1 When no dosing is occurring in RMT1, the 
value "0" from IN1 is used as the input value 
for the adder. 

 0 * 

SEL_R2 RMT2 IN1 When no dosing is occurring in RMT2, the 
value "0" from IN1 is used as the input value 
for the adder. 

 0 * 
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Block Name I/O Meaning Value 
SEL_R3 BOUT IN1 When no drainage process is occurring, the 

value "0" from IN1 is used as the input value 
for the adder. 
When the drainage process is occurring, 
then the value from IN0 is used. This value is 
negative because it has to represent the 
reduction of the fill level. 

 0 * 

ADD4_P ADD  All outputs of the SEL_R blocks are 
connected to the adder.  

 

INT_P SIM_VOL V_HL The integrator defines the high limit based 
on the maximum value of the fill level. 

 1200.
0 

  TI Reset time  2.0 
  HYS Hysteresis  1 * 

 * default 
  
4. Make the following output-input interconnections:  

 
Block Output Block Input 
RMT1_REAC1 OUT RMT1_REAC1_or_2 IN1 
RMT1_REAC2 OUT RMT1_REAC1_or_2 IN2 
RMT1_REAC1_or_2 OUT RMT1 K 
RMT1 OUT ADD U1 
RMT2_REAC1 OUT RMT2_REAC1_or_2 IN1 
RMT2_REAC2 OUT RMT2_REAC1_or_2 IN2 
RMT2_REAC1_or_2 OUT RMT2 K 
RMT2 OUT ADD U2 
BOUT OUT ADD U3 
ADD V SIM_VOL U 
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5. Select View > Chart Inputs/Outputs from the menu, and drag the following chart 
inputs/outputs to associate them with parameters:  

 
Interface 
interface  
editor 

Block Block  
I/O 

Name of chart 
I/O 

Data type 
of chart 
I/O 

Comment for chart I/O 

RMT1_REAC1 IN1 BVALV_RMT1_1 Bool Valve for dosing from 
RMT1 to REAC1 

RMT1_REAC1 IN2 BMOT_RMT1 Bool Pump for dosing RMT1 
RMT1_REAC2 IN1 BVALV_RMT1_2 Bool Valve for dosing from 

RMT1 to REAC2 
RMT1_REAC2 IN2 BMOT_RMT1 

already created 
Bool Pump for dosing RMT1 

RMT1 IN0 ARMT1 Real  Dosing process value 
DOSE.PV_OUT from 
RMT1 

RMT2_REAC1 IN1 BVALV_RMT2_1 Bool Valve for dosing from 
RMT2 to REAC1 

RMT2_REAC1 IN2 BMOT_RMT2 Bool Pump for dosing RMT2 
RMT2_REAC2 IN1 BVALV_RMT2_2 Bool Valve for dosing from 

RMT2 to REAC2 
RMT2_REAC2 IN2 BMOT_RMT2 

already created 
Bool Pump for dosing RMT2 

RMT2 IN0 ARMT2 Real Dosing process value 
DOSE.PV_OUT from 
RMT2 

BOUT K BOUT Bool Pump drainage from 
REAC1 

IN 

 IN0 AOUT Real Drain speed for REAC1 
from CFC_LI311 

OUT SIM_VOL V LEVEL_ 
OUTPUT 

Real Simulation value for fill 
level 
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 Note 
To be able to distinguish the chart inputs/outputs better, the following name convention is 
used: 
• A" prefix means "Analog" 
• B" prefix means "Digital" 

 
  
6. Close the CFC chart. 
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6.4 Working with process tag types 

6.4.1 Use of process tag types 

Introduction 
Process tag types are used if there are many process tags of the same type in the project. 
A CFC chart is the basis of a process tag type. You do not have to create a separate CFC 
for each individual process tag if you use process tag types. 
You first create a kind of basic CFC chart with all the generally valid parameters. 
You duplicate this chart using import/export functions. By doing so you create instances of 
the process tag type with its properties. 
With the import/export function, you enter the required process tag-specific parameters for 
each process tag to be created. 
PCS 7 offers the advantage that you can also specifically adapt the process tags created in 
this way. For example, if you are generating several motor process tags, you can add a 
variety of interlock mechanisms for each process tag. These are not overwritten even when 
you perform a new import. 
  

 

NOTICE  
You must not change the following for the created process tags: 
• Specific adaptations to the block inputs/outputs for which parameters were assigned via 

the import file. These adaptations are overwritten with the parameters defined in the 
import file when a new import operation takes place. 

• Changes to the block names 
 

  
In Getting Started - Part 1, you became familiar with process tag types: You used the 
standard process tag types that PCS 7 makes available for the motor and valves. In this part 
of Getting Started, you create process tag types yourself. 
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Basic procedure for creating process tag types 
To create process tag types, proceed as follows: 
● First, based on the concrete project, define all of the process tags of the same type that 

you can create from process tag types. 
● Then, create the CFC chart that will be used as the top chart for the process tag type. 
● Create a process tag type from this. In so doing you define which block inputs/outputs are 

to be individually assignable for the process tags created using the process tag type. 
● There are two options for creating the process tags: 

– You create an import file. 
You enter the process tags to be created along with their parameters for all block I/Os. 
You then create the individual process tags. 
This option is described in detail in this Getting Started. 

– You place the process tag type at the desired location in the plant hierarchy.  
You enter the relevant parameters. 
This option is not described in this Getting Started. 

Process tag types required for the REAC part of the plant 
You can create the following process tags in your example project using process tag types: 
● Motors: Agitators and drainage pumps 
● Valves: All 
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6.4.2 How to create "MOTOR" process tags using process tag types 

Overview 
You create the process tag types and the process tags from a process tag type for motor 
process tags in five steps: 
  

 
Step What? 
 1 Creating the "TYPE_MOTOR" basic chart (Page 76) 
 2 Creating the "TYPE_MOTOR" process tag type (Page 79) 
 3 Creating the "MOTOR_REAC1" import file (Page 84) 
 4 Editing the "MOTOR_REAC1" import file (Page 86) 
 5 Generating "TYPE_MOTOR" process tags (Page 90) 

  

6.4.2.1 Step 1 - How to create the "TYPE_MOTOR" top chart 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Lib/Process Tag Types". 
2. Insert a CFC chart and name it "TYPE_MOTOR". 
3. Open the "TYPE_MOTOR" CFC chart in the CFC Editor. 
4. Open the "color_gs_Lib/S7 Program(1)/Blocks" library in the catalog. 
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5. Use a drag-and-drop operation to insert the following objects and arrange them according 
to the graphic below. 
– DRIVER/CH_DI 
– CONTROL/MOTOR 
– DRIVER/CH_DO 

CH_DO 

CH_DI 

MOTOR 

 
 

6. Enter the parameters according to the following table:  
 

Block Name in project 
CH_DI FBON 
MOTOR MOTOR 
CH_DO COUT 

  
7. Open "color_gs_Lib/S7 Program(1)/Charts" library in the catalog, and drag the "SIMMO" 

chart below the "FBON" block. 
This is the chart you created specifically for the simulation. The chart is displayed like a 
block. You can make interconnections to this chart the same as for a block. The 
inputs/outputs are chart inputs/outputs that you have defined for the "SIMMO" chart. 

8. Make the interconnection according to the following table:  
 

Block Output Block Input 
FBON Q MOTOR FB_ON 

QSTART COUT I MOTOR 
QSTART SIMMO START 

SIMMO FBRUN FBON SIM_I 
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9. Click on the "SIM_ON" input of the "FBON" block. 
10. Select Insert > Textual Interconnection... from the menu. 

The "Insert Textual Interconnection" dialog box opens. 
11. Enter the name "ActivateSimulation" in the "Textual interconnection" box. 

 
 

This way, you enter a character string as a placeholder. When you create the process 
tags, these placeholders are replaced by a concrete path reference. 
The textual reference is displayed in the sheet bar and indicated by a yellow triangle. 

12. For the "MOTOR" block, click on the "AUTO_ON" input and enter the character string 
"Level_Reac" as the textual interconnection. When editing the import file this character 
string signals to you that you must enter the actual path reference for the fill level. 

13. Close the CFC editor. 
You have created the top chart. 
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6.4.2.2 Step 2 - How to create the "TYPE_MOTOR" process tag type 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Lib/Process tag types". 
2. Select the CFC chart "TYPE_MOTOR" in the detailed window and select Options > 

Process Tags > Create/Change Process Tag Type... from the menu. 
The "Process Tags - Create Process Tag Type" wizard opens at the "Introduction" step. 

3. Click "Next". 
The "Which I/Os do you want to assign to the process tag type?" step opens. 
In the "I/Os in the chart of the process tag type" list, you will find the blocks you inserted 
in the "TYPE_MOTOR" CFC chart. 
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4. Double-click on the "COUT" block. 
The tree view opens and displays all inputs/outputs with the "Visible" attribute. 

 
 

5. Double-click on the "VALUE" I/O. 
This transfers the I/O to the "I/O points for parameters/signals" list. 
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6. Click in the "Parameter" field in the "Parameter/signal" column. 
A drop-down list opens. 

7. Select the entry "Signal" from the drop-down list. 

 
 



Configuring CFC charts with the use of rational functions  
6.4 Working with process tag types 

 PCS 7 - Getting Started - Part 2 
82 Getting Started, 09/2007, A5E00857270-02 

8. Follow exactly the same procedure to enter the following inputs/outputs in the "I/O points 
for parameters/signals" area and to define the values for the parameters/signals. 

 Block I/O Meaning Parameter/ 
signal 

COUT already done 
VALUE 

Input value of I/O module Signal 

VALUE Input value of I/O module Signal FBON 
SIM_ON Activates simulation Parameter 
AUTO_ON Automatic value ON/OFF Parameter 
LIOP_SEL Switches between Manual/Auto Parameter 
AUT_L Selects Man/Auto Parameter 

MOTOR 

TIME_MON Monitoring time Parameter 
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9. Click "Finish". 
This creates the CFC chart as a process tag type. The icon changes as follows: 

 
 

Video  
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6.4.2.3 Step 3 - How to create the "MOTOR_REAC1" import file 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Lib/Process Tag Types". 
2. Select the "TYPE_MOTOR" process tag type in the detailed window, and select 

Options > Process Tags > Assign/Create Import File... from the menu. 
The "Process Tags: Assign/Create Import File", wizard opens. 

3. Click "Next >"  
The "Which import file do you want to assign to the process tag type?" step opens. 

4. Click in an edit box of the "Column title" column and change the default name to match 
the entries in the following table. 
You will see the column title later in the import file.  

 
Column header default name Column header adapted name 
COUT.VALUE Output value COUT.VALUE 
FBON.VALUE Input value motor on FBON.VALUE 
FBON.SIM_ON Simulation motor FBON.SIM_ON 
MOTOR.AUTO_ON Auto mode on/off MOTOR.AUTO_ON 
MOTOR.LIOP_SEL Man/auto changeover MOTOR.LIOP_SEL 
MOTOR.AUT_L Selection man/auto MOTOR.AUT_L 
MOTOR.TIME_MON Monitoring time MOTOR.TIME_MON 
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5. Since you created the process tag type first, you will now need to create a new import file. 
Click "Create File Template..." 
The "Create File Template" dialog box opens. The default folder in which PCS 7 stored 
import files is already open. 
PCS 7 proposes a file name for the import file that is identical to the name of the process 
tag type. 

6. Change the name to "MOTOR_REAC1.IEA" and click "OK". 
The "Create File Template" dialog box opens and the "General" tab is active. 

7. In the "Create File Template" dialog box, make the settings listed in the following table 
and then click "OK".  

 
Tab Selected check box 

Assigned AS (AS) 
Chart comment (ChComment) 

General 

Block comment (BlockComment) 
Value (Value) 
I/O comment (ConComment) 

Parameter 

Textual interconnection (TextRef) 
I/O comment Signals 
Symbol name 

  
8. Click "Open File". 

The import file is opened in the IEA file editor. The first line already exists with default 
settings.  
Each line represents exactly one process tag. 
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6.4.2.4 Step 4 - Editing the "MOTOR_REAC1" import file 
The following describes the procedure for editing the import file in the IEA file editor. At the 
end of the section you will find a short description of the basic procedure for editing the data 
in Excel.  

Requirement 
● The "MOTOR_REAC1.IEA" import file is created and open in the IEA file editor. 

Procedure 
1. The first row stands for the concrete process tag NR311. 

Complete the row according to the table below: 
  

 

  Note 
For space reasons the parameters in the following table are arranged in columns instead 
of in lines. This is exactly reversed in the IEA file editor. 
The order of the columns in the IEA file editor may be different from the order specified in 
the table. When entering the parameters pay attention to selecting the correct column. 

  
Column Sub-column Default entry Parameter 
Project  color_gs_Prj Apply 
Hierarchy  Process tags\ Plant1\REAC1 
AS  S7 Program(1) Apply 

ChName TYPE_MOTOR CFC_NR311 Chart 
ChComment   
SymbolName --- NR311_con 
ConComment Output value Apply 

Output value 
COUT.VALUE 

BlockComment Digital output Apply 
SymbolName --- NR3x1_on 
ConComment Input value Apply 

Input value motor on 
FBON.VALUE 

BlockComment Digital input Apply 
TextRef ActivateSimulation GENERAL\ACT_SIM.Q0 Simulation motor 

FBON.SIM_ON ConComment 1=Activate 
simulation 

Apply 

TextRef Level_Reac "-
"CFC_LI311\TANK_LEV_MON.QL_W
RN 

ConComment AUTO Mode 1=ON 
0=OFF 

Apply 

Auto mode on/off 
MOTOR.AUTO_ON 

BlockComment MOTOR Apply 
Value  0  1 Man/auto 

changeover 
MOTOR.LIOP_SEL 

ConComment Select: 1=Linking, 
0=Operator Active 

Apply 
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Column Sub-column Default entry Parameter 
Value  0  1 Selection man/auto 

MOTOR.AUT_L ConComment Linkable Input for 
MANUAL/AUTO 
Mode 

Apply 

Value  3.0  10.0 Monitoring time 
MOTOR.TIME_MON ConComment Monitoring Time  

for ON [s] 
Apply 

  
 

 Note 
In the sub-column "TextRef" you will find the textual interconnection that you entered in the 
top chart as a character string. Here you replace the wildcard with the path reference to the 
"GENERAL" CFC chart, which enables you to activate simulation in process mode. 
You have added the "-" character in front of the textual interconnection for the 
"MOTOR.AUTO_ON" I/O. This means the input is negated. 

 

 
 

2. Click on row number 4. 
This selects the row. 

3. Select Edit > Duplicate Row... from the menu. 
The "Duplicate Row" dialog box opens. 
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4. Enter a "1" in the "Number of duplicated rows" box and click "OK". 
The row is duplicated with all entries. 

 
 

5. Enter the deviating parameters as listed in the following table: 
  

 

  Note 
All deviating parameters are marked in bold in the table. 

 
Column Sub-column Parameter 
Project  color_gs_Prj 
Hierarchy  Plant1\REAC1 
AS  Apply 

ChName CFC_NP311 Chart 
ChComment  
SymbolName NP311_con Output value COUT.VALUE 
ConComment Apply 
SymbolName NP3x1_on 
ConComment Apply 

Input value motor on FBON.VALUE 

BlockComment  
ConComment Apply 
TextRef GENERAL\ACT_SIM.Q0 

Simulation motor FBON.SIM_ON 

  
TextRef --- 
  
ConComment Apply 

Auto mode on/off MOTOR.AUTO_ON 

BlockComment  
Value  0 Man/auto changeover MOTOR.LIOP_SEL 
ConComment Apply 
Value  0 Selection man/auto MOTOR.AUT_L 
ConComment Apply 
Value  10.0 Monitoring time MOTOR.TIME_MON 
ConComment Apply 
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 Note 
The "---" character string deletes a textual interconnection. 

 
  
6. Select File > Save from the menu. 

Video  

 
 

7. Close the IEA file editor. 
You return to the "Process Tags: Assign/Create Import File" wizard. 

8. Click "Finish". 
The wizard closes. 
  

 

  Note 
Alternatively, as an experienced user of Microsoft Excel, you can edit the data of the 
import file in Excel. Proceed as follows: 
1. You insert as many empty lines in the IEA file editor that are needed to accommodate 

the number of existing process tags. 
2. You select the area in the IEA file editor to be edited in Excel. 
3. You insert the data into Excel using copy-and-paste. 
4. You edit the data in Excel. 
5. Select the edited area in Excel and insert it back into the IEA file editor using copy-

and-paste. 
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6.4.2.5 Step 5 - How to create "TYPE_MOTOR" process tags 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Lib/Process Tag Types". 
2. Select the "TYPE_MOTOR" process tag type in the detailed window, and select 

Options > Process Tags > Import... from the menu. 
The "Import-Export Assistant Process Tags: Import" opens at the "Introduction" step. 

3. Click "Next". 
The "Which settings do you want to use for import?" step opens. 
In the "Import file <--> process tag type" list, you will see the assignment import file - 
process tag type: "[storage path] MOTOR_REAC1 <--> TYPE_MOTOR". 
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4. Click "Next". 
The "Do you want to complete the import" step opens. 

5. Click "Finish". 
The import begins and a progress bar is displayed. When the import is complete, the 
NR311 and NP311 process tags are created and stored in the "REAC1" folder. The 
import log is displayed on the screen. 

 
 

6. Click "Exit". 
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6.4.2.6 The results... 

Procedure 
1. Go to the plant hierarchy and select the folder  

"color_gs_MP/color_gs_Prj/Plant1/REAC1". 
2. There you will see two new CFC charts: "CFC_NP311" and "CFC_NR311". These are the 

process tags that you created through the import operation. 
3. Open the newly created process tag "CFC_NR311" in the CFC Editor.  

There you can see the results of the import and the relationship between the entries in 
the import file and the real process tag: 

"FBON" Block, "SIM_ON" Input  
At the "FBON" block, you will relocate the textual interconnection for the "SIM_ON" input. It 
has been replaced by a concrete interconnection: 
"Plant1\REAC1\\GENERAL(A,1)\ACT_SIM.Q0" 
Double-click on this interconnection in the side bar. This brings you to the relevant 
interconnection partner. 
This was the following parameter in the import file:  

 
Column Sub- 

column 
Default entry Parameter 

Simulation motor 
FBON.SIM_ON 

TextRef ActivateSimulation GENERAL\ACT_SIM.Q0 

  

FBON" Block, "VALUE" Input  
At the "FBON" block, you will find the interconnection to an input/output module for the 
"VALUE" input. 
This was the following parameter in the import file:  

 
Column Sub- 

column 
Default entry Parameter 

Input value motor on 
FBON.VALUE 

SymbolName  "NR3x1_on" I0.2 
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"COUT" Block "VALUE" Output  
Similarly, at the "COUT" block you will find the interconnection to an input/output module for 
the "VALUE" output. 
This was the following parameter in the import file:  

 
Column Sub- 

column 
Default entry Parameter 

Output value 
COUT.VALUE 

SymbolName  "NR311_con" A1.2 
associated block comment 

  

"MOTOR" Block, "TIME_MON" Input 
For the "MOTOR" block, you will find a specific value for the "TIME_MON" input. 
This was the following parameter in the import file: 
  

 
Column Sub- 

column 
Default entry Parameter 

Monitoring time 
MOTOR.TIME_MON 

Value  3.0  10.0 

  

"MOTOR" Block, "AUTO_ON" Input 
For the "MOTOR" block, you will find the textual interconnection for the "AUTO_ON" input, 
which has been replaced by the specific path reference:  
"Plant1\REAC1\\CFC_LI311 (A1)\TANK_LEV_MON.QL_WRN". This input has also been 
negated. 
This was the following parameter in the import file:  

 
Column Sub- 

column 
Standard  
entry 

Parameter 

Auto mode on/off 
MOTOR.AUTO_ON 

TextRef Level_Reac "-"CFC_LI311\MEAS_MON.QL_WRN 
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6.4.3 How to create "VALVE" process tags using process tag types 

Overview 
You create the process tag types and the process tags from a process tag type for valve 
process tags in five steps:  

 
Step What? 
 1 Creating the "TYPE_VALVE" top chart (Page 94) 
 2 Creating the "TYPE_VALVE" process tag type (Page 97) 
 3 Creating the "VALVE_REAC1" import file (Page 98) 
 4 Editing the "VALVE_REAC1" import file (Page 86) 
 5 Generating "TYPE_VALVE" process tags (Page 90) 

6.4.3.1 Step 1 - How to create the "TYPE_VALVE" top chart 
Follow the same basic procedure as for the "TYPE_MOTOR" process tag type. Brief 
instructions for the procedure are given below along with tables containing the required 
values.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Insert the "TYPE_VALVE" CFC chart in the "color_gs_MP/color_gs_Lib/Process Tag 

Types" folder. 
2. Open the "TYPE_VALVE" CFC chart in the CFC Editor. 
3. Open the "color_gs_Lib\S7 Program(1)\Blocks" or the 

"color_gs_Lib/S7 Program(1)\Charts" library in the catalog. 
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4. Use a drag-and-drop operation to insert the following objects and arrange them according 
to the graphic below. 
– DRIVER/CH_DI - twice 
– CONTROL/VALVE 
– DRIVER/CH_DO 
– SIMV 

CH_DO 

CH_DI 

SIMV 

VALVE 

CH_DI 

CH_DO 

 
 

5. Enter the parameters based on the following table:  
 

Block Name in project I/O Invisible 
CH_DI1 FBOP   
CH_DI2 FBCL   
VALVE VALVE QCONTROL no 
CH_DO COUT   
SIMV    

6. Make the interconnections in accordance with the following table:  
 

Block Output Block Input 
FBOP Q VALVE FB_OPEN 
FBCL Q VALVE FB_CLOSE 

QCONTROL COUT I VALVE 
QCONTROL SIMV CONTROL 
FBOPEN FBOP SIM_I SIMV 
FBCLOSE FBCL SIM_I 
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7. Insert the following textual interconnections as placeholders:  

 
Block I/O Textual interconnection Meaning 
FBOP SIM_ON ActivateSimulation Activates simulation in process mode
FBCL SIM_ON ActivateSimulation Activates simulation in process mode
VALVE L_RESET Reset Resets monitoring errors 

  
8. Close the CFC editor. 
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6.4.3.2 Step 2 - How to create the "TYPE_VALVE" process tag type 
Follow the same basic procedure as for the "TYPE_MOTOR" process tag type. Brief 
instructions for the procedure are given below along with tables containing the required 
values.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "TYPE_VALVE" CFC chart in the "color_gs_MP/color_gs_Lib/Process tag 

types" folder and select Options > Process Tags > Create/Change Process Tag Type... 
from the menu. 

2. In the "Which inputs/outputs do you want to assign to the process tag type?" step, assign 
the following inputs/outputs to the process tag type:  

 
Block I/O Meaning Parameter/ 

signal 
COUT VALUE Input value of I/O module Signal 

VALUE Input value of I/O module Signal FBCL 
SIM_ON Activates simulation Parameter 
VALUE  Input value of I/O module Signal FBOP 
SIM_ON Activates simulation Parameter 
L_RESET Resets the valves Parameter VALVE 
TIME_MON Monitoring time Parameter 

  
3. Click "Finish". 

You have completed creation of the process tag type. 
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6.4.3.3 Step 3 - How to create the "VALVE_REAC1" import file 
Follow the same basic procedure as for the "TYPE_MOTOR" process tag type. Brief 
instructions for the procedure are given below along with tables containing the required 
values.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "TYPE_VALVE" CFC chart in the "color_gs_MP/color_gs_Lib/Process tag 

types" folder, and select Options > Process Tags > Assign/Create Import File... from the 
menu. 

2. In the step "Which import file do you want to assign to the process tag type?", change the 
column headers as follows: 

  
Column header default name Column header adapted name 
COUT.VALUE Output value COUT.VALUE 
FBCL.VALUE Input value for closing FBCL.VALUE 
FBCL.SIM_ON Activates simulation for closing FBCL.SIM_ON 
FBOP.VALUE input value for opening FBOP.VALUE 
FBOP.SIM_ON Activates simulation for opening FBOP.SIM_ON 
VALVE.L_RESET Reset valve VALVE.L_RESET 
VALVE.TIM_MON Monitoring time VALVE.TIME_MON 

  
3. Click the "Create file template..." button. 
4. Name the import/export file "VALVE_REAC1.IEA". 
5. In the "Create File Template" dialog box, assign the parameters according to the following 

table and click "OK": 
 Tab Selected check box 

Assigned AS (AS) 
Chart comment (ChComment) 
Block comment (BlockComment) 

General 

Block icon (BlockIcon) 
Value (Value) 
I/O comment (ConComment) 

Parameter 

Textual interconnection (TextRef) 
I/O comment Signals 
Symbol name 

  
6. Click "Open File". 
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6.4.3.4 Step 4 - How to edit the "VALVE_REAC1" import file 
The following describes the procedure for editing the import file in the IEA file editor.  

Requirement 
The "MOTOR_REAC1.IEA" import file is created and open in the IEA file editor. 

Procedure 
1. The first row stands for a concrete process tag. 

Complete the row according to the table below: 
  
Column Sub- 

column 
Default entry Parameter 

Project  color_gs_Prj Apply 
Hierarchy  Process tags\ Plant1\REAC1 
AS  S7 Program(1) Apply 

ChName TYPE_VALVE CFC_NK311 Chart 
ChComment   
SymbolName --- NK311_copen 
ConComment Output value Apply 

Output value COUT.VALUE 

BlockComment Digital output Apply 
SymbolName --- NK31x_close 
ConComment Input value Apply 

Input value for closing 
FBCL.VALUE 

BlockComment Digital input Apply 
TextRef ActivateSimulation GENERAL\ACT_SIM.Q0 Activates simulation for 

closing FBCL.SIM_ON ConComment 1=Activate simulation  
SymbolName --- NK31x_open 
ConComment Input value Apply 

input value for opening 
FBOP.VALUE 

BlockComment Digital input Apply 
TextRef ActivateSimulation GENERAL\ACT_SIM.Q0 Activates simulation for 

opening FBOP.SIM_ON ConComment 1=Activate simulation Apply 
TextRef Reset GENERAL\RESET_TON.

Q 
ConComment Linkable Input RESET Apply 
BlockComment Single-Drive/Dual-

Feedback Valve 
Apply 

Reset valve 
VALVE.L_RESET 

BlockIcon   2 
Value  3.0  10.0 Monitoring time 

VALVE.TIME_MON ConComment Monitoring Time [s] Apply 
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 Note 
Here you will find a new sub-column:  
"BlockIcon" 
The entries in this column allow you to control which block icon is created. You already know 
this function from Getting Started - Part 1: There you controlled the display of the valve as a 
block icon in the Process Object view. Now you apply the same function in the import file. 
You used another textual interconnection here:  
The interconnection to VALVE.L_RESET. It is also interconnected with the "GENERAL" 
CFC chart. 

 
  
2. Select line 4 and duplicate the line four times. 

You then have a total of five process tags. 
3. In the "Chart/ChName" and "Output value output module COUT.VALUE\SymbolName" 

columns, assign the parameters for the individual process tags as follows:  
 

Row Column "Chart/ChName" Column "output value COUT.VALUE\SymbolName" 
 5 CFC_NK312 NK312_copen 
 6 CFC_NK313  NK313_copen 
 7 CFC_NK314  NK314_copen 
 8 CFC_NK315 NK315_copen 

  
 

 Note 
All other parameters remain unchanged.  
In a real project you modify more parameters than this. For example, for each 
interconnection to an input/output module you enter a separate symbolic name.  
In Getting Started - Part 2, you interconnected several block inputs/outputs to a single 
input/output of an input/output module for simulation purposes. 

 
  
4. Save the file and close the IEA file editor. 
5. Click "Finish". 
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6.4.3.5 Step 5 - How to create "TYPE_VALVE" process tags 
You have created the "TYPE_VALVE" process tag type. You can now use it to create a 
process tag for every valve contained in the project. Here in this Getting Started, you will first 
create the process tags for the "REAC1" part of the plant. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "TYPE_VALVE" CFC chart in the "color_gs_MP/color_gs_Lib/Process tag 

types" folder, and select Options > Process Tags > Import... from the menu. 
2. Pay special attention during the "Which settings do you want to use for import?" step that 

the correct import file - process tag type "[storage path] VALVE_REAC1 <--> 
TYPE_VALVE" is displayed in the "Import file <--> Process tag type" list. 
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3. Complete import. 
Following the import, the log file is displayed. It is significantly more detailed than when 
creating the process tags for the motor.  
The following process tags are set up in the "REAC1" folder of the plant hierarchy: 
– CFC_NK311 
– CFC_NK312 
– CFC_NK313 
– CFC_NK314 
– CFC_NK315 

 
 

4. Click "Exit". 
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6.4.4 How to close textual interconnections... 
You worked with textual interconnections when creating process tags. If these 
interconnections are not yet closed, you can close all textual interconnections using a special 
PCS 7 function. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "GENERAL" CFC chart is open in the CFC Editor 

The following interconnections exist: 
– Block output "RESET_TON.Q" to all "VALVE.L_RESET" valve inputs 
– Block output "ACT_SIM.Q0" to all valve and motor process tags for the 

"INPUT.SIM_ON" input. 
If the interconnections are not closed, carry out the procedure described below. 
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Procedure 
1. Select Options > Make Textual Interconnections. 

This makes all interconnections from output Q to all valve blocks. The following log file is 
displayed: 

 
 

2. Double-click on a path in the sheet bar of the CFC chart. 
You automatically change to the CFC chart "CFC_NK31x". The interconnection flashes 
and is displayed in magenta. You can now see that the textual interconnection "RESET" 
that you specified in the process tag type has been replaced by an actual interconnection. 

3. Close the CFC editor. 
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6.5 Modifications of process tag types 

6.5.1 Making subsequent changes 

Possible subsequent changes 
Process tag types make it easy to perform changes in the future: You make the changes at 
the process tag type and in the import file, and transfer the changed information to all newly 
generated process tag with a new import. 
The following changes are possible:  
● Adding a New Parameter (Page 107): You may want to display different block icons on 

the OS for the newly created process tags, for example, and perform this assignment 
using the import file. 

● Deleting all created process tags (Page 110): This function is of interest when you have 
generated numerous process tags from a process tag type and you do not want to delete 
them all manually in the plant hierarchy. 

● Adding an additional block I/O (Page 110). You require, for example, an additional block 
I/O, which you wish to configure with the import file. 

In this part of Getting Started, you will add a parameter. We will provide an overview of the 
basic procedures for the other types of corrections. 
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6.5.2 The most important information about the import/export file 
When you perform subsequent corrections you work intensively with the import/export file. 
You should familiarize yourself with the most important operations so that you can work with 
confidence. These are described briefly below. You may already be familiar with many 
functions from using spreadsheet software. 

Navigating in the table 
You navigate in the table using the following keyboard commands: 
● The UP and DOWN arrows move you up and down lines in the columns 
● The < TAB > key moves you to the right (forwards) to the next cell and < Shift> +  < TAB 

> moves you to the left (backwards) to the preceding cell in the line 
● The <Enter> key is used, for example, to end an edit and to move to the next line in the 

column. 

Selecting in the table 
You can select cells in the table with the following keyboard commands: 
● Select multiple cells: Press <Shift> and an arrow key at the same time. 
● Select an entire row: Click on the number field at the beginning of the row. 
● Select multiple rows: Click while also pressing <Shift> or <Ctrl>. 
● Select a column: Click on the field with the column title. 
● Select several columns: Click while also pressing <Shift> or <Ctrl>. 

Special considerations for the import/export file 
Pay attention to the following when subsequently changing the import file:  

 
If you want to... ... then  
Delete an existing textual interconnection or an 
interconnection to an input/output 
 

Enter the code word "---" 

Leave an existing interconnection unchanged  Leave the edit box empty 
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6.5.3 How to add a parameter 
You will now add the "Block icon" parameter for the process tag type "TYPE_MOTOR" 
because you need this parameter for configuring the OS.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Select the "TYPE_MOTOR" process tag type in the "color_gs_MP/color_gs_Lib/Process 

tag types" folder, and select Options > Process Tags > Assign/Create Import File... from 
the menu. 

2. Switch to the step "Which import file do you want to assign to the process tag type?" and 
check if the correct import file, "…\MOTOR_REAC1.IEA", is displayed in the drop-down 
list. 

3. Click "Open File". 
The file is opened in the IEA file editor. 

4. Select any field in the column "Auto mode on/off MOTOR.AUTO_ON/BlockComment". 
5. Select Edit > Expand column group from the menu. 
6. In the "Expand Parameter Column Group" dialog box, select the "Block icon" check box 

and click "OK". 
The "BlockIcon" column is inserted. 
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7. Enter the name "pump" for the "CFC_NP311" process tag in the "BlockIcon" column. This 
name represents the display of the block icon in the process image. You create this 
special block icon yourself during the configuration of the OS. 

 
 

8. Save the file. 
9. Close the IEA file editor. 
10. Click "Finish". 

Video  

 
 

11. Select the process tag type "TYPE_MOTOR", and select  Options > Process Tags > 
Import from the menu. 
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12. Make sure that you have selected the correct import file "MOTOR.REAC1.IEA" and start 
the import. 
The existing process tags are modified according to the parameters in the import/export 
file. You can see all of the modifications that have been performed in the log. 

 
 

For this modification this means specifically:  
In CFC chart "CFC_NP311", the name "pump" is entered in the "Block icon" text box in the 
block properties of the "MOTOR" block. 
You can check this by opening the CFC chart "CFC_NP311" and viewing the block 
properties of the "MOTOR" block. 
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6.5.4 How to make corrections - basic procedure 
  

 

NOTICE  
The following instructions are not part of the scope of the tasks in this Getting Started. The 
instructions are therefore kept to a minimum and are intended only as an overview of the 
basic procedure involved. We have included these instructions to show you the wide variety 
of possibilities offered by process tag types.  

 
  

Options for corrections 
The following correction options are described in basic terms: 
● Deleting all created process tags 
● Adding an I/O point 

Procedure for deleting process tags 
1. Make a copy of the original import file and name it "DELETE_[Name of the original import 

file].IEA". 
2. Open the file in the IEA file editor. 
3. Select any field in the "Project" column and select the menu command Edit > Insert 

Column Group > General.... 
4. In the "Insert General Column Groups" dialog box, select the "Import mode" check box 

and click "OK". 
The "ImportMode" column is inserted as the first column. 

5. For all process tags that you want to delete, enter the command "DELETE" and save the 
file. 

6. Close the IEA file editor. 
7. Select the process tag type "TYPE_MOTOR", and select  Options > Process Tags > 

Import... from the menu. 
8. Open the import to which you added the "DELETE" import mode and start the import. 

All process tags are deleted. 
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Procedure for adding a block input/output 
1. Select the process tag type, and select Options > Process Tags > Create/Change 

Process Tag Type... from the menu. 
2. Insert the additional I/O point and complete the change. 
3. Open the corresponding import file, and select Edit > Insert Column Group > Parameter 

or Signal from the menu.. 
This inserts an additional column. 

4. Give the new column a descriptive name and save the import file. 
5. Select the process tag type and then the menu command Options > Process Tags > 

Assign/Create Import File... 
The additional column that you inserted from the import file appears in the "Undefined I/O 
points in import file" list. 

6. Drag this column onto the new I/O point in the "I/O points of the process tag type for 
parameters/signals" list 

7. Complete the function. 
8. Perform a new import. 
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6.6 Creating other CFC charts 

6.6.1 How to create the "CFC_LI311" CFC chart 
You use this chart to measure and simulate the fill level in REAC1. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Prj/Plant1/REAC1". 
2. Insert the "CFC_LI311" CFC chart and open it in the CFC Editor. 
3. Open the "color_gs_Lib/S7 Program(1)\Blocks" library in the catalog. 
4. Use a drag-and-drop operation to insert the following blocks, and arrange them according 

to the graphic below. 
– OPERATE/OP_A_LIM 
– DRIVER/CH_AI - twice 
– CONTROL/MEAS_MON 
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OP_A_LIM 

CH_AI1 MEAS_MON 

CH_AI2 
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5. Enter the parameters based on the following table: 
  
Block Name in 

project 
I/O Meaning Value 

CH_AI1 TANK_LEV VH_RANGE High limit process value fill level  1200.0 
U_AH High alarm limit fill level  990.0 
U_WH High warning limit fill level  950.0 
U_AL Low alarm limit fill level  20 
U_WL Low warning limit fill level  40 
MO_PVHR ** Upper display limit for faceplate in 

the OS 
 1200 

MEAS_MON TANK_LEV_ 
MON 

HYS Hysteresis  5 * 
VHRANGE High limit process value  0 
VLRANGE Low limit process value  -100 

CH_AI2 OUTFLOW 

SIM_V Simulation value for the flow during 
draining  

 -10 

U_HL High limit minimum fill level  1200.0 
U_LL Low limit minimum fill level  50 

OP_A_LIM DRAIN_ 
MIN_LEV 

U ** Default minimum fill level  60 

 * default 
 ** Input/output must be set as visible 
  
1. Open the "color_gs_Lib/S7 Program(1)\Charts" library in the catalog. 
2. Drag the chart "SIMREAC" below the "TANK_LEV_MON" block. 

This is the chart you created specifically for the fill level simulation. 
3. Make the interconnection according to the following table:  

 
Block Output Block Input 
TANK_LEV V TANK_LEV_MON U 
SIMREAC LEVEL_OUTPUT TANK_LEV SIM_V 
OUTFLOW V SIMREAC AOUT 
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4. Make the following textual interconnections with a specific path reference:  
 

Block Input Textual interconnection Meaning 
TANK_LEV SIM_ON GENERAL\ACT_SIM.Q0 Activates simulation 

BVALV_RMT1_1 CFC_NK113\VALVE.QOPENED Valve to REAC1 open 
BMOT_RMT1 CFC_NP111\MOTOR.QRUN Pump RMT1 running 
ARMT1 CFC_FC111\INPUT_U.V Simulation value for flow – this 

is integrated for the fill quantity. 
BVALV_RMT2_1 CFC_NK117\VALVE.QOPENED Valve to REAC2 open 
BMOT_RMT2 CFC_NP112\MOTOR.QRUN Pump RMT2 running 
ARMT2 CFC_FC112\INPUT_U.V ditto - The values are read from 

the RMT2 part of the plant 

SIMREAC 

BOUT CFC_NP311\MOTOR.QRUN The drain pump must be 
running 

OUTFLOW SIM_ON GENERAL\ACT_SIM.Q0 Activates simulation 

  
 

 Note 
The inputs BVALV_RMT1_2 and BVALV_RMT2_2 should not be interconnected for the 
REAC1 part of the plant. 
Ensure that these inputs have the input value "0". 

 
  

 

 Note 
All textual interconnections are automatically closed because all interconnection partners are 
available. 

 
  
5. Select the block inputs/outputs to correspond to the following table, and select Insert > 

Interconnection to Address from the menu. 
The selection list of symbolic names for the block I/Os opens. 

6. Double-click on the required block I/O. 
The global address is entered and the interconnection is displayed in the sheet bar.  

 
Block Input/output Address 
TANK_LEV Input "VALUE" LI311 
OUTFLOW Input "VALUE" LI311_V 

  
7. Close the CFC chart. 
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6.6.2 How to create the "CFC Chart TC 311" CFC chart 
This chart regulates the temperature for REAC1. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Prj/Plant1/REAC1". 
2. Insert the "CFC_TC311" CFC chart and open it in the CFC Editor. 
3. Use a drag-and-drop operation to Insert the blocks listed in the table in the specified 

order and arrange them to correspond to the figure below. 
 

  Note 
The table provides information about the name of the storage folder and the function of 
the blocks. 

 
Block Location   
  Tab Folder 
TOF Libraries "color_gs_Lib\S7 Program(1)\Blocks\IEC_TC" 
CTRL_PID Libraries "color_gs_Lib\S7 Program(1)\Blocks\CONTROL" 
MUL_R Libraries "color_gs_Lib\S7 Program(1)\Blocks\MATH_FP" 
SEL_R Blocks "MULTIPLX" 
PT1_P Libraries "color_gs_Lib\S7 Program(1)\Blocks\CONTROL" 
CH_AI Libraries "color_gs_Lib\S7 Program(1)\Blocks\DRIVER" 
CH_AO Libraries "color_gs_Lib\S7 Program(1)\Blocks\DRIVER" 
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CH_AO 

CH_AI 

TOF SEL_R 

PT1_P 

CTRL_PID 

MUL_R 
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4. Enter the parameters according to the following table: 
 

Block Name in  
project 

I/O In- 
visi- 
ble 

Meaning Value 

TOF TOF PT  Maintains the temperature 
after the maximum value 
has been achieved 

1m 

SP_EXT  External setpoint  80 
GAIN  Proportional-action 

coefficient 
 1 * 

TN  Integral-action time [s]  8 
TV  Derivative-action time [s]  0 * 
LIOP_INT_SEL  Activates basic operator 

control 
 0 * 

LMN_HLM  High alarm limit  100 * 
LMN_LLM  Low alarm limit  0 * 
SPEXTHLM  High limit external setpoint  100 * 
SPEXTLLM  Low limit external setpoint  0 * 
PVH_ALM  Process value: High alarm 

limit 
 140 

PVH_WRN  Process value: High 
warning limit 

 130 

PVL_ALM  Process value: Low alarm 
limit 

 20 

PVL_WRN  Process value: Low warning 
limit 

 25 

NM_PVHR  High limit phys. meas. value 
range proc. value 

 150 

NM_PVLR  Low limit phys. meas. value 
range proc. value 

 0 * 

MO_PVHR  High display limit   150 

CTRL_PID CTRL_TEMP 

MO_PVLR  Low display limit  0 
SEL_R SEL_R IN1  Minimum temperature of the 

reactor 
 30 

PT1_P PT1_P TM_LAG  Time delay  60 
CH_AI INPUT VHRANGE  High limit process value  150 
MUL_R MUL_R IN2  Converts the valve position 

to temperature feedback 
 1 * 

CH_AO OUTPUT UHRANGE  High limit manipulated 
variable 

 100 * 

 * default 
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5. Make the interconnections in accordance with the following table:  
 

Block Output Block Input 
TOF Q SEL_R K 
SEL_R OUT PT1_P U 
PT1_P V INPUT SIM_V 
INPUT V CTRL_TEMP PV_IN 
CTRL_TEMP LMN MUL_R IN1 
CTRL_TEMP LMN CTRL_TEMP LMNR_IN 
CTRL_TEMP LMN OUTPUT U 
MUL_R OUT SEL_R IN0 

  
6. Make the following textual interconnections:  

 
Block Input Textual interconnection Meaning 
INPUT SIM_ON GENERAL\ACT_SIM.Q0 Activates simulation 
TOF IN CFC_NK313\VALVE.QOPENED Valve 313 open 

  
 

 Note 
All textual interconnections are automatically closed because all interconnection partners are 
available. 

 
7. Select the block inputs/outputs in accordance with the following table, and select Insert > 

Interconnection to Address from the menu and make the interconnections.  
 

Block Input/output Address 
INPUT Input "VALUE" TC311 
OUTPUT Output "VALUE" TC311_c 

  
8. Close the CFC chart and close the CFC Editor. 
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6.7 Summary 

6.7.1 Summary: "Rational engineering in the CFC configuration" 

New functions 
What have you learned while working with CFC charts? 
In addition to using textual interconnections, you have learned two important functions for 
rational engineering: 
● Chart-in-chart technique 
● Tag types 
Both functions offer special advantages and are used according to your own specific 
requirements. 
The following is a brief summary of the most important properties of these two functions. 

Chart-in-chart technique 
In Getting Started you use the chart-in-chart technique for the simulation charts. Chart-in-
chart technique means that you create generally valid charts for multiple use in other charts. 
You already inserted the "SIMV" simulation chart into all charts for valve process tags as a 
hierarchical chart. 
Note the following when using the chart-in-chart technique: 
● Store the charts you have specified for the chart-in-chart technique in your master data 

library. In this way, you have convenient access to the charts and they are available to all 
configuration engineers working decentrally within a multiproject. 

● Note that central changes cannot be made with the chart-in-chart technique. 
Modifications that you implement in the hierarchical chart are not automatically applied to 
all points of use. If you insert the modified hierarchical chart into another top chart, you 
will have two different versions of the hierarchical chart in your project. When the top 
chart opens, it is not immediately clear which version of the hierarchical chart you have 
used. Make sure you always change the name of the chart when you make subsequent 
changes to a hierarchical chart. Since the name is displayed when you use this chart in 
the top chart, you will immediately know which version of the hierarchical chart you have 
used. 
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Tag types 
In Getting Started, you use process tag types to create process tags of the same type. For 
example, you created the "VALVE" process tag type and then used it to create all five 
process tags required for the "REAC1" part of the plant. You can also use this process tag 
type to create other valve process tags in other parts of the plant. You can also create 
significantly more process tags using an import file. 
Note the following when using process tag types: 
● You can modify the created process tags to meet the specific requirements for this 

process tag. 
Exception: You cannot change the block I/Os for which parameters were assigned via the 
import file. 

● You assign descriptive names to the column headers. 
● In order to establish a unique relationship between the process tag types and the created 

process tags, you assign a descriptive name to the corresponding import file. 
● Create a backup copy of the original import file before making critical changes to the 

import file. In this way you can easily restore the "old status". This procedure is 
recommended if you create a large number of process tags. 

● You can edit the data of the import/export file externally in a spreadsheet program such 
as Excel. You should only use this option, however, if you are very familiar with the 
functions of the spreadsheet program. The IEA file editor offers comparable functions that 
are adequate for the purpose of this configuration work. 

Creating process tags from multiple process tag types simultaneously 
When creating process tags, you even have the option of creating process tags from 
different process tag types in a single operation. The basic procedure is as follows: 
1. In the plant view of SIMATIC Manager, select the folder  

"color_gs\color_gs_lib\Process tag types". 
2. Select Options > Process Tags > Import... from the menu. 

Step 2(3) of the wizard displays all import files that you have already created. 
3. Delete the import files of all the process tag types from which you do not want to create 

process tags, and complete the import. 
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Configuring SFC charts with the use of rational 
functions 7
7.1 Overview of configuration steps in the SFC 

Configuration tasks 
During SFC configuration, you will perform the configuration steps: 
● Modify the RMT plant sections  

These corrections are necessary in order to combine the RMTx and REACx parts of the 
plant with one another. 

● Work with SFC types  
This is a very important function of rational engineering. 
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7.2 Modification of the SFC charts in the 'RMT1/2' plant sections 

7.2.1 Modifications in the RMT parts of the plant 

Interfaces and valves 
You will need to modify the SFC charts from the RMT1 and RMT2 parts of the plant using 
the interfaces between "RMTx" and "REACx".  
● The valves NK311 and NK312 belong to the "REAC1" part of the plant. 
● The valves NK321 and NK322 belong to the "REAC2" part of the plant; they also have to 

be opened when the liquid dosing starts. 
These valves are controlled by the SFC charts in RMT1 and RMT2. 

7.2.2 How to modify the SFC charts of the RMTx parts of the plant 
You already know the basic procedures in the SFC editor from Getting Started - Part 1. The 
only new feature here is the use of textual interconnections.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

Procedure for the "RMT1" part of the plant 
1. Go the the tree view and select the folder  

"color_gs_MP/color_gs_Prj/Plant1/RMT1", and open the "SFC_RMT1" SFC chart in the 
detailed window. 
The SFC editor opens. 

2. Select the "START" step. 
3. Select Edit > Object Properties... from the menu. 

The "Properties" dialog box opens. 
4. Select the "Initialization" tab. 
5. Click the button labeled with row number 11. 
6. Open the context menu and select the menu command Insert Empty Line. 

An empty row is inserted beside the number 11 button. 
7. Place the cursor in the edit box for the left address in empty line 11, and click the 

"Browse" button. 
The "Browse" dialog box opens and the "Plant View" tab is active. 

8. Go to the tree view and select the block: 
"Plant1\REAC1\CFC_NK311\VALVE". 
All the associated I/Os of the block are displayed on the right. 
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9. Double-click on the "AUT_ON_OP" input. 
This brings you back to the "Properties" dialog box, and enters the value for the left 
address. 

10. Set the right address to the value "Auto". 
11. Click the "Apply" button. 

The value is entered. 
12. Insert another empty line before line 12. 
13. Enter the textual interconnection in this line: 

– Left address: "CFC_NK321\VALVE.AUT_ON_OP" 
This entry is highlighted in yellow to identify it as a textual interconnection. 

– Right address: "1". 
  

 

NOTICE  
 

You must enter the numerical value "1" for the textual interconnection – this is the 
Boolean value for "Auto". On no account should you enter simply "Auto". 

  

 
 

14. Click "Apply". 
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15. Click the arrow button to move to the next steps and make the other entries for the 
"RMT1" part of the plant according to the table below. 
  

 

  Note 
Insert empty lines for new instructions after the existing instructions for the valve controls. 
The inputs/outputs are grouped efficiently.  

  
 

Step Comment Left address Right 
address 

Direct interconnection Plant1\REAC1\CFC_NK311\VALVE.AUT_ON_OP Auto Completed 
already: 
START 

Textual 
interconnection 

CFC_NK321\VALVE.AUT_ON_OP 1 

INIT_LINE1 Direct interconnection Plant1\REAC1\CFC_NK311\VALVE.AUTO_OC TRUE 
INIT_LINE2 Textual 

interconnection 
CFC_NK321\VALVE.AUTO_OC 1 

Direct interconnection Plant1\REAC1\CFC_NK311\VALVE.AUTO_OC FALSE CLOSE_LINE 
Textual 
interconnection 

CFC_NK321\VALVE.AUTO_OC 0 

Direct interconnection Plant1\REAC1\CFC_NK311\VALVE.AUTO_OC FALSE END 
Textual 
interconnection 

CFC_NK321\VALVE.AUTO_OC 0 
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Procedure for the "RMT2" part of the plant 
1. Open the "SFC_RMT2" chart. 
2. Open the "Properties" dialog box and enter the instructions according to the table below:  

 
Step Comment Left address Right 

address 
Direct interconnection Plant1\REAC1\CFC_NK312\VALVE.AUT_ON_OP Auto START 
Textual 
interconnection 

CFC_NK322\VALVE.AUT_ON_OP 1 

INIT_LINE1 Direct interconnection Plant1\REAC1\CFC_NK312\VALVE.AUTO_OC TRUE 
INIT_LINE2 Textual 

interconnection 
CFC_NK322\VALVE.AUTO_OC 1 

Direct interconnection Plant1\REAC1\CFC_NK312\VALVE.AUTO_OC FALSE CLOSE_LINE 
Textual 
interconnection 

CFC_NK322\VALVE.AUTO_OC 0 

Direct interconnection Plant1\REAC1\CFC_NK312\VALVE.AUTO_OC FALSE END 
Textual 
interconnection 

CFC_NK322\VALVE.AUTO_OC 0 

  
3. Close the "Properties" dialog box, and close the SFC Editor. 
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7.3 Working with SFC types 

7.3.1 Overview of SFC types 

Introduction 
At this point, we will first provide you with a theoretical overview of the SFC types. Of course, 
SFC types offer you many more options that cannot be described in detail in  
Getting Started - Part 2. 
SFC types offer the advantage of "reusability" because they work according to the 
type-instance concept. This means that you first create the SFC type. From this you then 
create an SFC instance that is actually connected to the process, by inserting the SFC type 
into a CFC chart. This means that you can create SFC types for all processes that occur 
repeatedly in a project, for example, heating, agitating, starting.  
The great advantage of the type-instance concept is the capability of centralized editing: For 
example, if you wish to add process values or setpoints to the SFC type at a later point in 
time, they are added to all other SFC instances automatically. 

Characteristics of an SFC type 
The SFC type has certain properties that distinguish it from an SFC chart: 
● The SFC type possesses no runtime properties. 
● The SFC type is managed in the component view only and not in the plant hierarchy. 
● The SFC type is managed and used as a function block and can therefore be found in the 

CFC block catalog under "Other blocks" and "All blocks". It is displayed as a block when 
inserted into a CFC chart. 
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7.3.2 What are the important elements in an SFC type? 

Elements of an SFC type 
The following provides a brief overview of the elements of an SFC type that you will need for 
the configuration in Getting Started - Part 2: 
● Control strategy 

Control strategies structure an SFC type in terms of the process. You can define control 
strategies so that they can be used in the sequencers, for example, heating, cooling. 
Control strategies are optional. However, when you want to run sequencers according to 
a control strategy, the relevant control strategies must be defined. You assign a control 
strategy to the sequencer in the properties of the sequencer. If there is to be only one 
sequencer per control strategy, it is better to give the control strategies and the 
sequencers similar names. This makes assigning control strategies to sequencers easier. 

● Sequencers 
You are already familiar with sequencers from your work in Getting Started - Part 1. 
There you created the SFC chart with exactly one sequence for dosing the raw material. 
An SFC type can contain up to 32 different sequencers. 
Each sequencer has a start condition. 
The start condition "RUN = TRUE" means that the sequencer can be started when the 
SFC is active. 
The start condition "QCS = 1" means that this sequencer is started when the control 
strategy with the number "1" is active. 

● SFC interface 
The SFC interface includes all inputs/outputs that are created during the configuration of 
the SFC type and are made externally visible for the SFC instance in the CFC chart. Here 
a distinction is made between the interface inputs/outputs created by default for every 
SFC instance and the interface inputs/outputs that depend on the definition of the 
characteristics in the SFC type. This distinction is independent of the definitions made in 
the SFC type. 

● Characteristics 
Characteristics include, for example, control strategies, setpoints, process values, block 
contacts. You can define the exact characteristics needed, for example, the setpoint for a 
fill level. For every characteristic that you define, PCS 7 automatically creates the 
required inputs/outputs in the SFC instance. And you can create the actual process 
interfacing for these inputs/outputs. 



Configuring SFC charts with the use of rational functions  
7.3 Working with SFC types 

 PCS 7 - Getting Started - Part 2 
130 Getting Started, 09/2007, A5E00857270-02 

7.3.3 Planning for the "REAC" SFC type 

Introduction 
Create an SFC type in the project "color_gs". This is to be used to control heating and 
drainage processes in the reactors. Beforehand, you must consider which elements you will 
need for your SFC type. You require the following elements for the "color_gs" project: 
● Control strategies and sequencers 
● Setpoints 
● Process values 
● Block contacts 

Specification of the control strategies and sequencers 
First, you define which reusable function units are available for the reactor. A control strategy 
and a separate sequencer will be created for each of these function units. You require the 
following control strategies for the "color_gs" project: 
● "Heat": This control strategy represents the heating process in the reactor. 
● "Drain": The control strategy stands for emptying the reactor 
In the "color_gs" project, each control strategy is assigned to exactly one sequencer. This 
makes a total of three sequencers: 
● Reset (default name: Starting): This sequence is automatically started as soon as a 

sequence control system is started. It sets all valves of this part of the plant to the 
"closed" state. This is needed so that the simulation can start in the process mode without 
problems. 
  

 

  Note 
In actual practice, this sequencer for closing the valves is usually executed at the end of 
the overall process. In this Getting Started, however, the sequencer is executed at the 
beginning of the process to ensure reliable performance of the simulation. 

  
● Heating: This sequence regulates the heating process using the controller block and 

opens/closes the corresponding intake valve. 
● Drain: This sequence opens/closes the valves between reactor and filling tank and 

starts/stops the pump. 
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Specification of the setpoints 
Next, you define the setpoints for the sequence control system. The plant operator can easily 
change these setpoints in process mode on the operator station. You can also define the 
limit values. The setpoints, which can be specified by the plant operator, must be within 
these limits. Of course, the setpoints and their limit values also apply to automatic mode – 
but we will not be using this variant in this Getting Started. 
For the "color_gs" project, the setpoint "Heating" is defined for the temperature in the heating 
process. It is used in the "Heating" sequence. The liquid in the reactor is heated until it 
reaches the setpoint. 

Specification of the process values 
Process values can be used for control within sequences. In the "color_gs" project, the 
process value "fill level" is used in the "Drain" sequence. The drainage pump must stop as 
soon as the minimum value for the reactor fill level is achieved. 

Specification of the block contacts 
Block contacts are defined specifically for individual process tags. This means that you must 
create block contacts for the necessary process tags to which you want to interconnect the 
SFC instance at a later time. 
Note the following for the block inputs/outputs that are visible in the SFC interface of the SFC 
instance:  
The IN or OUT I/Os are interchanged in the SFC instance. If, for example, you create a block 
contact for a "MOTOR" process tag, the QRUN I/O for the "MOTOR" block is an OUT I/O. 
However, in the SFC instance this I/O becomes an IN I/O. This interchange permits you to 
make the necessary interconnections. 
You require block contacts for the following process tags in your "color_gs" project: 
● Control valve for the heating process 
● Valve for the inflow during the heating process 
● Pump for drainage 
● Valve for drainage 
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7.3.4 How to create an SFC type 

Overview 
You create the SFC type in 11 steps: 
  

 
Step What? 
 1 Create an SFC type in SIMATIC Manager (Page 133) 
 2 Open an SFC type in the SFC Editor (Page 134) 
 3 Define control strategies (Page 135) 
 4 Create sequencers (Page 137) 
 5 Specify setpoints (Page 139) 
 6 Define process values (Page 141) 
 7 Define block contacts (Page 142) 
 8 Configure "RESET" sequence (Page 144) 
 9 Design "Heating" and "Drain" sequencers (Page 147) 
 10 Create an SFC instance (Page 150) 
 11 Store in master data library (Page 152) 
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7.3.5 Step 1 - How to create an SFC type 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Go to the tree view and select the folder 

"color_gs_MP/color_gs_Prj/SIMATIC 400(1)/CPU 417-4/S7 Program(1)/Charts". 
2. Select Insert > S7 Software > A SFC Type from the menu. 

The SFC type is inserted. 
3. Enter the name "REAC". 

  
 

  Note 
In contrast to the usual procedure, SFC types for creation are not stored in the master 
data library. Only if it is stored in the aforementioned folder is the SFC type available to 
you as a block to be inserted in the CFC chart as an SFC instance.  
Upon completion, you will save the SFC type in the master data library in order to make it 
available for all the other engineers working in the multiproject, for example.  
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7.3.6 Step 2 - How to open the "REAC" SFC type 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Go to the tree view and select the folder 

"color_gs_MP/color_gs_Prj/SIMATIC 400(1)/CPU 417-4/S7 Program(1)/Charts". 
2. Select the "REAC" object in the detailed window. 
3. Select Edit > Open Object from the menu. 

The SFC editor opens. As with an SFC chart, there is already a sequencer with the 
"START" and "END" steps and Transition 1 present. 
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7.3.7 Step 3 - How to define the control strategies 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "REAC" SFC type is open in the SFC Editor. 

Procedure 
1. Select View > Characteristics from the menu. 

The characteristics editor is open in the upper part of the SFC editor. 
2. Select the "Control Strategies" entry in the tree view. 

An empty input line is then displayed in detailed window. 
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3. Position the mouse pointer in the "Name" column and enter the name "HEAT". 
This name is displayed to the operator in process mode, for example, when selecting a 
control strategy. 
The system assigns the number "1" automatically. You can use this number to logically 
combine the control strategy and the sequencer, for example. 

4. Enter the text "Heating Reactor" in the "Comment" column. 
5. Using the same procedure, enter the following control strategy: 

 
Name Number 

automatically 
Comment 

DRAIN  2 Drainage of Reactor 

You have now defined all required control strategies. 
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7.3.8 Step 4 - How to create the sequencers 
The "RUN" sequencer is automatically created when the SFC type is created. You rename 
this sequencer and, of course, create additional sequencers. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "REAC" SFC type is open in the SFC Editor. 
● The tab with the "RUN" sequencer is activated. 

Procedure 
1. Select Edit > Sequencer Properties... from the menu. 

The "Properties" dialog box opens and the "General" tab is active. 
2. Enter the name "Reset" in the "Name" box. 
3. Click "Apply". 
4. Change to the "Start condition" tab. 
5. Enter the start condition "STARTING" as Address 1. 
6. Click in the edit box for Address 2 and select the entry "Starting" from the drop-down list. 

 
 

7. Click "Apply" and then "Close". 
The dialog box closes. 
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8. Select Insert > Sequencer > At End from the menu. 
The new sequencer "SEQ1" is inserted and displayed in a separate tab. This tab is 
automatically activated. 

9. Select Edit > Sequence Properties from the menu, and enter the following parameters:  
 

Start condition   
Name Address 1 

  
Operator 

  
Address 2 

RUN = Run HEATING 
  QCS =  1 

  

 
 

10. Click the "Apply" button and then the "Close" button. 
11. Repeat steps 8 to 10 to define the "Drain" sequence:  

 
Start condition   

Name Address 1 
  
Operator 

  
Address 2 

RUN = Run DRAIN 
QCS =  2 

  
12. Click "Apply" and then "Close". 

The "Properties" dialog box closes. 
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7.3.9 Step 5 - How to specify the setpoints 
You need to specify a setpoint for the heating temperature. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "REAC" SFC type is open in the SFC Editor. 
● The characteristics editor is open 

Procedure 
1. Select the "Setpoints" entry in the tree view. 

An empty input line is then displayed in detailed window. 
2. Place the mouse pointer in the edit box in the "Name" column, and enter the name 

"Heating". 
3. Press the <TAB> key. 

A drop-down list is displayed in the edit box of the "Data type" column and the name you 
have specified is automatically entered in the "I/O name" column. You change it to a 
descriptive name after the data type has been defined. 

4. Select the "REAL" data type from the drop-down list. 
5. Enter the following information. To do this, place the cursor in the relevant column and 

enter the data in accordance with the table:  
 

Column name Meaning Value 
I/O name Descriptive I/O name for the setpoint value in the SFC interface SPHeat 
Initial value Setpoint with which the control strategies are processed until 

the plant operator changes the setpoint 
 80 

Low limit Minimum setpoint that the plant operator can specify in process 
mode 

 40 

High limit Maximum setpoint that the plant operator can specify in 
process mode 

 150 
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Result 
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7.3.10 Step 6 - How to create process values 
The process value will be set for the fill level. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "REAC" SFC type is open in the SFC Editor. 
● The characteristics editor is open 

Procedure 
1. Select the "Process values" entry in the overview. 

An empty input line is then displayed in the detailed window. 
2. Place the mouse pointer in the edit box in the "Name" column and enter the name 

"Level". 
3. Place the mouse pointer in the "Data type" column. 

A list box with the possible data types is displayed. 
4. Select the "REAL" data type. 

This specifies the parameters for the process value. The I/O name is automatically taken 
from the "Name" field. 

5. Create another process value with the following parameters: 
– Name: Level_min 
– Data type: REAL 
– I/O name: Levmin 
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7.3.11 Step 7 - How to create the block contacts 
Next, you specify the block contacts. These inputs/outputs are created in addition to the 
standard inputs/outputs in the SFC instance. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "REAC" SFC type is open in the SFC Editor. 
● The characteristics editor is open 

Procedure 
1. Select the "Block contacts" entry in the tree view. 

An empty input line is then displayed in detailed window. 
2. Place the cursor in the edit box in the "Name" column, and enter the name "HeatCtrl". 
3. Press the <TAB> key. 

A drop-down list is displayed in the edit box of the "Block" column and the name you have 
specified is automatically entered in the "I/O name" column. 

4. Select the "CTRL_PID" block from the drop-down list box. 
This drop-down list box contains all the blocks you have used in your project up to now. 
The chart inputs/outputs for the SFC instance are created based on the selected block. 

5. Place the mouse pointer in the "I/O name" column and overwrite the name that was 
entered automatically with the name "HCtrl". 
The name is short and self-explanatory but contains the essential information, the name 
of the sequencer and the name of the associated process tag. 

6. In the "Comment" column, enter the supplementary information "Temperature control". 
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7. Enter the following information. To do this, place the cursor in the relevant column and 
enter the data in accordance with the table: 

 
Name Block I/O name Comment 
Completed already: 
HeatControl 

CTRL_PID HCtrl Temperature control 

HeatValve VALVE HValv Intake temperature control 
DrainValve1 VALVE DValv1 Valve1 drainage 
DrainValve2 VALVE DValv2 Valve2 drainage 
DrainMotor MOTOR DMot Pump drainage 

  

 
 

8. Select View > Characteristics from the menu. 
This closes the characteristics editor since you have completed all of the required data 
entries. 
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7.3.12 Step 8 - How to configure the "RESET" sequencer 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "REAC" SFC type is open in the SFC Editor. 
● The tab with the "RUN" sequencer is activated. 

Procedure for defining steps 
1. Select Insert > Step+Transition from the menu. 
2. Insert a new step 3 along with transition 2 below transition 1. 

This sets the structure of the sequencer. 
3. Select Insert > Select from the menu. 

The mouse pointer changes to a selection cursor. 
4. Select the "START" step and then the menu command Edit > Object Properties.... 

The "Properties" dialog box opens and the "General" tab is active. 
5. Change to the "Processing" tab and enter the following parameters in accordance with 

the table below. 
Note the following point: 
  

 

  Note 
Since you are entering parameters for an SFC type, you will work with the block contacts 
that you have defined in the characteristics editor. This means that you cannot navigate 
to the desired block I/O using the "Browse" button and apply it from there. 
You will make the work easier by proceeding as follows: 
• Select View > Inputs/Outputs from the menu. 
• Navigate to the corresponding input/output in the overview. 
• Drag and drop the I/O name in the input line. 
Remember that the "IN" and "OUT" I/Os are interchanged for the SFC type. 

  
 

I/O type Left address Right address 
OUT HValv_LIOP_SEL TRUE 
OUT DValv1_LIOP_SEL TRUE 
OUT DValv2_LIOP_SEL TRUE 
OUT HValv_AUT_L TRUE 
OUT DValv1_AUT_L TRUE 
OUT DValv2_AUT_L TRUE 
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6. Click "Apply". 
Video  
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7. Go to Step 3 using the arrow buttons. 
8. Enter the name "CLOSE_VALVE" in the "General" tab and click "Apply". 
9. Enter the following parameters in the "Edit" tab:  

 
I/O type Left address Right address 
OUT HValv_AUTO_OC FALSE 
OUT DValv1_AUTO_OC FALSE 
OUT DValv2_AUTO_OC FALSE 

  
10. Click the "Apply" button and then the "Close" button. 

Procedure for defining transitions 
1. Select transition "2" and then the menu command Edit > Object Properties.... 

The "Properties" dialog box opens and the "General" tab is active. 
2. Enter the name "CLOSE_OK". 
3. Click "Apply". 
4. Change to the "Condition" tab and enter the following parameters: 
  

 
I/O type Left address Operator Right address 
IN HValv_QCLOSED = TRUE 
IN DValv1_QCLOSED = TRUE 
IN DValv2_QCLOSED = TRUE 

  
5. Click the logic button to logically OR the three addresses. 

The "&" symbol is replaced by the ">1" symbol. 
6. Click "Apply" and then "Close". 

All your entries are saved and the "Properties" dialog box closes. 
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7.3.13 Step 9 - How to Configure the "Heating" and "Drain" Sequencers 

Requirements 
● The example project is open in SIMATIC Manager. 
● The "REAC" SFC type is open in the SFC Editor. 

Procedure for configuring the "HEATING" sequencer 
1. Select the "HEATING" tab. 
2. Insert four additional steps with transitions below transition 1. 
3. Enter the following parameters for the steps: 

  
 

  Note 
All parameters can be found in the "OUT" inputs/outputs. 

  
General" tab Edit" tab 
Step 

  
Name Left address 

  
Right address 

HCtrl_LIOP_INT_SEL TRUE 
HCtrl_SPEXON_L TRUE 
HCtrl_LIOP_MAN_SEL TRUE 

START Unchanged 

HCtrl_AUT_L TRUE 
 3 VALVE_OPEN HValv_AUTO_OC TRUE 
 4 CONTROL HCtrl_SP_EXT SPHeat_Q 
 5 SP_DOWN HCtrl_SP_EXT 30 
 6 VALVE_CLOSE HValv_AUTO_OC FALSE 

Unchanged HValv_LIOP_SEL FALSE 
 HValv_AUTO_OC FALSE 
 HCtrl_LIOP_INT_SEL FALSE 

END 

 HCtrl_LIOP_MAN_SEL FALSE 

  
4. Enter the following parameters for the transitions: 
  
General" tab Condition" tab 
Transition 

  
Name I/O 

type 

  
Left address 

  
Operator 

  
Right  
address 

 1 - - - - - 
 2 OPEN_OK IN HValv_QOPENED = TRUE 
 3 TEMP_OK OUT SPHeat_AO >= SPHeat_Q 
 4 SP_LOW OUT SPHeat_AO <= 60 
 5 CLOSE_OK IN HValv_QCLOSED = TRUE 
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Procedure for configuring the "Drain" sequencer  
1. Select the "Drain" tab. 
2. Insert four additional steps with transitions below transition 1. 
3. Enter the following parameters for the steps: 

  
 

  Note 
All parameters can be found in the "OUT" inputs/outputs. 

  
General" tab Edit" tab 
Step 

  
Name Left address 

  
Right address 

DMot_LIOP_SEL TRUE START Unchanged 
DMot_AUT_L TRUE 
DValv1_AUTO_OC TRUE  3 OPEN_VALVE 
DValv2_AUTO_OC TRUE 

 4 PUMP_ON DMot_AUTO_ON TRUE 
 5 PUMP_OFF DMot_AUTO_ON FALSE 

DValv1_AUTO_OC FALSE  6 CLOSE_VALVE 
DValv2_AUTO_OC FALSE 
DValv1_LIOP_SEL FALSE 
DValv1_AUTO_OC FALSE 
DValv2_LIOP_SEL FALSE 
DValv2_AUTO_OC FALSE 
DMot_LIOP_SEL FALSE 

END Unchanged 

DMot_AUTO_ON FALSE 
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4. Enter the following parameters for the transitions: 
  

 

  Note 
All parameters can be found in the "IN" inputs/outputs. 

  
General" tab Condition" tab 
Transition 

Name 
Left address 

Operator Right address 

 1 - - - - 
DValv1_QOPENED = TRUE  2 OPEN_OK 
DValv2_QOPENED = TRUE 
DMot_QRUN = TRUE  3 ON_OK 
Level < Levmin 

 4 OFF_OK DMot_QSTOP = TRUE 
DValv1_QCLOSED = TRUE  5 CLOSE_OK 
DValv2_QCLOSED = TRUE 

  
5. Close the SFC Editor. 
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7.3.14 Step 10 - How to create an SFC instance 

Requirements 
● The example project is open in SIMATIC Manager. 
● The following CFC charts are open: 

– CFC_TC311 
– CFC_NP311 
– CFC_NK313 
– CFC_NK314 
– CFC_NK315 
– CFC_LI311 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/Plant1/REAC1" folder in the tree view. 
2. Insert a CFC chart and name it "SFC_REAC". 
3. Open the CFC chart. 
4. Select the "Blocks" tab in the catalog and open the "Other blocks" folder. 
5. Drag the "REAC" block to the CFC chart. 

This block is the SFC instance that is based on the SFC type you have already created 
and configured. Here, you will see all I/Os you defined in the block contacts. 
You will also find the setpoints and process values you defined in the Characteristics 
editor. 

6. Select Edit > Object Properties... from the menu. 
The "Properties" dialog box opens. 

7. Enter the name "REAC" in the "Name" field. 
8. Click "OK". 
9. Now interconnect to the actual blocks in the corresponding charts: 

– Click on the "HCtrl_SP_Ext" output. 
If the I/O names are not fully visible, move the mouse slowly over the individual 
inputs/outputs to have the full name of the I/O displayed as a tooltip. 

– Change to the "CFC_TC311" CFC chart. 
– Click on the on the "SP_Ext" input of the "CTRL_TEMP" block. 

All inputs and outputs to the control block are closed automatically. 
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10. Make the following interconnections from the SFC instance to the CFC charts: 
  

 
Output SFC_REAC CFC chart Block Input 
HValv_AUTO_OC CFC_NK313 VALVE AUTO_OC 
DValv1_AUTO_OC CFC_NK314 VALVE AUTO_OC 
DValv2_AUTO_OC CFC_NK315 VALVE AUTO_OC 
DMot_AUTO_ON CFC_NP311 MOTOR AUTO_ON 

  
11. Make the following interconnections from the CFC charts to the SFC instance:  

 
CFC chart Block Output  

CFC chart 
Input SFC_REAC 

CFC_TC311 INPUT V SPHeat_AI 
This displays the current control value on 
the OS of the controller. 

DRAIN_MIN_LEV V Levmin 
Minimum fill level 

CFC_LI311 

TANK_LEV V Level 
Current fill level 

  
12. Select the menu command Options > Optimize Run Sequence... 
13. In the "The run sequence of the blocks will be changed and optimized according to the 

data flow....." message box, click "OK". 
All blocks are then arranged automatically in the correct run sequence. 

14. Close the CFC editor. 
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7.3.15 Step 11 - How to store the SFC type in the master data library 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Select the "color_gs_MP/color_gs_Prj/SIMATIC 400(1)/CPU 417-4/S7 Program(1)/Charts" 

folder in the tree view. 
2. Copy the "REAC" SFC type. 
3. Change to the tree view and select the folder 

"color_gs_MP/color_gs_Lib/S7 Program(1)/Charts". 
4. Insert the SFC type. 
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7.4 Summary 

7.4.1 Summary of "Rational engineering in the SFC configuration" 

New functions 
What have you learned from working with SFC charts? 
In addition to using textual interconnections in SFC charts, you have also learned about a 
very important function for efficient engineering: working with SFC types. 
SFC types offer the special advantage of centralized editing. For example, whenever you 
add a new block contact for an SFC type, this block contact is automatically added to every 
SFC instance. Changes in the sequencers are also automatically made in every SFC 
instance. 
  

 

NOTICE  
Make changes only to the SFC type that you have saved in the project folder in the 
component view, and then store the updated version in the master data library. 
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Compiling, downloading, and testing charts 8
8.1 Compiling, downloading and testing your project 

Introduction 
You already know this function from Getting Started - Part 1: Compiling and downloading 
BATCH with the command "Compile and download objects". You enter the required settings 
in the relevant dialog box. 
This part of Getting Started introduces testing of the SFC instance with your specific control 
strategies. It involves controlling the control strategies through a special connection of the 
SFC instance. 

8.2 How to compile and download the project 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 
● The CPU is in STOP. 

The first time you download, you need to download the entire program. It is only possible 
to download the entire program if the CPU is in STOP mode. 
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Procedure 
1. Select the "color_gs_MP\color_gs_Prj" folder in the tree view. 
2. Select PLC > Compile and Download Objects from the menu. 

The "Compile and Download Objects" dialog box opens. 
3. Expand the entire tree so that all entries can be seen. 
4. Perform the settings in accordance with the following table:  

 
Object Compile Downlo

ad 
color_gs_Prj/[name of your local PC station]/Configuration X - 
color_gs_Prj/[name of your local PC station]/WinCC Application/OS(1) - - 
SIMATIC 400(1)/Hardware X X 
SIMATIC 400(1)/CPU 417-4/Charts X X 

  

 
 

5. Select the "Charts" object in the tree view, and click the "Edit..." button. 
The "Compile Program/Download to Target System" dialog box opens. 
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6. Select the following "options":  
 

Tab Option Selected 
Entire program yes 
Generate module drivers yes 

Compile charts as program 

Generate SCL source no 
Download S7 Entire program yes 

  

 
 

7. Click "OK". 
8. In the "Remember that if you download later (e.g. in the SIMATIC Manager using...), the 

blocks will be deleted on the CPU" message box, click "OK". 
9. Click the "Start" button. 
10. Click "OK" in the first message box "Downloading program changes during operation can, 

in the case of malfunctions or program errors, cause serious damage to personnel and 
equipment!...". 
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11. Click "Yes" in the second message box "If you want to download changes online, please 
make sure that the prerequisites have been met.... Do you want to continue?" 
The compilation and download are started.  
When the function is completed, the log file is displayed in the text editor: The compilation 
of the charts completed with warnings. 

12. Close the text editor. 
13. Select the "Charts" object in the tree view, and click on "Single Object" in the "Display 

Log" area. 
The "Logs" dialog box opens. The detailed warnings are shown here. These warnings are 
displayed because the textual interconnections could not be completed with the current 
project status. These interconnections can only be completed when the configuration of 
the REAC2 part of the plant is finished. You can still test the project in this condition 
despite the warnings. 

 
 

14. Click "Close". 
The "Logs" dialog box closes. 

15. Change the CPU back to RUN. 
Since you have configured external I/O in HW Config without closing the connections, the 
following error LEDs light on the CPU: 
– EXTF – steady light 
– BUS2F – flashing 
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8.3 How to test the program 
If you want to test your configured control strategies on the ES, you must connect the 
corresponding inputs. You have no operator interface on which to select the corresponding 
control strategy.  

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 

  
 

  Note 
If you want to include the RMT1 and RMT2 parts of the plant in the test, make sure that 
you start a drain operation after every filling operation. 

  

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP\color_gs_Prj\Plant1\REAC1". 
2. Open the "SFC_REAC" CFC chart in the CFC Editor. 
3. Select the "REAC" SFC instance, and select Edit > Object Properties from the menu. 
4. Set the "CSP_OP" I/O to make it visible, and click "OK". 

As default, the I/O has the value "0". 
5. Select Debug > Test Mode from the menu. 

This brings you into test mode: you are already familiar with this function from Getting 
Started - Part 1. 

6. Double-click on the "CSP_OP" input. 
The "Properties - Input/Output" dialog box opens. 
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7. Enter the number of the desired control strategy in the "Properties - Input/Output" dialog 
box and click "OK". 

 
 

  
CSP_OP Control strategy 
 1 HEATING 
 2 DRAIN 

  
1. Select the SFC instance "REAC" and then select Edit > Open from the menu. 

The SFC instance is opened in the SFC editor and the "RESET" tab is active. 
2. Select Debug > Test Mode from the menu. 

You change to the test mode. 
3. Click the "Start" button. 

The "RESET" sequencer is started first. 
Immediately after this, the control strategy you set at the "CSP_OP" input in the CFC 
editor is started automatically. 

4. Enter another control strategy in the CFC chart and start the sequencer again. 
  

 

  Note 
To monitor the values at the inputs and outputs in the CFC charts, open the desired CFC 
charts in the CFC Editor and go into test mode there.  
Use the following procedure to make the values at the connections visible: 
1. Press the shortcut <CTRL+A>. 

This selects all the blocks in the CFC chart. 
2. Select Debug > Watch On from the menu. 

The values at the I/Os are then displayed. 
3. If you want to monitor additional inputs/outputs, select the desired I/O and select 

Debug > Input/Outputs > Add to Watch List from the menu. 

  
5. Enter "0" again at the "CSP_OP" input. 
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Configuring the PCS 7 OS 9
9.1 Overview of work when configuring the OS 

Introduction 
You have already made many of the settings for OS configuration in SIMATIC Manager. 
When configuring the OS, you will access these data conveniently. This includes the 
following functions, for example: 
● You will conveniently interconnect the picture objects with the block inputs/outputs from 

the CFC charts when creating process pictures. 
● You have already assigned block icons to the process tags in the CFC charts enabling 

you to create the block icons automatically. 
● You defined the plant hierarchy in the SIMATIC Manager and made the settings for the 

OS area. This hierarchy is automatically represented on the OS in process mode. 

Work involved in OS configuration 
During OS configuration, you will perform the following configuration steps: 
● Creating and using your own icons 

You will create a new icon for the agitator in the reactor and for the pump for draining. For 
this purpose, you will use the functions for creating graphics that you became familiar 
with when creating the process pictures in Getting Started - Part 1. 

● Creating the status display 
Here, you will combine the newly created icon for the agitator with a status display. 

● Adapting the standard block icons 
There are two motors in the "REAC1" unit: One motor acts as an agitator, the other as a 
pump. These two functions should be easy to recognize by the plant operator based on 
the block icons. You will therefore modify the default block icon for the motor. 

● Creating the process picture for the "REAC1" plant section 
You are already familiar with this work from creating the process picture for the "RMT1" 
and "RMT2" parts of the plant. 

● Adapting the process pictures for the plant sections "RMT1" and "RMT2" 
These corrections are necessary to combine the plant sections RMTx and REACx. 
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9.2 Creation of icons 

9.2.1 How to create your own icons for process pictures 

Custom icons for process tags 
When you create plant-specific process pictures, it may be necessary to create you own 
special icons, for example, for process tags. You will create these icons once and then be 
able to use them repeatedly. 
In this Getting Started, you will create custom icons for the following process tags: 
● Agitator in the reactor 
● Pump for drainage 
All of the icons that you create will be stored together in a separate file. Each individual icon 
will then be exported to a separate picture file with the *.emf format. You can then use the 
picture for representing different states in a status display. 

9.2.2 How to open the picture file for your icons 
You will store all of the icons that you have created yourself in this file. 

Requirements 
● The example project is open in SIMATIC Manager. 
● The component view is activated 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Prj/[Name of PC station]/WinCC Application/OS(1)". 
2. Select Edit > Open Object from the menu. 

The WinCC Explorer opens. 
3. In the navigation window, select the "Graphics Designer" object. 
4. Open the context menu and select Open. 

An empty file opens in the Graphics Designer. 
5. Select File > Save as... from the menu and save the file with the name 

"status_display.pdl" in the suggested directory. 
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9.2.3 How to create the icons for the agitator 

Requirement 
The "status_display.pdl" file is open in the Graphics Designer. 

Procedure 
1. If the object palette is not displayed, select View > Toolbar from the menu and select the 

"Objects" check box. 
2. Create a long rectangle. 
3. Select View > Properties... from the menu. 

The "Object Properties" dialog box opens. 
4. Enter the following parameters – for all other parameters accept the default values:  

 
Property Attribute Static" parameter column 
Rectangle Object name Axis 

Width  5 Rectangle/Geometry 
Height  240 

Rectangle/Colors Background color Black 

  
5. Create a second rectangle with the following parameters  

 
Property Attribute Static" parameter column 
Rectangle Object name Background 

Width  45 Rectangle/Geometry 
Height  15 

Rectangle/Colors Background color Dark gray 
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6. Now create an agitator icon from several lines: 

 
 

7. Position the icon on the small rectangle. 
8. Assemble all of the elements to form a symbolic representation for an agitator. 

 
 

9. Select all of the elements with the mouse and create a copy. 
10. Assign the small rectangle the color "green". 
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11. Add descriptive static text fields: 
  

 
Type of agitator icon Text field/File name 
Green agitator icon agitator_on.emf 
Gray agitator icon agitator_off.emf 

  
12. Select all of the elements of the green agitator – except the explanatory text fields – with 

the mouse, and select Edit > Group > Group from the menu. 
13. Then select all the elements of the gray agitator - except the explanatory text fields - with 

the mouse, and select Edit > Group > Group from the menu. 

 
 

14. Save the "status_display.pdl" file. 
15. Select the green agitator icon and then select File > Export... from the menu 

The "Save as Metafile" dialog box opens and the graphics folder for your project is 
selected automatically. 

16. Enter the file name "agitator_on.emf" and click "Save". 
17. Select the gray agitator and export the object to the "agitator_off.emf" file. 
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9.2.4 How to create the icons for the pump 
The icons for the pump are also stored in the "status_display.pdl" file. You do not create the 
icons from scratch; instead, you modify an existing icon.  

Requirement 
The "status_display.pdl" file is open in the Graphics Designer. 

Procedure 
1. Select Insert > Import from the menu. 

The "Load Metafile" dialog box opens. 
2. Select the "@motor_on.emf" file and click "Open". 

The "Import - Document Size" dialog box opens. 

 
 

3. Accept the default settings and click "OK". 
The icon for a motor, which you are already familiar with from Getting Started - Part 1, is 
imported. 

4. Delete the letter "M". 
5. Select the "Polygon" object from the object palette and create a triangle roughly in the 

form of the pump icon as shown in the illustration below. 
  

 

  Note 
Click once with the mouse for each corner and complete the polygon by double-clicking. 
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6. Enter the following parameters:  
 

Property Attribute Static" parameter column 
Polygon Object name Pump 

Width  25 Polygon/Geometry 
Height  20 

Polygon/Colors Background color Black 

  
7. If the triangle is not symmetric, grab the right corner with the mouse and drag it to the 

correct position. 

 
 

8. Insert the triangle in the circle. 
9. Select all of the elements with the mouse and create a copy. 
10. Select the circle and assign it the color "dark gray". 
11. Create a third copy and assign the color "red" to the circle in this copy. 
12. Group the individual elements for each icon without the explanatory text fields. 
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13. Create explanatory text fields for each icon:  
 

Symbol Text field/File name 
Green circle pump_on.emf 
Dark gray circle pump_off.emf 
Red circle pump_error.emf 

  

 
 

14. Save the "status_display.pdl" file. 
15. Export the new icons and assign file names based on the entries in the corresponding 

text fields. 
16. Close the "status_display.pdl" file. 
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9.3 Working with standard block icons 

9.3.1 Where are the standard block icons stored? 

Modification of block icons 
In the next step you will modify the existing default block icons provided by PCS 7. The 
default block icons are stored in a specific file:  
In the "@@PCS7Typicals.pdl" file that is installed automatically when you install PCS 7. 
You do not, however, save your modified block icons in the original file but in a new one. In 
Getting Started - Part 2, this file is given the name "@PCS7Typicals_gs2.pdl". 
Do not confuse the block icons with the icons you have created in the "status_display.pdl" 
file. The icons that you have already created are pure graphic elements.  
Block icons provide many functions:  
Starting from one block icon, you can, for example, open faceplates in process mode that will 
give you extensive information about the process tag. Some block icons already have an 
integrated group display or status display. 
The most important thing about the default block icons is the assignment to specific blocks in 
the CFC charts so that they are created automatically. 

File Names "@@PCS7Typicals.pdl" and "@PCS7Typicals _gs2.pdl" 
The name of the "@@PCS7Typicals.pdl" file must not be changed:  
With this name, PCS 7 automatically knows which file it must take the block icons from when 
executing the "Create/update block icons" function. If only the "@@PCS7Typicals.pdl" file is 
available, PCS 7 automatically takes the block icons from this file.  
If you wish to use modified block icons in your project, you can store them in the 
corresponding template files. You can use up to 10 different template files.  
When assigning the file name, you must ensure that the file name consists of the fixed name 
component "@PCS7Typicals" plus an additional variable name component. The fixed name 
component is always at the beginning of the file name and is required for PCS 7 to identify 
the files in which the additional block icons are stored. You assign the variable name 
component according to your project requirements. 
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9.3.2 Modification of the default block icons 

Purpose 
For Getting Started - Part 2, you modify the following default block icons: 
● "MOTOR" 
● "SFC type" 

"MOTOR" block icon 
You are already familiar with the "MOTOR" block icon from Getting Started - Part 1. The 
default block icon represents the motor with an "M" inside a circle. Since motors have a 
variety of functions in the "REAC" unit, you should make these functions clearly recognizable 
to the plant operator at first glance. The agitator is represented by an "M" within a circle. 
Since there is no need to make any changes here, you use the default block icon.  
However, the pump requires another block icon. It is displayed as a triangle within a circle. 
This block icon is the one you will create. You have already done the preparatory work for 
this in the "status_display.pdl" file, where you created the icons for the graphical display. 

Assignment of block icons to the blocks 
You may remember this from Getting Started - Part 1. There you entered specific numbers in 
the process object view to define the vertical or horizontal orientation of the "VALVE" block 
icon in the process picture. Of course, these numbers are also available in the data for the 
block icon, enabling the block icons to be assigned to the blocks. You will also make this 
assignment for the pump and agitator. 

"SFC type" block Icon 
You call the faceplate with the help of this block icon. From there you can manipulate the 
SFC instance in process mode, for example, select control strategies or specify setpoints. Of 
course, a separate block icon must therefore be available for each SFC instance. Copies of 
the default block icon "SFC type" are created for this purpose. The corresponding SFC 
instances are then assigned to each copy. 
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9.3.3 How to create a new template file 

Requirement 
The operator station OS (1) in WinCC Explorer is open. 

Procedure 
1. Select the "OS(1)\Graphics Designer" object in the tree view. 
2. Position the cursor in the detailed window. 
3. Open the context menu and select the menu command New Picture. 

A new picture with the file name "NewPdl0.Pdl" is added at the end of the list. 
4. Select this new picture in the detailed window. 
5. Open the context menu and select Rename Picture from the menu. 
6. Enter the name "@PCS7Typicals_gs2.pdl" in the dialog box and click "OK". 

This renames your new template file. 

9.3.4 How to modify the default block icons 

Overview 
You modify the default block icons in four steps: 
  

 
Step What? 
 1 Store copies of the block icons required (Page 172) 
 2 Modify properties for the "MOTOR" block icon (Page 173) 
 3 Modify the representation of the pump (Page 174) 
 4 Modify the "SFC-TYP" block icon (Page 176) 
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9.3.5 Step 1 - How to store copies of the required block icon 

Requirement 
The operator station OS (1) in WinCC Explorer is open. 

Procedure 
1. Open the "@PCS7Typicals_gs2.pdl" file. 

This is the file in which you save your project-specific block icons. 
2. Open the "@@PCS7Typicals.pdl" file in the Graphics Designer. 

This is the file containing the standard block icons. 
3. Select the "MOTOR" block icon including the title "MOTOR" in the "MOTOR" line of the 

"@@PCS7Typicals.pdl" file, and select Edit > Copy from the menu. 
4. Switch to the "@PCS7Typicals_gs2.pdl" file and select Edit > Paste from the menu. 

 A copy of the "MOTOR" block icon is inserted. 
5. Position the block icon at the upper left of the drawing area. 
6. Switch to the "@@PCS7Typicals.pdl" file and mark the block icon "SFC Type" in the 

"Other" row. 
7. Select Edit > Copy from the menu. 
8. Switch to the "@PCS7Typicals_gs2.pdl" file and select Edit > Paste from the menu. 

 A copy of the "SFC_Type" block icon is inserted. 
9. Position the "SFC_Type" block icon below the "MOTOR" block icon. 
10. Save the "@PCS7Typicals_gs2.pdl" file. 
11. Close the "@@PCS7Typicals.pdl" file. 



 Configuring the PCS 7 OS 
 9.3 Working with standard block icons 

PCS 7 - Getting Started - Part 2 
Getting Started, 09/2007, A5E00857270-02 173 

9.3.6 Step 2 - How to change the properties of the "MOTOR" block icon 

Requirement 
● The "@PCS7Typicals_gs2.pdl" file is open in the Graphics Designer. 

Procedure 
1. Change the title to "PUMP" just like in a standard text box. 
2. Select the newly inserted block icon. 
3. Select the menu command View > Properties. 
4. Select the "General" property. 
5. Double-click on the "Type" attribute. 

The "Text Input" dialog box opens. 
6. Enter the following in the "Output value" field: "@MOTOR/pump". 

 
 

  
 

  Note 
You are already familiar with the "pump" value from your work in creating the motor 
process tags. In that case you changed the existing process tags by adding an additional 
parameter: the "BlockIcon" parameter. You entered exactly this value in the "BlockIcon" 
column in the import file. 

  
7. Click "OK" and close the "Object Properties" dialog box. 
8. Save the file. 
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9.3.7 Step 3 - How to adapt the representation of the pump 

Requirement 
● The "@PCS7Typicals_gs2.pdl" file is open in the Graphics Designer. 

Procedure 
1. Select the block icon with the title "PUMP". 
2. Select Edit > Customized Object > Edit...in the menu 

You use this to divide the block icon, which is implemented as a customized object, into 
individual elements. You can edit these individually. 
  

 

NOTICE  
 

Do not select "Ungroup" from the menu under any circumstances. This ungroups the 
customized object, and the entire configuration of the block icon will be deleted. 

  
3. Select the circle with "M". 

This graphic element has been implemented as a so-called "status display (expanded)". 
4. Open the context menu and select the menu command Configuration Dialog... 

The "Extended Status Display Properties" dialog box opens. 
5. Change to the "Assign pictures" tab. 
6. Select "Index 0" in the first row. 

The assigned pictures are displayed in the preview. 
7. Make sure that the "*.wmf,*.emf" check box is activated. 

This means that all pictures with the file extension "*.emf" and "*.wmf" are displayed. 
8. Double-click on the "pump_off.emf" file in the list of pictures. 

Both the preview and the list show that the original motor representation has been 
replaced in the basic picture by the pump representation. 

9. Now double-click on the "pump_on.emf" file in the list of pictures. 
Both the preview and the list show that the original motor representation has been 
replaced in the flashing picture by the pump representation. 

10. Select the next line "Index 1". 
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11. Replace all other pictures in similar manner:  
 

Row Basic picture New 
basic picture 

Flashing picture New 
flashing picture 

Completed: 
Index 0 

@motor_is_off.emf pump_off.emf @motor_is_on.emf pump_on.emf 

Index 1 @motor_is_on.emf pump_on.emf - - 
Index 2 @motor_is_off.emf pump_off.emf - - 
Index 3 @MOTOR_Error.emf pump_error.emf - - 

  
12. Click "OK". 

You can see that the representation of the pump has already changed in the 
"@PCS7Typicals_gs2" file. 

13. Keeping the mouse button pressed, draw a lasso around all elements of the block icon 
and select Edit > Customized Object > Finish Editing from the menu. 

14. Save the "@PCS7Typicals_gs2" file. 
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9.3.8 Step 4 - How to modify the "SFC TYPE" block icon 

Creating block icons for SFC instances 
 

 Note 
When you execute the "Create/Update Block Icons" function, a block icon is automatically 
placed in the appropriate picture and interconnected for all SFC instances that are enabled 
for operator control and monitoring. 

 

Requirement 
● The "@PCS7Typicals_gs2.pdl" file is open in the Graphics Designer. 

Procedure 
1. Change the title of the "SFC_TYPE" block icon to "SFC_TYPE_REAC". 
2. Select the faceplate icon and the View > Properties... from the menu. 

The "Object Properties" dialog box opens. 
3. Select the "@SFC_Typ/1" property. 
4. Double-click the "Object name" attribute and enter the name "REAC". 

 
 

5. Select the "General" property. 
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6. Double-click on the "Tag" attribute. 
The "Text Input" dialog box opens. 

7. In the "Output Value" box, enter the complete path to the SFC instance including the 
name of the SFC instance in the CFC chart: 
"Plant1/REAC1/SFC_REAC/REAC". 

 
 

8. Enter the following values: 
  
Property Attribute Value 
General Type @REAC/1 
General Tag name Plant1/REAC1/SFC_REAC/REAC 

  

 
 

9. Close the "Object Properties" dialog box. 
10. Save the "@PCS7Typicals_gs2" file. 
11. Close the Graphics Designer and close WinCC Explorer. 
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9.4 Creating block icons and compiling the OS 

9.4.1 Creating block icons and compiling the OS 

Functions in the plant hierarchy 
In order to generate block icons, you also need to run functions in the plant hierarchy – you 
are already familiar with this from Getting Started - Part 1. The steps involved are briefly 
outlined in the following sections. 
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9.4.2 How to select the option for creating block icons 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 
● WinCC Explorer is closed. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Prj/Plant1/REAC1". 
2. Select the "REAC1" process picture in the detailed window and open the object 

properties. 
3. In the "Block Icons" tab, select the "Derive the block icons from the technological 

hierarchy" check box. 

 
 

4. Click "OK" and close the dialog box. 
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9.4.3 How to create the block icons 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 
● The option for creating block icons is selected. 

Procedure 
1. Go to the tree view and select the folder  

"color_gs_MP/color_gs_Prj/Plant1/REAC1". 
2. Select Options > Plant Hierarchy > Create/Update Block Icons from the menu. 
3. Check the following: 

– The correct picture is selected. 
– The "Included lower level hierarchy levels" are set to "1". 

 
 

4. Click "OK". 
The block icons are generated. 
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5. In the "To ensure possible automatic corrections to the WinCC picture 
interconnections,…. Do you want to see the function log now?" message box, click "Yes". 
The log is opened in the text editor. There you will see the process tags for which block 
icons have been created. You can also see the variant. 
For the "Valve" process tag, for example, Variant "2" signifies the horizontal 
representation. For the "Motor" process tag, the "pump" variant signifies the 
representation of the motor as a pump. 
This is the name you entered in the import/export file and which has now been used 
when creating the block icons. 

 
 

6. Close the text editor. 
  

 

  Note 
If the log is not displayed, select Options > Plant Hierarchy > Open Block Icons Log from 
the menu. 
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9.4.4 How to compile the OS 

Requirements 
● SIMATIC Manager is open. 
● The plant view is activated. 
● The block icons have been created. 

Procedure 
1. Switch to the component view. 
2. Select the "color_gs_MP\color_gs_Prj" folder in the tree view. 
3. Select PLC > Compile and Download Objects from the menu. 

The "Compile and Download Objects" dialog box opens. 
4. Expand the entire tree so that all entries can be seen. 
5. Select the following check boxes: 

– Object "OS(1)": check box in the "Compile" column 
– Object "Charts": check box in the "Compile" column 
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6. Select the "OS(1)" object in the tree view, and click the "Edit" button. 
7. In the "Settings: Compile OS" wizard, take the following steps:  

 
Step Actions 
"Which areas do you want to assign to the 
operator station OS(1)?" 

No additional settings are required here because OS(1) 
is already assigned for all areas by default and you will 
not use any other operator stations in your project. 

"Select the network connections for the S7 
programs associated with the areas" 

Click the "Connection" button and select the S7 
connection you have made in NetPro in the "Select 
network connection" dialog box. 

"Select the data you want to compile and 
the scope of the compilation" 

Select the following check boxes or radio buttons: 
• Tags and messages 
• SFC Visualization: 
• Picture Tree 
• Entire OS with memory reset 

  
8. Click "Apply". 
9. Click the "Start" button. 
10. Click "Yes" in the second message box "If you want to download changes online, please 

make sure that .... Do you want to continue?". 
The compilation starts and when it is completed, the log file is displayed in the text editor. 
The compilation is completed with warnings because the open textual interconnections 
cannot be made at this stage of the configuration. 

11. Close the text editor. 
12. Close the "Compile and Download Objects" dialog. 
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9.5 Creating a process picture 

9.5.1 Creating a process picture 

Overview 
You already know how to create a process picture from your work in Getting Started - Part 1. 
The steps involved in this work are briefly outlined in the following. Detailed instructions are 
provided for all tasks that were not covered in the first part of Getting Started. This includes 
the following configuration steps:: 
● Inserting and configuring the status display 
● Inserting the buttons 

9.5.2 How to create the process picture 

Requirement 
The operator station OS (1) in WinCC Explorer is open. 

Procedure 
1. Open the "REAC1" picture in Graphics Designer. 

All the block icons have already been inserted here. 
2. Select View > Library from the menu, and insert the following additional objects from the 

various folders.  
 

Path in the library Name of object Number 
Global Library/PlantElements/Pipes - Smart Objects/3D Pipe 
Horizontal 

Horizontal pipes  8 x 

Global Library/PlantElements/Pipes - Smart Objects/3D Pipe 
Vertical 

Vertical pipes  3 x 

Global Library/PlantElements/Pipes - Smart Objects/3D Pipe 
Elbow 1 

Angle  1 x 

Global Library/PlantElements/Pipes - Smart Objects/3D Pipe 
Elbow 2 

Angle  2 x 

Global Library/PlantElements/Pipes - Smart Objects/3D Pipe 
Elbow 3 

Angle  1 x 

Global Library/PlantElements//Tanks/Tank4 Reactor  1 x 
Global Library/Icons/Valves 31  1 x 
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3. Position the block icons and the new graphic objects as shown in the following illustration, 
and change the size of the objects to roughly match: 

 
 

4. Select the reactor, and select View > Properties from the menu. 
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5. Enter the parameters in accordance with the following table and then close the "Object 
Properties" dialog box:  

 
Property Attribute Static" parameter column 
Tank4 Object name Reactor 1 

Width  110 Tank4/Geometry 
Height  300 

Tank4/Colors Bar background color Dark gray 
Tank4/Link Maximum value  1200 

  
 

Property Attribute Dynamic" parameter column 
Fill level Tag interfacing using ES variables 

Plant1/REAC1/CFC_LI311/TANK_LEV_MON.U 
Tank4/Link 

Minimum 
value 

Delete dynamic 

  
6. Create a symbolic representation for the heating using the "line" and "polygon" objects. 
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7. Create the graphic representation for the block icons. 
Use standard graphics objects such as rectangles and static text fields with the required 
colors and position the block symbols:  

 
Block icon Display 
SFC type 

 
Operator control block for simulation 

 
Operator control block for minimum fill level 

 

  
8. Save the "REAC1.pdl" file. 
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9.5.3 How to insert a status display 

Introduction 
You create a special status display for the agitator. The icon for the agitator represents the 
current status of the agitator exactly like the motor: 
● Green: Agitator activated 
● Gray: Agitator deactivated 

Requirements 
● The operator station OS (1) in WinCC Explorer is open. 
● The "REAC1" process picture is open in the Graphics Designer. 
● The object palette is open, and the "Default" tab is active. 

Procedure 
1. Select the "Smart Objects/Status Display" object in the object palette. 
2. Go to the drawing area. 

The mouse pointer changes to a small status display symbol. 
3. Open a rectangle about the size of the agitator. 

The "Status Display Configuration" dialog box opens. 
4. Click the "Tag Selection" button. 

The tag selection dialog opens. 
5. Make sure that the "ES Variables" check box is selected in the "Data source" area. 
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6. Go to the tree view and select the entry  
ES Variables/Plant1/REAC1/CFC_NR311/MOTOR" and then select the "QRUN" I/O in 
the detailed window. 

 
 

7. Click "OK". 
The tag is entered. 

8. Now select the "agitator_off.emf" file in the "Selection of Picture" list, and drag this picture 
into the "Basic picture" column. 

9. Click the "Add" button. 
This adds a further status to the list of statuses: Status "1" 
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10. Now drag the "agitator_on.emf" picture from the picture selection to the basic picture of 
status "1". 

 
 

11. Click "OK". 
The icon for the agitator is displayed in the process picture. 

12. Now position the agitator in the reactor on the agitator motor and adapt the size. 
13. Save the "REAC1" picture. 

Video  
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9.5.4 How to insert buttons for RMT1 and RMT2 

Requirements 
● The operator station OS (1) in WinCC Explorer is open. 
● The "REAC1" process picture is open in the Graphics Designer. 
● The object palette is open, and the "Default" tab is active. 

Procedure 
1. Select the "Windows Objects/Button" object in the object palette. 
2. Go to the drawing area. 

The mouse pointer changes to a small button. 
3. Drag a rectangle roughly the size of the button on the supply pipe of RMT1. RMT1 is the 

inlet valve NK311. 
The "Button Configuration" dialog box opens. 

4. Enter the name "RMT1" in the "Text" box. 

 
 

5. Click "Font". 
The "Font" dialog box opens. 

6. Select "Arial" and click "OK". 
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7. Click on the button next to the "Change Picture on Mouse Click" box. 
The "Pictures" dialog box opens. 

 
 

8. Select the picture "RMT1.PDL" and click "OK". 
The picture name is entered in the input box. 

9. Click "OK". 
The button is configured. 
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10. Repeat steps 1 to 7 to insert buttons for changing the picture to the "RMT2" part of the 
plant.  
Enter the parameters based on the following table: 

  
Parameter Value 
Position Feed pipe on the "NK312" inlet valve 
Button label RMT2 
Link to picture RMT2.PDL 
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NOTICE  
Note that the permission of the plant operator to change the picture using the button is not 
checked in process mode. When you use this function in actual operation, you must protect 
the authorization level with a C script. 

 
  
11. Save the "REAC1" picture. 
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9.5.5 How to modify the RMT1 and RMT2 process pictures 
Since you are representing reactors 1 and 2 in the "REAC1" and "REAC2" process pictures, 
you do not require any other symbolic representation in the "RMT1" and "RMT2" pictures. 

Requirements 
● The operator station OS (1) in WinCC Explorer is open. 
● The "RMT1" and "RMT2" process pictures are open in the Graphics Designer. 

Procedure 
1. Change to the "RMT1.pdl" process picture. 
2. Delete Reactor 1 and its labeling. 
3. Insert the Windows "Button" object from the object palette. 
4. Enter the following parameters in the configuration dialog box: 

– "Text" input box: Enter "REAC1" 
– "Font" button: Select the "Arial" font 
– "Change Picture on Mouse Click" button: Select the "REAC1.pdl" picture 

5. Delete Reactor 2 and its labeling. 
6. Insert the Windows "Button" object from the object palette. 
7. Enter the following parameters in the configuration dialog box: 

– "Text" input box: Enter "REAC2" 
– "Font" button: Select the "Arial" font 
– "Change Picture on Mouse Click" input field: Manually enter the picture name 

"REAC2.pdl" 
 

  Note 
Since you have not yet configured the "REAC2" part of the plant, you have to enter the 
picture name manually. 

8. Select the object "Raw Material Tank tank1" and open the "Object Properties" dialog box 
by opening the context menu and selecting Properties from the menu. 

9. Select the "Links" property, and enter the value "1000" for the "Maximum value" attribute 
in the "Static" column. 

10. Close the "Object Properties" dialog box. 
11. Save and close the "RMT1.pdl" picture. 
12. Change the "RMT2.pdl" process picture analogously. 
13. Save and close the "RMT2.pdl" picture. 
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9.6 Summary 

9.6.1 Summary of "Rational Engineering for the OS Configuration" 

New functions 
What have you learned when configuring the OS? 
● You have created custom icons for your process pictures that you can reuse as needed. 

In this case, there is no centralized editing feature. This is comparable to the chart-in-
chart technique that you were introduced to when working with CFC charts. 

● You have learned how to create new block icons by modifying default block icons. You 
have also become familiar with the relationship between the blocks and the block icons. 
Block icons offer the special advantage of centralized editing. When you change a block 
icon in the "@PCS7Typicals" file and call the function "Create/update block icons" again, 
all block icons are updated accordingly. 

 

  Note 
Be aware of the following: If you have adapted the block icons in the process picture, any 
changes you have made will be overwritten when the block icons are updated. 
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Operating and monitoring in process mode 10
10.1 Functions in process mode 

Overview 
In Getting Started - Part 1, you already became familiar with the operator control and 
monitoring functions in process mode.  
You will learn about two new functions in this part of Getting Started. 
● Operating the SFC instance 
● Switching the simulation method 
Of course, you can still operate the "RMT1" and "RMT2" parts of the plant as usual. 
  

 

 Note 
Be sure to run the "DRAIN" control strategy to empty the reactor before every new dosing 
with RMTx.  
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10.2 Operating the SFC instance 

Overview 
You can operate the SFC instance by means of the block icon with the associated faceplate. 
You have created the block icon using the automatic functions in PCS 7. You open the 
faceplate by clicking the block icon. 
You can perform the following operations here: 
● Start SFC Instance (Page 198) 
● Select control strategy (Page 199) 
● Specify temperature setpoints (Page 200) 
In addition you can switch the type of simulation (Page 201) in process mode. 

10.3 How to start the SFC instance 

Requirements 
● The example project is in process mode. 
● The RMT1/RMT2 part of the plant has been run through once with dosing in Reactor 1. 

Procedure 
1. Click the block icon "...SFC-REAC/REAC". 

The associated faceplate opens. 
2. Select the entry "Prepared Values" from the drop-down list box. 

This activates the "Start" button. 
3. Click "Start". 

The "SFC Operation" dialog box opens. 
4. Click "OK". 

This starts the control strategy displayed in the "Prepare control strategy" list. 
5. Click "Section". 

The sequencer is displayed with the tabs for the various sequencers. Here, you can 
closely monitor which step or which transition is being performed.  
You will also see that the "RESET" sequencer is always executed first at every start 
before the selected control strategy is started. 

6. When the sequencer has run through successfully, click the "Reset" button. 
Then start the SFC instance again. 
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10.4 How to select the control strategy 

Requirements 
● The example project is in process mode. 
● The "SFC_REAC" faceplate is open. 

Procedure 
1. Select the entry "Prepared Values" from the drop-down list box. 

This activates the "Start" button and the "Current control strategy" drop-down list box. 
2. Select the entry "DRAIN" from the "Current control strategy" list. 

The "SFC Operation" dialog opens. 
3. Click "OK". 

The selected control strategy is displayed in the list box. 
4. Click "Start". 

The "SFC Operation" dialog box opens. 
5. Click "OK". 

The sequencer starts. 
6. When the sequencer has run through successfully, click the "Reset" button. 

You can then start the SFC instance again. 
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10.5 How to change the setpoint for the temperature 

Requirements 
● The example project is in process mode. 
● The "SFC_REAC" faceplate is open. 

Procedure 
1. Click the block icon "...SFC-REAC/REAC". 

The associated faceplate opens. 
2. Select the entry "Prepared Values" from the drop-down list box. 

This activates the "Start" button and the "Current control strategy" drop-down list box. 
3. Select the control strategy "HEAT". 
4. Click in the edit box with the specified setpoint. In this case the setpoint is "80". 

This is the setpoint you set for the "Setpoints" characteristic when creating the SFC type. 
The high and low limits are displayed automatically. You have already specified these 
values in the characteristics of the SFC type. 

5. Enter a setpoint within the specified limits and press the ENTER key. 
The "SFC Operation" dialog opens. 

6. Click "OK". 
The setpoint is applied. 

7. Start the control strategy "HEAT" again and observe the values in the SFC and CFC 
charts. 
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10.6 How to switch the simulation method 

Simulation options 
You have two different simulation options:  
● Simulation using CFC charts 
● Simulation using I/O modules 
Simulation using CFC charts is set by default but can be easily changed in process mode. 

Requirements 
● The example project is in process mode. 
● The I/O modules are connected. 

Procedure 
1. Click the "..../ACT_SIM" block icon. 

The faceplate opens. 
2. Click the "COMMAND" list. 
3. Select the "Off" option in the dialog box, and click "OK". 
4. Close the faceplate 

This enables simulation using I/O modules. The circle in the block icon is now displayed 
as a gray circle. 
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10.7 How to specify the minimum fill level 
You have inserted a faceplate in the CFC_LI311 CFC chart that you can use to specify the 
minimum fill level that must be maintained during the drain operation. 

Requirement 
The example project is in process mode. 

Procedure 
1. Click the "..../DRAIN_MIN_LEV" block icon. 

The faceplate opens. 
2. Enter the required fill level. 
3. Click "OK". 
4. Close the faceplate. 

This defines the minimum fill level and this exact fill level will be maintained in the reactor 
at the next drain operation. 



 

PCS 7 - Getting Started - Part 2 
Getting Started, 09/2007, A5E00857270-02 203 

Performing the additional task 11
11.1 Overview of the configuration of reactor 2 

Duplication of parts of a plant 
In this sample project, the fastest way for you to configure the REAC2 part of the plant is to 
copy the entire REAC1 part of the plant and then conveniently modify the required 
parameters in the process object view. 
PCS 7 offers other possibilities for duplicating parts of a plant:  
● You quickly create new process tags from the created process tag types by editing the 

import/export file followed by an import procedure. 
● You use the created SFC type on all comparable parts of a plant. 
No extra work is required for the hardware configuration because both parts of the plant are 
controlled from the same CPU. Besides, no additional operator stations are required 
because you have a single-station system Also you have already assigned the symbolic 
names for the inputs and outputs during the hardware configuration. 
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11.2 How to configure the "REAC2" part of the plant 

Overview 
The basic procedure for configuring the REAC2 part of the plant is described in the following:  
● Copying the REAC1 part of the plant 
● Adjusting the parameters 

Requirements 
● The example project is open in SIMATIC Manager. 
● The process object view is activated 
● The "General" tab is activated. 

Procedure 
1. Select the "REAC1" hierarchy folder and copy it to the "Plant1" hierarchy folder. 

PCS 7 automatically assigns a new name "REAC1(1)". 
2. Rename the new folder to "REAC2". 
3. Rename the process tags in "Name" column on the "General" tab according to the plant 

overview (Page 17): 
– Chart GENERAL(1) to GENERAL2 
– Chart CFC_LI311(1) to CFC_LI321 
– Chart SFC_REAC1(1) to SFC_REAC2 
– Picture REAC1(1) to REAC2 
– etc. 

4. Change to the "Signals" tab. 
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5. Adapt the symbolic names for the inputs and outputs of the distributed I/O of reactor 2 in 
the "Signal" column: 
Replace the identifier "1" that stands for reactor 1 with the number "2", for example:  
– Change "NK311_copen" to "NK321_copen" 
– Change "TC311" to "TC321" 
– etc. 
As soon as you change a signal name, the relevant comment and absolute address are 
automatically updated. 
  

 

  Note 
Make sure to leave the symbolic names of the signals that apply both to Reactor 1 and 
Reactor 2 unchanged. In the sample project, these are the following names: 
• NR3x1_on 
• NP3x1_on 

  
6. Open the CFC_LI321 CFC chart and add the following textual interconnections for the 

"SIMREAC" chart: 
  

Block Input Textual interconnection 
BVALV_RMT1_2 CFC_NK114\VALVE.QOPENED 
BMOT_RMT1 CFC_NP111\MOTOR.QRUN 
ARMT1 CFC_FC111\INPUT_U.V 
BVALV_RMT2_2 CFC_NK118\VALVE.QOPENED 
BMOT_RMT2 CFC_NP112\MOTOR.QRUN 
ARMT2 CFC_FC112\INPUT_U.V 

SIMREAC 

BOUT CFC_NP321\MOTOR.QRUN 
  

 Note 
The BVALV_RMT1_1 and BVALV_RMT2_1 inputs do not have to be interconnected to the 
REAC2 part of the plant. 
The values of these inputs must be "0". 

 
  

 Note 
Interconnections to charts that are stored outside the copied hierarchy folder are deleted. All 
interconnections within the copied hierarchy folder are retained and will be automatically 
updated in the process object view after the charts have been renamed. 

 
  
7. Select Options > Optimize Run Sequence... from the menu. 
8. In the "The run sequence of the blocks will be changed and optimized according to the 

data flow....." message box, click "OK". 
All blocks are then arranged automatically in the correct run sequence. 

9. Close the CFC editor. 
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11.3 How to compile the changes 

Requirements 
● The example project is open in SIMATIC Manager. 
● The plant view is activated. 
● The CPU is in RUN_P.  

You can download changes without the CPU being in STOP. 
● WinCC Explorer is closed. 

Procedure 
1. Select the "color_gs_MP\color_gs_Prj" folder in the tree view, and select PLC > Compile 

and Download Objects from the menu. Make the settings according to the following 
figure: 

 
 

2. Select the "color_gs_Prj/[Name of your local PC station]/WinCC Application/OS(1)" object 
in the tree view and click "Edit". 



 Performing the additional task 
 11.3 How to compile the changes 

PCS 7 - Getting Started - Part 2 
Getting Started, 09/2007, A5E00857270-02 207 

3. In the "Select the data you want to compile and the scope of the compilation" step, select 
the "Changes" option. 

 
 

4. Select the "Charts" object in the tree view, and click the "Edit..." button. 
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5. In the "Compile Charts as Program" tab, select the "Changes only" option and click 
"Apply". 
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6. Change to the "S7 Download" tab, select the "Changes only" option and click "OK". 

 
 

7. Click "Start" to start the compilation and download. 
Once the download is completed, the textual interconnections in the SFC charts are 
made and all tag links are updated for reactor 2 in the process picture. 
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